5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C# Directory Reference

5113 C# Programming Manual
  • 5113 C#
5113 C# Directory Reference

Files

file | JY5113AITask.cs
file | JY5113AOTask.cs
file | JY5113CITask.cs
file | JY5113COTask.cs
file | JY5113DITask.cs
file | JY5113DOTask.cs
Generated by doxygen 1.9.1


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113AITask.cs File Reference

Classes

class | JY5113.JY5113AITask
JY5113 Analog Input Task. More...
class | JY5113.AIChannel
AI Channel parameter class More...
class | JY5113.AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | JY5113.AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | JY5113.AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | JY5113.AISampleClock
Sample clock configuration class More...
class | JY5113.AIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5113.AITrigger
AI Trigger class More...
class | JY5113.AIDigitalTrigger
AI Digital Trigger More...
class | JY5113.AIAnalogTrigger
AI Analog Trigger More...
class | JY5113.AIRecord
AI Record class More...
class | JY5113.AIAdvanced
AI Advance parameter More...
class | JY5113.DSMode
DS Mode Class Paraments More...
class | JY5113.AISync
Configure sync signal More...
class | JY5113.AISignalExport
AI Signal Export Class More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.AIBandWidth { JY5113._39KHz = JY5113Import.JY5113_AI_BandWidth_39K , JY5113._15KHz = JY5113Import.JY5113_AI_BandWidth_15K , JY5113._80KHz = JY5113Import.JY5113_AI_BandWidth_80K }
AI BandWidth More...
enum class | JY5113.AITriggerType { JY5113.Immediate = JY5113Import.JY5113_TriggerType_Immediately , JY5113.Digital = JY5113Import.JY5113_TriggerType_Digital , JY5113.Analog = JY5113Import.JY5113_TriggerType_Analog , JY5113.Soft = JY5113Import.JY5113_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | JY5113.AIDigitalTriggerEdge { JY5113.Rising = JY5113Import.JY5113_DigitalTriggerEdge_Rising , JY5113.Falling = JY5113Import.JY5113_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | JY5113.AIAnalogTriggerEdge { JY5113.Rising = JY5113Import.JY5113_AnalogTriggerEdge_Rising , JY5113.Falling = JY5113Import.JY5113_AnalogTriggerEdge_Falling }
AI Analog Trigger Edge More...
enum class | JY5113.AIAnalogWindowCondition { JY5113.Entering = JY5113Import.JY5113_AnalogWindowCondition_Entering , JY5113.Leaving = JY5113Import.JY5113_AnalogWindowCondition_Leaving }
AI Analog Window Trigger Condition More...
enum class | JY5113.AIAnalogTriggerComparator { JY5113.Edge , JY5113.Hysteresis , JY5113.Window }
AI Analog Trigger Comparator More...
enum class | JY5113.AIMode { JY5113.Single = JY5113Import.JY5113_AI_Single , JY5113.Finite = JY5113Import.JY5113_AI_Finite , JY5113.Continuous = JY5113Import.JY5113_AI_Continuous , JY5113.Record = 0x3 }
AIMode More...
enum class | JY5113.AITerminal { JY5113.RSE = JY5113Import.JY5113_AI_RSE , JY5113.Differential = JY5113Import.JY5113_AI_Diff }
AITerminal More...
enum class | JY5113.AISampleClockSource { JY5113.Internal = JY5113Import.JY5113_AI_InternalClock , JY5113.External = JY5113Import.JY5113_AI_ExternalClock }
AIClockSource Type More...
enum class JY5113.ClockTerminal {
JY5113.PFI0 = JY5113Import.JY5113_Clock_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_Clock_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_Clock_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_Clock_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_Clock_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_Clock_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_Clock_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_Clock_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_Clock_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_Clock_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_Clock_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_Clock_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_Clock_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_Clock_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_Clock_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_Clock_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_Clock_PXI_Trig_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_Clock_PXI_Trig_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_Clock_PXI_Trig_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_Clock_PXI_Trig_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_Clock_PXI_Trig_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_Clock_PXI_Trig_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_Clock_PXI_Trig_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_Clock_PXI_Trig_7 ,
JY5113.AI_SampleClock = JY5113Import.JY5113_Inter_AI_SampleClock , JY5113.AO_SampleClock = JY5113Import.JY5113_Inter_AO_SampleClock , JY5113.DI_SampleClock = JY5113Import.JY5113_Inter_DI_SampleClock , JY5113.DO_SampleClock = JY5113Import.JY5113_Inter_DO_SampleClock ,
JY5113.CI0_SampleClock = JY5113Import.JY5113_Inter_CI_0_SampleClock , JY5113.CI1_SampleClock = JY5113Import.JY5113_Inter_CI_1_SampleClock , JY5113.CI2_SampleClock = JY5113Import.JY5113_Inter_CI_2_SampleClock , JY5113.CI3_SampleClock = JY5113Import.JY5113_Inter_CI_3_SampleClock ,
JY5113.CO0_Output = JY5113Import.JY5113_Inter_CO_0_Output , JY5113.CO1_Output = JY5113Import.JY5113_Inter_CO_1_Output , JY5113.CO2_Output = JY5113Import.JY5113_Inter_CO_2_Output , JY5113.CO3_Output = JY5113Import.JY5113_Inter_CO_3_Output
}
External Sample Clock Terminal More...
enum class | JY5113.AITriggerMode { JY5113.Start = JY5113Import.JY5113_StartTrigger , JY5113.Reference =JY5113Import.JY5113_ReferenceTrigger }
AI Trigger Mode More...
enum class JY5113.AIAnalogTriggerSource {
JY5113.Channel_0 , JY5113.Channel_1 , JY5113.Channel_2 , JY5113.Channel_3 ,
JY5113.Channel_4 , JY5113.Channel_5 , JY5113.Channel_6 , JY5113.Channel_7 ,
JY5113.Channel_8 , JY5113.Channel_9 , JY5113.Channel_10 , JY5113.Channel_11 ,
JY5113.Channel_12 , JY5113.Channel_13 , JY5113.Channel_14 , JY5113.Channel_15 ,
JY5113.Channel_16 , JY5113.Channel_17 , JY5113.Channel_18 , JY5113.Channel_19 ,
JY5113.Channel_20 , JY5113.Channel_21 , JY5113.Channel_22 , JY5113.Channel_23 ,
JY5113.Channel_24 , JY5113.Channel_25 , JY5113.Channel_26 , JY5113.Channel_27 ,
JY5113.Channel_28 , JY5113.Channel_29 , JY5113.Channel_30 , JY5113.Channel_31 ,
JY5113.Channel_32 , JY5113.Channel_33 , JY5113.Channel_34 , JY5113.Channel_35 ,
JY5113.Channel_36 , JY5113.Channel_37 , JY5113.Channel_38 , JY5113.Channel_39 ,
JY5113.Channel_40 , JY5113.Channel_41 , JY5113.Channel_42 , JY5113.Channel_43 ,
JY5113.Channel_44 , JY5113.Channel_45 , JY5113.Channel_46 , JY5113.Channel_47 ,
JY5113.Channel_48 , JY5113.Channel_49 , JY5113.Channel_50 , JY5113.Channel_51 ,
JY5113.Channel_52 , JY5113.Channel_53 , JY5113.Channel_54 , JY5113.Channel_55 ,
JY5113.Channel_56 , JY5113.Channel_57 , JY5113.Channel_58 , JY5113.Channel_59 ,
JY5113.Channel_60 , JY5113.Channel_61 , JY5113.Channel_62 , JY5113.Channel_63
}
AI Analog Trigger Source More...
enum class JY5113.AIDigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig , JY5113.AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig ,
JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig , JY5113.CIO_2_StartTrig = JY5113Import.JY5113_CIO2_StartTrig , JY5113.CIO_3_StartTrig = JY5113Import.JY5113_CIO3_StartTrig ,
JY5113.CO0_Output = JY5113Import.JY5113_CO_0_Out , JY5113.CO1_Output = JY5113Import.JY5113_CO_1_Out , JY5113.CO2_Output = JY5113Import.JY5113_CO_2_Out , JY5113.CO3_Output = JY5113Import.JY5113_CO_3_Out
}
AI Digital Trigger Source More...
enum class | JY5113.FileFormat { JY5113.Bin }
Streaming file format More...
enum class | JY5113.RecordMode { JY5113.Finite , JY5113.Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | JY5113.SyncTopology { JY5113.Independent , JY5113.Master , JY5113.Slave }
Synchronization board configuration More...
enum class JY5113.SyncTriggerRouting {
JY5113.NONE = -1 , JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 ,
JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 , JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 ,
JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口) More...
enum class JY5113.SyncPulseRouting {
JY5113.NONE = -1 , JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 ,
JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 , JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 ,
JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号) More...
enum class | JY5113.AISignalExportSource { JY5113.StartTrig = JY5113Import.SignalSource_JY5113_AI_StartTrig , JY5113.ReferenceTrig = JY5113Import.SignalSource_JY5113_AI_ReferenceTrig , JY5113.SampleClock = JY5113Import.SignalSource_JY5113_AI_SampleClock }
AI Signal Export Source More...
enum class JY5113.SignalExportDestination {
JY5113.PFI0 = JY5113Import.SignalDestination_JY5113_PFI0 , JY5113.PFI1 = JY5113Import.SignalDestination_JY5113_PFI1 , JY5113.PFI2 = JY5113Import.SignalDestination_JY5113_PFI2 , JY5113.PFI3 = JY5113Import.SignalDestination_JY5113_PFI3 ,
JY5113.PFI4 = JY5113Import.SignalDestination_JY5113_PFI4 , JY5113.PFI5 = JY5113Import.SignalDestination_JY5113_PFI5 , JY5113.PFI6 = JY5113Import.SignalDestination_JY5113_PFI6 , JY5113.PFI7 = JY5113Import.SignalDestination_JY5113_PFI7 ,
JY5113.PFI8 = JY5113Import.SignalDestination_JY5113_PFI8 , JY5113.PFI9 = JY5113Import.SignalDestination_JY5113_PFI9 , JY5113.PFI10 = JY5113Import.SignalDestination_JY5113_PFI10 , JY5113.PFI11 = JY5113Import.SignalDestination_JY5113_PFI11 ,
JY5113.PFI12 = JY5113Import.SignalDestination_JY5113_PFI12 , JY5113.PFI13 = JY5113Import.SignalDestination_JY5113_PFI13 , JY5113.PFI14 = JY5113Import.SignalDestination_JY5113_PFI14 , JY5113.PFI15 = JY5113Import.SignalDestination_JY5113_PFI15 ,
JY5113.PXI_Trig0 = JY5113Import.SignalDestination_JY5113_PXITrig0 , JY5113.PXI_Trig1 = JY5113Import.SignalDestination_JY5113_PXITrig1 , JY5113.PXI_Trig2 = JY5113Import.SignalDestination_JY5113_PXITrig2 , JY5113.PXI_Trig3 = JY5113Import.SignalDestination_JY5113_PXITrig3 ,
JY5113.PXI_Trig4 = JY5113Import.SignalDestination_JY5113_PXITrig4 , JY5113.PXI_Trig5 = JY5113Import.SignalDestination_JY5113_PXITrig5 , JY5113.PXI_Trig6 = JY5113Import.SignalDestination_JY5113_PXITrig6 , JY5113.PXI_Trig7 = JY5113Import.SignalDestination_JY5113_PXITrig7
}
输出目的终端 More...


5113 C# Programming Manual: JY5113.JY5113AITask Class Reference

  • JY5113
  • JY5113AITask
Public Member Functions | Properties | List of all members
JY5113.JY5113AITask Class Reference

JY5113 Analog Input Task. More...

Public Member Functions

JY5113AITask (int slotNumber)
Constructor. More...
JY5113AITask (string boardName)
Constructor. More...
void | AddChannel (int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth._80KHz)
Add one channel More...
void | AddChannel (int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth._80KHz)
Add a group of channels. More...
void | AddChannel (int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth)
Add a set of channels, each with a different range (except terminal and bandwidth) More...
void | RemoveChannel (int chnId)
Delete the channel with the specified channel number. More...
void | ReadData (ref double[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel data by columns and store it in a data buffer. More...
void | ReadData (ref double[,] buf, int timeout=10000)
Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data. More...
void | ReadData (ref double[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadData (ref double[] buf, int timeout=10000)
Read the one channel data and store it in a data buffer. More...
void | ReadRawData (ref short[,] buf, int samplesPerChannel, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310 More...
void | ReadRawData (ref short[,] buf, int timeout=10000)
Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310 More...
void | ReadRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Read one or multi-channel raw data by columns and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int samplesPerChannel, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadRawData (ref short[] buf, int timeout=10000)
Read the one channel raw data and store it in a data buffer. More...
void | ReadSinglePoint (ref double readValue, int channel)
Read one sample for specified channel in register. More...
void | ReadSinglePoint (ref double[] readValues)
Read raw one sample for all channels in register . More...
void | GetRecordPreviewData (ref double[,] buf, int samplesPerChannel, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[,] buf, int timeout=1000)
Preview multi-channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int samplesPerChannel, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordPreviewData (ref double[] buf, int timeout=1000)
Preview one channel data when streaming is in progress. More...
void | GetRecordStatus (out double recordedLength, out bool recordDone)
Get the streaming status More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete More...
void | Start ()
Start AITask More...
void | SendSoftwareTrigger ()
Generate a software trigger signal generate a software trigger signal More...
void | Stop ()
Stop AI Task More...

Properties

JY5113Device | Device [get]
Device Handle More...
List< AIChannel > | Channels [get, set]
List of AI channels, 64 SE or 32 Different More...
AIMode | Mode [get, set]
AI acquisition mode，support Finite/Continuous/Record More...
double | SampleRate [get, set]
每个通道的采样率。每组通道最大采样率为1M 默认采样率= 100k 你可以读取这个属性来获得在当前配置中实际生效的采样率 More...
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AISampleClock | SampleClock [get, set]
AI Sample Clock Configuration More...
AITrigger | Trigger [get, set]
时钟沿。仅在外部时钟时有效。 More...
AIRecord | Record [get]
Data streaming Configuration More...
bool | DisableCalibration [get, set]
Disalble calibration More...
AISignalExport | SignalExport [get, set]
Export AI Signal Configuration More...
AIAdvanced | Advanced [get, set]
AI Advanced Configuration More...

Detailed Description

JY5113 Analog Input Task.

Constructor & Destructor Documentation

◆ JY5113AITask() [1/2]

JY5113.JY5113AITask.JY5113AITask ( int slotNumber )

Constructor.

Used to create an AI task by a slot number

Parameters
slotNumber Card slot number.

◆ JY5113AITask() [2/2]

JY5113.JY5113AITask.JY5113AITask ( string boardName )

Constructor.

Used to create an AI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/3]

void JY5113.JY5113AITask.AddChannel | ( | int | chnId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal.RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth._80KHz
 | ) |  |

Add one channel

Parameters
chnId | channel's physical number ，chnId=-1, add all channels,0 - 64
rangeLow | lower range limit for the channel，-10V,-5V,-2.5V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2.5V,default 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
bandWidth | AI Bandwidth ,default 80KHz

◆ AddChannel() [2/3]

void JY5113.JY5113AITask.AddChannel | ( | int[] | chnsId,
 |  | double | rangeLow = -10,
 |  | double | rangeHigh = 10,
 |  | AITerminal | terminalCfg = AITerminal.RSE,
 |  | AIBandWidth | bandWidth = AIBandWidth._80KHz
 | ) |  |

Add a group of channels.

Parameters
chnsId | a group of channel physical numbers,0 - 64
rangeLow | lower range limit for the channel，-10V,-5V,-2.5V,default -10
rangeHigh | higher range limit for the channel,10V,5V,2.5V,default 10
terminalCfg | terminal input mode configuration，RSE/Differential.Default RSE
bandWidth | AI Bandwidth ,default 80KHz

◆ AddChannel() [3/3]

void JY5113.JY5113AITask.AddChannel | ( | int[] | chnsId,
 |  | double[] | rangeLow,
 |  | double[] | rangeHigh,
 |  | AITerminal | terminalCfg,
 |  | AIBandWidth | bandWidth
 | ) |  |

Add a set of channels, each with a different range (except terminal and bandwidth)

Parameters
chnsId | A collection of physical channel numbers. The range is 0 to 63 for the RSE channel and 0 to 31 for the Differential channel.
rangeLow | Higher range limit for the channel: 10V, 5V, 2.5V (default: 10V)
rangeHigh | Higher range limit for the channel: 10V, 5V, 2.5V (default: 10V)
terminalCfg | Terminal input mode configuration: RSE or Differential (default: RSE)
bandWidth | AI Bandwidth:39K,15K，376K (default: 376KHz)

◆ GetRecordPreviewData() [1/4]

void JY5113.JY5113AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [2/4]

void JY5113.JY5113AITask.GetRecordPreviewData | ( | ref double | buf[,],
 |  | int | timeout = 1000
 | ) |  |

Preview multi-channel data when streaming is in progress.

Each column represents one channel.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms
Returns

◆ GetRecordPreviewData() [3/4]

void JY5113.JY5113AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ GetRecordPreviewData() [4/4]

void JY5113.JY5113AITask.GetRecordPreviewData | ( | ref double[] | buf,
 |  | int | timeout = 1000
 | ) |  |

Preview one channel data when streaming is in progress.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ GetRecordStatus()

void JY5113.JY5113AITask.GetRecordStatus | ( | out double | recordedLength,
 |  | out bool | recordDone
 | ) |  |

Get the streaming status

Parameters
recordedLength | Length of the streamed, unit s
recordDone | recordDone = false :streaming is not over.recordDone = true :streaming is over

◆ ReadData() [1/5]

void JY5113.JY5113AITask.ReadData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [2/5]

void JY5113.JY5113AITask.ReadData | ( | ref double | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [3/5]

void JY5113.JY5113AITask.ReadData | ( | ref double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel data by columns and store it in a data buffer,Each channel is represented by one column of data.

param name="buf">Data buffer

Parameters
timeout timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish

◆ ReadData() [4/5]

void JY5113.JY5113AITask.ReadData | ( | ref double[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadData() [5/5]

void JY5113.JY5113AITask.ReadData | ( | ref double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel data and store it in a data buffer.

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [1/5]

void JY5113.JY5113AITask.ReadRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read one or multi-channel raw data by columns and store it in a data buffer.

The buffer is pointed by C# data type IntPtr. PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310 Data Type is short PXIe/PCIe/USB-5321B、PXIe/PCIe/USB-5311B Data Type is int

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [2/5]

void JY5113.JY5113AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [3/5]

void JY5113.JY5113AITask.ReadRawData | ( | ref short | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Read the multi-channel raw data by columns and store it in a data buffer,Each channel is represented by one column of data Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [4/5]

void JY5113.JY5113AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms

◆ ReadRawData() [5/5]

void JY5113.JY5113AITask.ReadRawData | ( | ref short[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Read the one channel raw data and store it in a data buffer.

Support Device: PXIe/PCIe/USB-5321、PXIe/PCIe/USB-5311、PXIe/PCIe/USB-5113、PXIe/PCIe/USB-5310

Parameters
buf | Data buffer
timeout | timeout before generating error message, uint is ms

◆ ReadSinglePoint() [1/2]

void JY5113.JY5113AITask.ReadSinglePoint | ( | ref double | readValue,
 |  | int | channel
 | ) |  |

Read one sample for specified channel in register.

Available when Mode is AIMode.Single

Parameters
readValue | value read
channel | Specified channel numbers.

◆ ReadSinglePoint() [2/2]

void JY5113.JY5113AITask.ReadSinglePoint ( ref double[] readValues )

Read raw one sample for all channels in register .

Available when Mode is AIMode.Single

Parameters
readValues Values read. Array length >= Channels.Count.

◆ RemoveChannel()

void JY5113.JY5113AITask.RemoveChannel ( int chnId )

Delete the channel with the specified channel number.

chnId=- 1, all channels will be deleted

Parameters
chnId Channel number of the channel to be deleted

◆ SendSoftwareTrigger()

void JY5113.JY5113AITask.SendSoftwareTrigger ( )

Generate a software trigger signal generate a software trigger signal

Returns

◆ Start()

void JY5113.JY5113AITask.Start ( )

Start AITask

◆ Stop()

void JY5113.JY5113AITask.Stop ( )

Stop AI Task

◆ WaitUntilDone()

bool JY5113.JY5113AITask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate
Returns
True: task end, false: timeout

Property Documentation

◆ Advanced

AIAdvanced JY5113.JY5113AITask.Advanced
getset

AI Advanced Configuration

◆ AvailableSamples

ulong JY5113.JY5113AITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY5113.JY5113AITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<AIChannel> JY5113.JY5113AITask.Channels
getset

List of AI channels, 64 SE or 32 Different

◆ Device

JY5113Device JY5113.JY5113AITask.Device
get

Device Handle

◆ DisableCalibration

bool JY5113.JY5113AITask.DisableCalibration
getset

Disalble calibration

◆ Mode

AIMode JY5113.JY5113AITask.Mode
getset

AI acquisition mode，support Finite/Continuous/Record

◆ Record

AIRecord JY5113.JY5113AITask.Record
get

Data streaming Configuration

◆ SampleClock

AISampleClock JY5113.JY5113AITask.SampleClock
getset

AI Sample Clock Configuration

◆ SampleRate

double JY5113.JY5113AITask.SampleRate
getset

每个通道的采样率。每组通道最大采样率为1M 默认采样率= 100k 你可以读取这个属性来获得在当前配置中实际生效的采样率

◆ SamplesToAcquire

int JY5113.JY5113AITask.SamplesToAcquire
getset

Number of samples to be read per channel.

default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AISignalExport JY5113.JY5113AITask.SignalExport
getset

Export AI Signal Configuration

◆ TransferedSamples

ulong JY5113.JY5113AITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

◆ Trigger

AITrigger JY5113.JY5113AITask.Trigger
getset

时钟沿。仅在外部时钟时有效。

AI Trigger Configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIChannel Class Reference

  • AIChannel
Public Member Functions | Properties | List of all members
JY5113.AIChannel Class Reference

AI Channel parameter class More...

Public Member Functions

AIChannel (int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth)
Constructor to create an AIChnParam task object. More...

Properties

int | ChannelID [get]
AI channel ID. More...
double | RangeLow [get, set]
Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V More...
double | RangeHigh [get, set]
High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V More...
AITerminal | Terminal [get, set]
Configure AI terminal. More...
AIBandWidth | BandWidth [get, set]
AI BandWidth,default 50KHz. More...

Detailed Description

AI Channel parameter class

Constructor & Destructor Documentation

◆ AIChannel()

JY5113.AIChannel.AIChannel | ( | int | channelId,
 |  | double | rangeLow,
 |  | double | rangeHigh,
 |  | AITerminal | terminalCfg,
 |  | AIBandWidth | bandWidth
 | ) |  |

Constructor to create an AIChnParam task object.

Parameters
channelId | AI channel ID.
rangeLow | Low range limit an AI channel.
rangeHigh | High range limit an AI channel.
bandWidth | AI BandWidth.

Property Documentation

◆ BandWidth

AIBandWidth JY5113.AIChannel.BandWidth
getset

AI BandWidth,default 50KHz.

◆ ChannelID

int JY5113.AIChannel.ChannelID
get

AI channel ID.

◆ RangeHigh

double JY5113.AIChannel.RangeHigh
getset

High range limit an AI channel，10V,5V,2.5V，1V, 0.5V, 0.25V

◆ RangeLow

double JY5113.AIChannel.RangeLow
getset

Low range limit an AI channel，-10V,-5V,-2.5V，-1V, -0.5V, -0.25V

◆ Terminal

AITerminal JY5113.AIChannel.Terminal
getset

Configure AI terminal.

(RSE,Differential)

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIAnalogHysteresisComparator Class Reference

  • AIAnalogHysteresisComparator
Public Attributes | Properties | List of all members
JY5113.AIAnalogHysteresisComparator Class Reference

AI Analog Hysteresis Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...
double[] | HighThresholdMultiChannels = new double[32]
High Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Hysteresis Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5113.AIAnalogHysteresisComparator.HighThreshold

High Threshold

◆ HighThresholdMultiChannels

double [] JY5113.AIAnalogHysteresisComparator.HighThresholdMultiChannels = new double[32]

High Threshold

◆ LowThreshold

double JY5113.AIAnalogHysteresisComparator.LowThreshold

Low Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5113.AIAnalogHysteresisComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIAnalogWindowComparator Class Reference

  • AIAnalogWindowComparator
Public Attributes | Properties | List of all members
JY5113.AIAnalogWindowComparator Class Reference

AI Analog Window Comparatorr More...

Public Attributes

double | HighThreshold
High Threshold More...
double | LowThreshold
Low Threshold More...
double[] | HighThresholdMultiChannels = new double[32]
High Threshold, the thresholds order is consistent according to the order in which channels are add ed. More...

Properties

AIAnalogWindowCondition Condition [get, set]
AI Analog Window Condition More...

Detailed Description

AI Analog Window Comparatorr

Member Data Documentation

◆ HighThreshold

double JY5113.AIAnalogWindowComparator.HighThreshold

High Threshold

◆ HighThresholdMultiChannels

double [] JY5113.AIAnalogWindowComparator.HighThresholdMultiChannels = new double[32]

High Threshold, the thresholds order is consistent according to the order in which channels are add ed.

◆ LowThreshold

double JY5113.AIAnalogWindowComparator.LowThreshold

Low Threshold

Property Documentation

◆ Condition

AIAnalogWindowCondition JY5113.AIAnalogWindowComparator.Condition
getset

AI Analog Window Condition

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIAnalogEdgeComparator Class Reference

  • AIAnalogEdgeComparator
Public Attributes | Properties | List of all members
JY5113.AIAnalogEdgeComparator Class Reference

AI Analog Edge Comparator More...

Public Attributes

double Threshold
Threshold More...

Properties

AIAnalogTriggerEdge Slope [get, set]
AI Analog Trigger Edge More...

Detailed Description

AI Analog Edge Comparator

Member Data Documentation

◆ Threshold

double JY5113.AIAnalogEdgeComparator.Threshold

Threshold

Property Documentation

◆ Slope

AIAnalogTriggerEdge JY5113.AIAnalogEdgeComparator.Slope
getset

AI Analog Trigger Edge

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AISampleClock Class Reference

  • AISampleClock
Properties | List of all members
JY5113.AISampleClock Class Reference

Sample clock configuration class More...

Properties

AISampleClockSource | Source [get, set]
Clock Source. More...
AIExternalSampleClock | External [get, set]
External Sample Clock， Valid when Source is AISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

AIExternalSampleClock JY5113.AISampleClock.External
getset

External Sample Clock， Valid when Source is AISampleClockSource.External.

◆ Source

AISampleClockSource JY5113.AISampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AISampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIExternalSampleClock Class Reference

  • AIExternalSampleClock
Properties | List of all members
JY5113.AIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5113.AIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5113.AIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AITrigger Class Reference

  • AITrigger
Properties | List of all members
JY5113.AITrigger Class Reference

AI Trigger class More...

Properties

AITriggerType | Type [get, set]
AI Trigger Type,enum Analog/Digital/Immediate/Soft. More...
AITriggerMode | Mode [get, set]
AI Trigger Mode. More...
AIDigitalTrigger | Digital [get, set]
Digital Trigger Congfiguration. More...
AIAnalogTrigger | Analog [get, set]
AI Analog Trigger. More...
int | ReTriggerCount [get, set]
Number of repeat triggers. More...
uint | PreTriggerSamples [get, set]
AI pretrigger samples, must be less than or equal to JY5113AITask.SamplesToAcquire. More...

Detailed Description

AI Trigger class

Property Documentation

◆ Analog

AIAnalogTrigger JY5113.AITrigger.Analog
getset

AI Analog Trigger.

Valid when Type is AITriggerType.Analog.

◆ Digital

AIDigitalTrigger JY5113.AITrigger.Digital
getset

Digital Trigger Congfiguration.

Valid when Type is AITriggerType.Digital.

◆ Mode

AITriggerMode JY5113.AITrigger.Mode
getset

AI Trigger Mode.

enum Start/Reference. The default value is AITriggerMode.Start.

◆ PreTriggerSamples

uint JY5113.AITrigger.PreTriggerSamples
getset

AI pretrigger samples, must be less than or equal to JY5113AITask.SamplesToAcquire.

Valid when Mode is AITriggerMode.Reference.

◆ ReTriggerCount

int JY5113.AITrigger.ReTriggerCount
getset

Number of repeat triggers.

When 0 or 1 only trigger once, When -1 continuous retrigger until stop.

◆ Type

AITriggerType JY5113.AITrigger.Type
getset

AI Trigger Type,enum Analog/Digital/Immediate/Soft.

The default value is AITriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIDigitalTrigger Class Reference

  • AIDigitalTrigger
Properties | List of all members
JY5113.AIDigitalTrigger Class Reference

AI Digital Trigger More...

Properties

AIDigitalTriggerSource | Source [get, set]
AI Digital Trigger Source More...
AIDigitalTriggerEdge | Edge [get, set]
AI Digital Trigger Edge，Rising/Falling More...

Detailed Description

AI Digital Trigger

Property Documentation

◆ Edge

AIDigitalTriggerEdge JY5113.AIDigitalTrigger.Edge
getset

AI Digital Trigger Edge，Rising/Falling

◆ Source

AIDigitalTriggerSource JY5113.AIDigitalTrigger.Source
getset

AI Digital Trigger Source

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIAnalogTrigger Class Reference

  • AIAnalogTrigger
Public Member Functions | Properties | List of all members
JY5113.AIAnalogTrigger Class Reference

AI Analog Trigger More...

Public Member Functions

AIAnalogTrigger ()
Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v More...

Properties

AIAnalogTriggerSource | Source [get, set]
Analog Trigger source More...
AIAnalogTriggerComparator | Comparator [get, set]
AI Analog Trigger Comparator More...
AIAnalogEdgeComparator | Edge [get, set]
AI Analog Edge Comparator More...
AIAnalogHysteresisComparator | Hysteresis [get, set]
AI Analog Hysteresis Comparatorr More...
AIAnalogWindowComparator | Window [get, set]
AI Analog Window Comparatorr More...

Detailed Description

AI Analog Trigger

Constructor & Destructor Documentation

◆ AIAnalogTrigger()

JY5113.AIAnalogTrigger.AIAnalogTrigger ( )

Default simulation trigger parameters: Trigger source - external trigger channel Trigger condition – above high threshold Threshold value – -0.1v

Property Documentation

◆ Comparator

AIAnalogTriggerComparator JY5113.AIAnalogTrigger.Comparator
getset

AI Analog Trigger Comparator

◆ Edge

AIAnalogEdgeComparator JY5113.AIAnalogTrigger.Edge
getset

AI Analog Edge Comparator

◆ Hysteresis

AIAnalogHysteresisComparator JY5113.AIAnalogTrigger.Hysteresis
getset

AI Analog Hysteresis Comparatorr

◆ Source

AIAnalogTriggerSource JY5113.AIAnalogTrigger.Source
getset

Analog Trigger source

◆ Window

AIAnalogWindowComparator JY5113.AIAnalogTrigger.Window
getset

AI Analog Window Comparatorr

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIRecord Class Reference

  • AIRecord
Properties | List of all members
JY5113.AIRecord Class Reference

AI Record class More...

Properties

string | FilePath [get, set]
Path of streaming file,including filePath and filename More...
FileFormat | FileFormat [get]
Streaming file format More...
RecordMode | Mode [get, set]
Two stream mode from enum Finite/Infinite More...
double | Length [get, set]
User specified stream length in second. More...

Detailed Description

AI Record class

Property Documentation

◆ FileFormat

FileFormat JY5113.AIRecord.FileFormat
get

Streaming file format

◆ FilePath

string JY5113.AIRecord.FilePath
getset

Path of streaming file,including filePath and filename

◆ Length

double JY5113.AIRecord.Length
getset

User specified stream length in second.

Only valid in the Finite mode

◆ Mode

RecordMode JY5113.AIRecord.Mode
getset

Two stream mode from enum Finite/Infinite

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AIAdvanced Class Reference

  • AIAdvanced
Properties | List of all members
JY5113.AIAdvanced Class Reference

AI Advance parameter More...

Properties

double | ConvertRate [get, set]
the convert rate of ADC. More...
DSMode | DSMode [get, set]
DSMode Config More...

Detailed Description

AI Advance parameter

Property Documentation

◆ ConvertRate

double JY5113.AIAdvanced.ConvertRate
getset

the convert rate of ADC.

◆ DSMode

DSMode JY5113.AIAdvanced.DSMode
getset

DSMode Config

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.DSMode Class Reference

  • DSMode
Properties | List of all members
JY5113.DSMode Class Reference

DS Mode Class Paraments More...

Properties

bool Enable [get, set]
Enable DSMode More...

Detailed Description

DS Mode Class Paraments

Property Documentation

◆ Enable

bool JY5113.DSMode.Enable
getset

Enable DSMode

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AISync Class Reference

  • AISync
Properties | List of all members
JY5113.AISync Class Reference

Configure sync signal More...

Properties

SyncTopology | Topology [get, set]
Configure sync signal More...
SyncTriggerRouting | TriggerRouting [get, set]
trigger signal Routing, default routing PXITrig0 More...
SyncPulseRouting | PulseRouting [get, set]
Sync Pulse signal Routing, default routing PXITrig1 More...

Detailed Description

Configure sync signal

Property Documentation

◆ PulseRouting

SyncPulseRouting JY5113.AISync.PulseRouting
getset

Sync Pulse signal Routing, default routing PXITrig1

◆ Topology

SyncTopology JY5113.AISync.Topology
getset

Configure sync signal

◆ TriggerRouting

SyncTriggerRouting JY5113.AISync.TriggerRouting
getset

trigger signal Routing, default routing PXITrig0

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: JY5113.AISignalExport Class Reference

  • AISignalExport
Public Member Functions | List of all members
JY5113.AISignalExport Class Reference

AI Signal Export Class More...

Public Member Functions

void | Add (AISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.AISignalExport.Add | ( | AISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AI Signal Source
destination | Export Desination

◆ Clear()

void JY5113.AISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.AISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AITask.cs


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113AOTask.cs File Reference

Classes

class | JY5113.JY5113AOTask
JY5113 Analog Ouput Task More...
class | JY5113.AOChannel
AO Channel parameter class . More...
class | JY5113.AOSampleClock
AO Sample clock configuration class More...
class | JY5113.AOExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5113.AOTrigger
Constructor to create an AOTrigger task object. More...
class | JY5113.AODigitalTrigger
AO Digital trigger . More...
class | JY5113.AOSignalExport
AO Signal Export Class More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.AODigitalTriggerEdge { JY5113.Rising , JY5113.Falling }
AO Digital Trigger Edge More...
enum class JY5113.AODigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , JY5113.AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig , JY5113.CO_0_Out = JY5113Import.JY5113_CO_0_Out ,
JY5113.CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
AO Digital trigger source. More...
enum class | JY5113.OutputCompleteState { JY5113.Zero , JY5113.Hold }
Output Complete State More...
enum class | JY5113.AOMode { JY5113.Single = 3 , JY5113.Finite = 0 , JY5113.ContinuousNoWrapping = 2 , JY5113.ContinuousWrapping = 1 }
AOMode More...
enum class | JY5113.AOSampleClockSource { JY5113.Internal , JY5113.External }
AO Sample Clock Source More...
enum class | JY5113.AOSignalExportSource { JY5113.StartTrig = JY5113Import.SignalSource_JY5113_AO_StartTrig , JY5113.SampleClock = JY5113Import.SignalSource_JY5113_AO_SampleClock }
SourceSignal More...
enum class | JY5113.AOTriggerType { JY5113.Immediate = JY5113Import.JY5113_TriggerType_Immediately , JY5113.Digital = JY5113Import.JY5113_TriggerType_Digital , JY5113.Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...


5113 C# Programming Manual: JY5113.JY5113AOTask Class Reference

  • JY5113AOTask
Public Member Functions | Properties | List of all members
JY5113.JY5113AOTask Class Reference

JY5113 Analog Ouput Task More...

Public Member Functions

JY5113AOTask (int slotNum)
Constructor, Used to create an AO task by a slot number More...
JY5113AOTask (string boardName)
Constructor. More...
void | AddChannel (int chnId)
Add one channel. More...
void | AddChannel (int[] chnsId)
Add a group of channels. More...
void | RemoveChannel (int chnId)
Delete the specified channel number. More...
void | WriteData (double[,] buf, int timeout=10000)
Write multi-channel data to AO buffer, Each column represents one channel. More...
void | WriteData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel data. More...
void | WriteData (double[] buf, int timeout=10000)
Write one channel data to AO buffer. More...
void | WriteRawData (ushort[,] buf, int timeout=10000)
Write multi-channel raw data to AO buffer, Each column represents one channel. More...
void | WriteRawData (IntPtr buf, int samplesPerChannel, int timeout=10000)
Write to AO buffer one or multi-channel raw data. More...
void | WriteRawData (ushort[] buf, int timeout=10000)
Write one channel raw Data to AO buffer. More...
void | WriteSinglePoint (double[] writeValues)
write one sample to all channels in register . More...
void | WriteSinglePoint (double writeValue, int channel)
Write one sample to the specified channel in register.Available when Mode is AOMode.Single More...
void | WriteRawSinglePoint (ushort[] writeValues)
write one raw sample to all channels in register . More...
void | WriteRawSinglePoint (ushort writeValue, int channel)
Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
void | Start ()
Start AO task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop AO task . More...

Properties

List< AOChannel > | Channels [get, set]
List of AO channels,,support 4 channels More...
AOMode | Mode [get, set]
Mode of AO Task. More...
double | UpdateRate [get, set]
每个通道的更新速率。最大更新速率为每组2M 默认采样率= 1000000 你可以读取这个属性来获得在当前配置中实际生效的更新速率。 More...
int | SamplesToUpdate [get, set]
Number of samples to be read per channel. More...
int | BufLenInSamples [get]
每个通道的样本数量可以存储在缓冲区中 see cref="SamplesToUpdate"/>必须小于或等于此值。 More...
uint | AvaliableLenInSamples [get]
Number of output samples per channel that can be write in AO buffuer. More...
OutputCompleteState | CompleteState [get, set]
AO Output Complete State, Valid when Mode is NOT AOMode.Single. More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
AOSampleClock | SampleClock [get, set]
AI Sample Clock Configuration More...
AOTrigger | Trigger = new AOTrigger() [get, set]
AO Trigger Configuration. More...
bool | DisableCalibration [get, set]
Disalble calibration. More...
AOSignalExport | SignalExport [get, set]
Export AO Signal More...
JY5113Device | Device [get]
Device More...

Detailed Description

JY5113 Analog Ouput Task

Constructor & Destructor Documentation

◆ JY5113AOTask() [1/2]

JY5113.JY5113AOTask.JY5113AOTask ( int slotNum )

Constructor, Used to create an AO task by a slot number

Parameters
slotNum Card slot number.

◆ JY5113AOTask() [2/2]

JY5113.JY5113AOTask.JY5113AOTask ( string boardName )

Constructor.

Used to create an AO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5113.JY5113AOTask.AddChannel ( int chnId )

Add one channel.

Parameters
chnId channel's physical number ，chnId=-1, add all channels。（5510 5511 support 4 channels）（5515 5516 support 2 channels）

◆ AddChannel() [2/2]

void JY5113.JY5113AOTask.AddChannel ( int[] chnsId )

Add a group of channels.

Parameters
chnsId a group of channel physical numbers。（5510 5511 support 4 channels）（5515 5516 support 2 channels）

◆ RemoveChannel()

void JY5113.JY5113AOTask.RemoveChannel ( int chnId )

Delete the specified channel number.

If it is -1, delete all channels.

Parameters
chnId Specified channel ID.

◆ SendSoftwareTrigger()

void JY5113.JY5113AOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113.JY5113AOTask.Start ( )

Start AO task .

◆ Stop()

void JY5113.JY5113AOTask.Stop ( )

Stop AO task .

◆ WaitUntilDone()

bool JY5113.JY5113AOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is AOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5113.JY5113AOTask.WriteData | ( | double | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5113.JY5113AOTask.WriteData | ( | double[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | >timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5113.JY5113AOTask.WriteData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [1/3]

void JY5113.JY5113AOTask.WriteRawData | ( | IntPtr | buf,
 |  | int | samplesPerChannel,
 |  | int | timeout = 10000
 | ) |  |

Write to AO buffer one or multi-channel raw data.

The buffer is pointed by C# data type IntPtr.

Parameters
buf | data buffer.
samplesPerChannel | Number of samples per channel
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [2/3]

void JY5113.JY5113AOTask.WriteRawData | ( | ushort | buf[,],
 |  | int | timeout = 10000
 | ) |  |

Write multi-channel raw data to AO buffer, Each column represents one channel.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawData() [3/3]

void JY5113.JY5113AOTask.WriteRawData | ( | ushort[] | buf,
 |  | int | timeout = 10000
 | ) |  |

Write one channel raw Data to AO buffer.

Parameters
buf | AO buffer for data.
timeout | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteRawSinglePoint() [1/2]

void JY5113.JY5113AOTask.WriteRawSinglePoint | ( | ushort | writeValue,
 |  | int | channel
 | ) |  |

Write one raw sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteRawSinglePoint() [2/2]

void JY5113.JY5113AOTask.WriteRawSinglePoint ( ushort[] writeValues )

write one raw sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

◆ WriteSinglePoint() [1/2]

void JY5113.JY5113AOTask.WriteSinglePoint | ( | double | writeValue,
 |  | int | channel
 | ) |  |

Write one sample to the specified channel in register.Available when Mode is AOMode.Single

Parameters
writeValue | Write value.
channel | Specified channel.

◆ WriteSinglePoint() [2/2]

void JY5113.JY5113AOTask.WriteSinglePoint ( double[] writeValues )

write one sample to all channels in register .

Available when Mode is AOMode.Single

Parameters
writeValues Write values. Array length >= Channels.Count.

Property Documentation

◆ AvaliableLenInSamples

uint JY5113.JY5113AOTask.AvaliableLenInSamples
get

Number of output samples per channel that can be write in AO buffuer.

◆ BufLenInSamples

int JY5113.JY5113AOTask.BufLenInSamples
get

每个通道的样本数量可以存储在缓冲区中 see cref="SamplesToUpdate"/>必须小于或等于此值。

◆ Channels

List<AOChannel> JY5113.JY5113AOTask.Channels
getset

List of AO channels,,support 4 channels

◆ CompleteState

OutputCompleteState JY5113.JY5113AOTask.CompleteState
getset

AO Output Complete State, Valid when Mode is NOT AOMode.Single.

Default is Zero.

◆ Device

JY5113Device JY5113.JY5113AOTask.Device
get

Device

◆ DisableCalibration

bool JY5113.JY5113AOTask.DisableCalibration
getset

Disalble calibration.

◆ Mode

AOMode JY5113.JY5113AOTask.Mode
getset

Mode of AO Task.

Select AO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single.

◆ SampleClock

AOSampleClock JY5113.JY5113AOTask.SampleClock
getset

AI Sample Clock Configuration

◆ SamplesToUpdate

int JY5113.JY5113AOTask.SamplesToUpdate
getset

Number of samples to be read per channel.

default: 1000. Only valid when Mode is AIMode.Finite.

◆ SignalExport

AOSignalExport JY5113.JY5113AOTask.SignalExport
getset

Export AO Signal

◆ TransferedSamples

ulong JY5113.JY5113AOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT AOMode.Single.

◆ Trigger

AOTrigger JY5113.JY5113AOTask.Trigger = new AOTrigger()
getset

AO Trigger Configuration.

◆ UpdateRate

double JY5113.JY5113AOTask.UpdateRate
getset

每个通道的更新速率。最大更新速率为每组2M 默认采样率= 1000000 你可以读取这个属性来获得在当前配置中实际生效的更新速率。

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AOChannel Class Reference

  • AOChannel
Properties | List of all members
JY5113.AOChannel Class Reference

AO Channel parameter class . More...

Properties

int | ChannelID [get]
AO channel ID. More...
double | RangeLow [get, set]
Low range limit an AO channel. More...
double | RangeHigh [get, set]
High range limit an AO channel. More...

Detailed Description

AO Channel parameter class .

Property Documentation

◆ ChannelID

int JY5113.AOChannel.ChannelID
get

AO channel ID.

◆ RangeHigh

double JY5113.AOChannel.RangeHigh
getset

High range limit an AO channel.

◆ RangeLow

double JY5113.AOChannel.RangeLow
getset

Low range limit an AO channel.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AOSampleClock Class Reference

  • AOSampleClock
Properties | List of all members
JY5113.AOSampleClock Class Reference

AO Sample clock configuration class More...

Properties

AOSampleClockSource | Source [get, set]
Clock Source. More...
AOExternalSampleClock | External [get, set]
External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External. More...

Detailed Description

AO Sample clock configuration class

Property Documentation

◆ External

AOExternalSampleClock JY5113.AOSampleClock.External
getset

External Sample Clock Configuration,Valid when Source is AOSampleClockSource.External.

◆ Source

AOSampleClockSource JY5113.AOSampleClock.Source
getset

Clock Source.

enum Internal/External,The default value is AOSampleClockSource.Internal.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AOExternalSampleClock Class Reference

  • AOExternalSampleClock
Properties | List of all members
JY5113.AOExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5113.AOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5113.AOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AOTrigger Class Reference

  • AOTrigger
Properties | List of all members
JY5113.AOTrigger Class Reference

Constructor to create an AOTrigger task object. More...

Properties

AOTriggerType | Type [get, set]
AO trigger type. More...
AODigitalTrigger | Digital [get, set]
AO Digital Trigger. More...

Detailed Description

Constructor to create an AOTrigger task object.

Used to build AO Trigger

Property Documentation

◆ Digital

AODigitalTrigger JY5113.AOTrigger.Digital
getset

AO Digital Trigger.

Valid when Type is AOTriggerType.Digital.

◆ Type

AOTriggerType JY5113.AOTrigger.Type
getset

AO trigger type.

enum Immediate/Digital/Soft.The default value is AOTriggerType.Immediate.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AODigitalTrigger Class Reference

  • AODigitalTrigger
Properties | List of all members
JY5113.AODigitalTrigger Class Reference

AO Digital trigger . More...

Properties

AODigitalTriggerSource | Source [get, set]
AO Digital Trigger source. More...
AODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

AO Digital trigger .

Property Documentation

◆ Edge

AODigitalTriggerEdge JY5113.AODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

AODigitalTriggerSource JY5113.AODigitalTrigger.Source
getset

AO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: JY5113.AOSignalExport Class Reference

  • AOSignalExport
Public Member Functions | List of all members
JY5113.AOSignalExport Class Reference

AO Signal Export Class More...

Public Member Functions

void | Add (AOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (AOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

AO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | AO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.AOSignalExport.Add | ( | AOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | AO Signal Source
destination | Export Desination

◆ Clear()

void JY5113.AOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.AOSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113AOTask.cs


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113CITask.cs File Reference

Classes

class | JY5113.JY5113CITask
JY5113 Counter Input Task More...
class | JY5113.CISampleClock
CI Sample Clock class More...
class | JY5113.CIInternalSampleClock
CI Internal Sample Clock Configuration Class More...
class | JY5113.CIImplicitSampleClock
CI Implicit Sample Clock class More...
class | JY5113.CIExternalSampleClock
CI Implicit Sample Clock class More...
class | JY5113.CIExternalTimebase
class | JY5113.CITimebase
class | JY5113.EdgeCounting
Configure CI EdgeCounting. More...
class | JY5113.EdgeCountingOutEvent
Edge counting output event configuration class More...
class | JY5113.PauseTrigger
Pause trigger configuration class. More...
class | JY5113.FrequencyMeas
Configure CI Measure. More...
class | JY5113.PeriodMeas
Configure CI Measure. More...
class | JY5113.PulseMeas
Configure CI Measure. More...
class | JY5113.SemiPeriodMeas
Configure CI Measure. More...
class | JY5113.TwoEdgeSeparation
Configure CI Measure. More...
class | JY5113.QuadEncoder
Configure CI Measure. More...
class | JY5113.TwoPulseEncoder
Configure CI Measure. More...
class | JY5113.CITrigger
Constructor to create an CITrigger task object. More...
class | JY5113.CIDigitalTrigger
CI Digital trigger . More...
class | JY5113.CISignalExport
CI Signal Export Class More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.CountDirection { JY5113.Up = JY5113Import.JY5113_CI_Count_Up , JY5113.Down = JY5113Import.JY5113_CI_Count_Down , JY5113.External = JY5113Import.JY5113_CI_Count_External }
Counter direction. More...
enum class | JY5113.CIMode { JY5113.Single = 2 , JY5113.Finite = 0 , JY5113.Continuous = 1 }
CIMode More...
enum class JY5113.CIType {
JY5113.EdgeCounting , JY5113.Period , JY5113.Frequency , JY5113.Pulse ,
JY5113.SemiPeriod , JY5113.TwoEdgeSeparation , JY5113.QuadEncoder , JY5113.TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | JY5113.CISampleClockSource { JY5113.Implicit = JY5113Import.JY5113_CI_ImplicitClock , JY5113.Internal = JY5113Import.JY5113_CI_InternalClock , JY5113.External = JY5113Import.JY5113_CI_ExternalClock }
CI Sample Clock Source. More...
enum class | JY5113.EdgeType { JY5113.Rising , JY5113.Falling , JY5113.Any }
Edge Type More...
enum class | JY5113.CITimebaseSource { JY5113.Internal100MHz = 0 , JY5113.Internal5MHz = 1 , JY5113.Internal100kHz = 2 , JY5113.External = 3 }
enum class | JY5113.EdgeCntOunEvtIdleState { JY5113.LowLevel = 0 , JY5113.HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | JY5113.LevelPolarity { JY5113.LowLevel = 0 , JY5113.HighLevel = 1 , JY5113.None = 2 }
Level Polarity More...
enum class | JY5113.ValueReturnMode { JY5113.TwoValue , JY5113.OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | JY5113.QuadEncodingType { JY5113.X1 , JY5113.X2 , JY5113.X4 }
Quadrature Encoding Type More...
enum class | JY5113.CITriggerType { JY5113.Immediate = JY5113Import.JY5113_CIO_Immediately , JY5113.Digital = JY5113Import.JY5113_CIO_Digital , JY5113.Soft = JY5113Import.JY5113_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5113.CIDigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , JY5113.AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
JY5113.AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig
}
CI Digital trigger source. More...
enum class | JY5113.CIDigitalTriggerEdge { JY5113.Rising , JY5113.Falling }
CI Digital Trigger Edge More...
enum class JY5113.InputTerminal {
JY5113.PFI0 = JY5113Import.JY5113_PFI0_Input , JY5113.PFI1 = JY5113Import.JY5113_PFI1_Input , JY5113.PFI2 = JY5113Import.JY5113_PFI2_Input , JY5113.PFI3 = JY5113Import.JY5113_PFI3_Input ,
JY5113.PFI4 = JY5113Import.JY5113_PFI4_Input , JY5113.PFI5 = JY5113Import.JY5113_PFI5_Input , JY5113.PFI6 = JY5113Import.JY5113_PFI6_Input , JY5113.PFI7 = JY5113Import.JY5113_PFI7_Input ,
JY5113.PFI8 = JY5113Import.JY5113_PFI8_Input , JY5113.PFI9 = JY5113Import.JY5113_PFI9_Input , JY5113.PFI10 = JY5113Import.JY5113_PFI10_Input , JY5113.PFI11 = JY5113Import.JY5113_PFI11_Input ,
JY5113.PFI12 = JY5113Import.JY5113_PFI12_Input , JY5113.PFI13 = JY5113Import.JY5113_PFI13_Input , JY5113.PFI14 = JY5113Import.JY5113_PFI14_Input , JY5113.PFI15 = JY5113Import.JY5113_PFI15_Input ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_PXI_Trig0_Input , JY5113.PXI_Trig1 = JY5113Import.JY5113_PXI_Trig1_Input , JY5113.PXI_Trig2 = JY5113Import.JY5113_PXI_Trig2_Input , JY5113.PXI_Trig3 = JY5113Import.JY5113_PXI_Trig3_Input ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_PXI_Trig4_Input , JY5113.PXI_Trig5 = JY5113Import.JY5113_PXI_Trig5_Input , JY5113.PXI_Trig6 = JY5113Import.JY5113_PXI_Trig6_Input , JY5113.PXI_Trig7 = JY5113Import.JY5113_PXI_Trig7_Input ,
JY5113.AI_SampleClock = JY5113Import.JY5113_IN_AI_SampleClock , JY5113.AO_SampleClock = JY5113Import.JY5113_IN_AO_SampleClock , JY5113.DI_SampleClock = JY5113Import.JY5113_IN_DI_SampleClock , JY5113.DO_SampleClock = JY5113Import.JY5113_IN_DO_SampleClock ,
JY5113.CO_0_OutPut = JY5113Import.JY5113_IN_CO_0_Output , JY5113.CO_1_OutPut = JY5113Import.JY5113_IN_CO_1_Output , JY5113.CO_2_OutPut = JY5113Import.JY5113_IN_CO_2_Output , JY5113.CO_3_OutPut = JY5113Import.JY5113_IN_CO_3_Output ,
JY5113.Timebase_100MHz = JY5113Import.JY5113_IN_CIO_100MHz , JY5113.Timebase_5MHz = JY5113Import.JY5113_IN_CIO_5MHz , JY5113.Timebase_100kHz = JY5113Import.JY5113_IN_CIO_100kHz
}
输入终端 More...
enum class JY5113.IOTerminal {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerOut_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerOut_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerOut_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerOut_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerOut_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerOut_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerOut_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerOut_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerOut_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerOut_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerOut_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerOut_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerOut_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerOut_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerOut_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerOut_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_TriggerOut_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_TriggerOut_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_TriggerOut_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_TriggerOut_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_TriggerOut_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_TriggerOut_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_TriggerOut_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_TriggerOut_PXI_7 ,
JY5113.None = 24
}
IO终端=信号的目的地（共24个） More...
enum class | JY5113.CISignalExportSource { JY5113.StartTrig , JY5113.SampleClock }
SourceSignal More...


5113 C# Programming Manual: JY5113.JY5113CITask Class Reference

  • JY5113CITask
Public Member Functions | Properties | List of all members
JY5113.JY5113CITask Class Reference

JY5113 Counter Input Task More...

Public Member Functions

JY5113CITask (int slotNum, int channel)
Constructor. More...
JY5113CITask (string boardName, int channel)
Constructor. More...
void | Start ()
Start CI task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop CI task . More...
void | ReadSinglePoint (ref uint count)
Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder More...
void | ReadData (ref uint[] bufCount, int samplesToAcquire, int timeout=10000)
Read counter values from buffer. More...
void | ReadData (ref uint[] bufCount, int timeout=10000)
Read counter values from buffer. More...
void | ReadData (ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000)
Read frequency value or period value from buffer. More...
void | ReadData (ref double[] bufMeasurement, int timeout=10000)
Read frequency value or period value from buffer. More...
void | ReadSinglePoint (ref double measurement, int timeout=10000)
Read a signle frequency value or period value from register. More...
void | ReadSinglePoint (ref double measurement1, ref double measurement2, int timeout=10000)
Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register. More...
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer. More...
void | ReadData (ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000)
Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer. More...

Properties

CIType | Type [get, set]
CI Application types. More...
ulong | AvailableSamples [get]
Number of points per channel that can be read in the buffer . More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
CIMode | Mode [get, set]
CI Sampling mode，support Single/Finite/Continuous More...
CISampleClock | SampleClock [get, set]
Clock Source. More...
uint | SamplesToAcquire [get, set]
Number of samples to be read per channel.Only valid when Mode is CIMode.Finite. More...
EdgeCounting | EdgeCounting [get, set]
Edge Counting Configuration More...
FrequencyMeas | FrequencyMeas [get, set]
Frequency Measurement Configuration More...
PeriodMeas | PeriodMeas [get, set]
Period Measurement Configuration More...
SemiPeriodMeas | SemiPeriodMeas [get, set]
SemiPeriodMeas Measurement Configuration More...
PulseMeas | PulseMeas [get, set]
Pulse Measurement Configuration More...
TwoEdgeSeparation | TwoEdgeSeparation [get, set]
TwoEdgeSeparation More...
QuadEncoder | QuadEncoder [get, set]
QuadEncoder More...
TwoPulseEncoder | TwoPulseEncoder [get, set]
TwoPulseEncoder More...
CITrigger | Trigger = new CITrigger() [get, set]
CI Trigger Configuration. More...
CISignalExport | SignalExport [get, set]
Export CI Signal Configuration More...
JY5113Device | Device [get]
Device More...

Detailed Description

JY5113 Counter Input Task

Constructor & Destructor Documentation

◆ JY5113CITask() [1/2]

JY5113.JY5113CITask.JY5113CITask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CI task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel suppor0-1

◆ JY5113CITask() [2/2]

JY5113.JY5113CITask.JY5113CITask | ( | string | boardName,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an m task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ ReadData() [1/6]

void JY5113.JY5113CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read frequency value or period value from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [2/6]

void JY5113.JY5113CITask.ReadData | ( | ref double[] | bufMeasurement,
 |  | int | timeout = 10000
 | ) |  |

Read frequency value or period value from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.Frequency or CIType.Period.

Parameters
bufMeasurement | Buffer for reading data. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period in seconds when Type is CIType.Period.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [3/6]

void JY5113.JY5113CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5113CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [4/6]

void JY5113.JY5113CITask.ReadData | ( | ref double[] | bufMeasurement1,
 |  | ref double[] | bufMeasurement2,
 |  | int | timeout = 10000
 | ) |  |

Read a measurements of pulse's duration value, or two-edge separtion value (two results at a time) from buffer.

. Available when JY5113CITask.Mode is NOT CIMode.Single, Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
bufMeasurement1 | Buffer for reading data. Indicates high level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
bufMeasurement2 | Buffer for reading data. Indicates low level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [5/6]

void JY5113.JY5113CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | samplesToAcquire,
 |  | int | timeout = 10000
 | ) |  |

Read counter values from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
samplesToAcquire | The length of the data to be read.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadData() [6/6]

void JY5113.JY5113CITask.ReadData | ( | ref uint[] | bufCount,
 |  | int | timeout = 10000
 | ) |  |

Read counter values from buffer.

Available when JY5113CITask.Mode is NOT CIMode.Single, and Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
bufCount | Buffer for reading data.
timeout | Timeout (ms). Wait until valid data is read or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [1/3]

void JY5113.JY5113CITask.ReadSinglePoint | ( | ref double | measurement,
 |  | int | timeout = 10000
 | ) |  |

Read a signle frequency value or period value from register.

Valid when Type is CIType.Frequency or CIType.Period.

Parameters
measurement Measurement value. Indicates frequency in Hz when Type is CIType.Frequency; Indicates period is seconds when Type is CIType.Period.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [2/3]

void JY5113.JY5113CITask.ReadSinglePoint | ( | ref double | measurement1,
 |  | ref double | measurement2,
 |  | int | timeout = 10000
 | ) |  |

Read a signle measurement of pulse's duration value, or two-edge separtion value (two results at a time) from register.

Available when Type is CIType.Pulse or CIType.TwoEdgeSeparation.

Parameters
measurement1 | Measurement Value 1. Indicates low level duration in seconds when Type is CIType.Pulse；Indicates separation between the rising edge of the first signal and the rising edge of the second signal when Type is CIType.TwoEdgeSeparation.
measurement2 | Measurement Value 2. Indicates high level duration in seconds when Type is CIType.Pulse ；Indicates seperation between previous rising edge of the second signal and current rising edge of the first signal when Type is CIType.TwoEdgeSeparation.
timeout
Timeout (ms). Wait until the measurement is completed or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ ReadSinglePoint() [3/3]

void JY5113.JY5113CITask.ReadSinglePoint ( ref uint count )

Read a signle count value from register, Available when Type is CIType.EdgeCounting , CIType.QuadEncoder or CIType.TwoPulseEncoder

Parameters
count counter value。

◆ SendSoftwareTrigger()

void JY5113.JY5113CITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113.JY5113CITask.Start ( )

Start CI task .

◆ Stop()

void JY5113.JY5113CITask.Stop ( )

Stop CI task .

Property Documentation

◆ AvailableSamples

ulong JY5113.JY5113CITask.AvailableSamples
get

Number of points per channel that can be read in the buffer .

◆ Device

JY5113Device JY5113.JY5113CITask.Device
get

Device

◆ EdgeCounting

EdgeCounting JY5113.JY5113CITask.EdgeCounting
getset

Edge Counting Configuration

◆ FrequencyMeas

FrequencyMeas JY5113.JY5113CITask.FrequencyMeas
getset

Frequency Measurement Configuration

◆ Mode

CIMode JY5113.JY5113CITask.Mode
getset

CI Sampling mode，support Single/Finite/Continuous

◆ PeriodMeas

PeriodMeas JY5113.JY5113CITask.PeriodMeas
getset

Period Measurement Configuration

◆ PulseMeas

PulseMeas JY5113.JY5113CITask.PulseMeas
getset

Pulse Measurement Configuration

◆ QuadEncoder

QuadEncoder JY5113.JY5113CITask.QuadEncoder
getset

QuadEncoder

◆ SampleClock

CISampleClock JY5113.JY5113CITask.SampleClock
getset

Clock Source.

◆ SamplesToAcquire

uint JY5113.JY5113CITask.SamplesToAcquire
getset

Number of samples to be read per channel.Only valid when Mode is CIMode.Finite.

◆ SemiPeriodMeas

SemiPeriodMeas JY5113.JY5113CITask.SemiPeriodMeas
getset

SemiPeriodMeas Measurement Configuration

◆ SignalExport

CISignalExport JY5113.JY5113CITask.SignalExport
getset

Export CI Signal Configuration

◆ TransferedSamples

ulong JY5113.JY5113CITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT CIMode.Single.

◆ Trigger

CITrigger JY5113.JY5113CITask.Trigger = new CITrigger()
getset

CI Trigger Configuration.

◆ TwoEdgeSeparation

TwoEdgeSeparation JY5113.JY5113CITask.TwoEdgeSeparation
getset

TwoEdgeSeparation

◆ TwoPulseEncoder

TwoPulseEncoder JY5113.JY5113CITask.TwoPulseEncoder
getset

TwoPulseEncoder

◆ Type

CIType JY5113.JY5113CITask.Type
getset

CI Application types.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CISampleClock Class Reference

  • CISampleClock
Properties | List of all members
JY5113.CISampleClock Class Reference

CI Sample Clock class More...

Properties

CISampleClockSource | Source [get, set]
CI Sample Clock Source More...
CIExternalSampleClock | External [get, set]
CI External Sample Clock Configuration. More...
CIImplicitSampleClock | Implicit [get, set]
CI Implicit Sample Clock Configuration. More...
CIInternalSampleClock | Internal [get]
Internal Sample Clock Configuration. More...

Detailed Description

CI Sample Clock class

Property Documentation

◆ External

CIExternalSampleClock JY5113.CISampleClock.External
getset

CI External Sample Clock Configuration.

Valid when Source is CISampleClockSource.External.

◆ Implicit

CIImplicitSampleClock JY5113.CISampleClock.Implicit
getset

CI Implicit Sample Clock Configuration.

Valid when Source is CISampleClockSource.Implicit.

◆ Internal

CIInternalSampleClock JY5113.CISampleClock.Internal
get

Internal Sample Clock Configuration.

Valid when Source is CISampleClockSource.Internal.

◆ Source

CISampleClockSource JY5113.CISampleClock.Source
getset

CI Sample Clock Source

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CIInternalSampleClock Class Reference

  • CIInternalSampleClock
Properties | List of all members
JY5113.CIInternalSampleClock Class Reference

CI Internal Sample Clock Configuration Class More...

Properties

double | Rate [get, set]
The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz). More...
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data More...

Detailed Description

CI Internal Sample Clock Configuration Class

Property Documentation

◆ IgnoreFirstSampleClock

bool JY5113.CIInternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data

◆ Rate

double JY5113.CIInternalSampleClock.Rate
getset

The rate of the internal sample clock (sample rate) which is generated by dividing the internal clock (200MHz).

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CIImplicitSampleClock Class Reference

  • CIImplicitSampleClock
Properties | List of all members
JY5113.CIImplicitSampleClock Class Reference

CI Implicit Sample Clock class More...

Properties

double ExpectedRate [get, set]
Expected Rate of Implicit Sample Clock. More...

Detailed Description

CI Implicit Sample Clock class

Property Documentation

◆ ExpectedRate

double JY5113.CIImplicitSampleClock.ExpectedRate
getset

Expected Rate of Implicit Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CIExternalSampleClock Class Reference

  • CIExternalSampleClock
Properties | List of all members
JY5113.CIExternalSampleClock Class Reference

CI Implicit Sample Clock class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected Rate of External Sample Clock. More...
bool | IgnoreFirstSampleClock [get, set]
Ignore the first sample clock data More...

Detailed Description

CI Implicit Sample Clock class

Property Documentation

◆ ExpectedRate

double JY5113.CIExternalSampleClock.ExpectedRate
getset

Expected Rate of External Sample Clock.

Filling this parameter accurately would helps the driver to set a proper DDR write frequency internally.

◆ IgnoreFirstSampleClock

bool JY5113.CIExternalSampleClock.IgnoreFirstSampleClock
getset

Ignore the first sample clock data

◆ Terminal

ClockTerminal JY5113.CIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CIExternalTimebase Class Reference

  • CIExternalTimebase
Properties | List of all members
JY5113.CIExternalTimebase Class Reference

More...

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5113.CIExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5113.CIExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CITimebase Class Reference

  • CITimebase
Properties | List of all members
JY5113.CITimebase Class Reference

More...

Properties

CITimebaseSource | Source [get, set]
CIExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

CIExternalTimebase JY5113.CITimebase.External
getset

外部时基配置。当 CITimebase.Source 为 CITimebaseSource.External时有效。

External Timebase Configuration. Valid when CITimebase.Source is COTimebaseSource.External.

◆ Source

CITimebaseSource JY5113.CITimebase.Source
getset

时基源。默认值为 CITimebaseSource.Internal100MHz。

Timebase Source. The default value is CITimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.EdgeCounting Class Reference

  • EdgeCounting
Properties | List of all members
JY5113.EdgeCounting Class Reference

Configure CI EdgeCounting. More...

Properties

int | InitialCount [get, set]
Initial Count More...
CountDirection | Direction [get, set]
Counter direction. More...
EdgeType | ActiveEdge [get, set]
The avtive edge of the input signal, the counter will count up or down on this edge. More...
PauseTrigger | Pause [get, set]
Pause Trigger Configuration More...
EdgeCountingOutEvent | OutEvent [get, set]
Edge counting output event. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...
InputTerminal | DirTerminal [get, set]
Terminal of External Count Diretion Control. More...

Detailed Description

Configure CI EdgeCounting.

Property Documentation

◆ ActiveEdge

EdgeType JY5113.EdgeCounting.ActiveEdge
getset

The avtive edge of the input signal, the counter will count up or down on this edge.

◆ Direction

CountDirection JY5113.EdgeCounting.Direction
getset

Counter direction.

enum Up/Down/External

◆ DirTerminal

InputTerminal JY5113.EdgeCounting.DirTerminal
getset

Terminal of External Count Diretion Control.

Valid when Direction is CountDirection.External

◆ InitialCount

int JY5113.EdgeCounting.InitialCount
getset

Initial Count

◆ InputTerminal

InputTerminal JY5113.EdgeCounting.InputTerminal
getset

Input Terminal

◆ OutEvent

EdgeCountingOutEvent JY5113.EdgeCounting.OutEvent
getset

Edge counting output event.

A pulse will be generated when the count value reaches specified threshold

◆ Pause

PauseTrigger JY5113.EdgeCounting.Pause
getset

Pause Trigger Configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.EdgeCountingOutEvent Class Reference

  • EdgeCountingOutEvent
Properties | List of all members
JY5113.EdgeCountingOutEvent Class Reference

Edge counting output event configuration class More...

Properties

EdgeCntOunEvtIdleState | IdleState [get, set]
Output idle state when the event has not occurred. More...
uint | Threshold [get, set]
Comparison threshold. More...
IOTerminal | Terminal [get, set]
Terminal More...

Detailed Description

Edge counting output event configuration class

Property Documentation

◆ IdleState

EdgeCntOunEvtIdleState JY5113.EdgeCountingOutEvent.IdleState
getset

Output idle state when the event has not occurred.

The default value is EdgeCntOunEvtIdleState.LowLevel

◆ Terminal

IOTerminal JY5113.EdgeCountingOutEvent.Terminal
getset

Terminal

◆ Threshold

uint JY5113.EdgeCountingOutEvent.Threshold
getset

Comparison threshold.

The default value is 2^32-1

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.PauseTrigger Class Reference

  • PauseTrigger
Properties | List of all members
JY5113.PauseTrigger Class Reference

Pause trigger configuration class. More...

Properties

LevelPolarity | ActivePolarity [get, set]
Pause trigger active polarity. More...
InputTerminal | Terminal [get, set]
Terminal More...

Detailed Description

Pause trigger configuration class.

Property Documentation

◆ ActivePolarity

LevelPolarity JY5113.PauseTrigger.ActivePolarity
getset

Pause trigger active polarity.

The default value is LevelPolarity.None, means the pause trigger is disabled.

◆ Terminal

InputTerminal JY5113.PauseTrigger.Terminal
getset

Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.FrequencyMeas Class Reference

  • FrequencyMeas
Properties | List of all members
JY5113.FrequencyMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5113.FrequencyMeas.InputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5113.FrequencyMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.PeriodMeas Class Reference

  • PeriodMeas
Properties | List of all members
JY5113.PeriodMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5113.PeriodMeas.InputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5113.PeriodMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.PulseMeas Class Reference

  • PulseMeas
Properties | List of all members
JY5113.PulseMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5113.PulseMeas.InputTerminal
getset

Input Terminal

◆ StartingEdge

EdgeType JY5113.PulseMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5113.PulseMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.SemiPeriodMeas Class Reference

  • SemiPeriodMeas
Properties | List of all members
JY5113.SemiPeriodMeas Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
EdgeType | StartingEdge [get, set]
The start edge of the input signal, the counter will count up or down on this edge. More...
InputTerminal | InputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ InputTerminal

InputTerminal JY5113.SemiPeriodMeas.InputTerminal
getset

Input Terminal

◆ StartingEdge

EdgeType JY5113.SemiPeriodMeas.StartingEdge
getset

The start edge of the input signal, the counter will count up or down on this edge.

◆ Timebase

CITimebase JY5113.SemiPeriodMeas.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.TwoEdgeSeparation Class Reference

  • TwoEdgeSeparation
Properties | List of all members
JY5113.TwoEdgeSeparation Class Reference

Configure CI Measure. More...

Properties

CITimebase | Timebase [get, set]
Timebase configuration More...
InputTerminal | FirstInputTerminal [get, set]
Input Terminal More...
InputTerminal | SecondInputTerminal [get, set]
Input Terminal More...
ValueReturnMode | EdgeSeparationMode [get, set]

Detailed Description

Configure CI Measure.

Property Documentation

◆ EdgeSeparationMode

ValueReturnMode JY5113.TwoEdgeSeparation.EdgeSeparationMode
getset

数据返回模式

data return mode

◆ FirstInputTerminal

InputTerminal JY5113.TwoEdgeSeparation.FirstInputTerminal
getset

Input Terminal

◆ SecondInputTerminal

InputTerminal JY5113.TwoEdgeSeparation.SecondInputTerminal
getset

Input Terminal

◆ Timebase

CITimebase JY5113.TwoEdgeSeparation.Timebase
getset

Timebase configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.QuadEncoder Class Reference

  • QuadEncoder
Properties | List of all members
JY5113.QuadEncoder Class Reference

Configure CI Measure. More...

Properties

QuadEncodingType | EncodingType [get, set]
Type of Encoding More...
bool | ZReloadEnabled [get, set]
In Encoder mode ,the Z signal enable More...
int | InitialCount [get, set]
Initial Count More...
InputTerminal | AInputTerminal [get, set]
Input Terminal More...
InputTerminal | BInputTerminal [get, set]
Input Terminal More...
InputTerminal | ZInputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5113.QuadEncoder.AInputTerminal
getset

Input Terminal

◆ BInputTerminal

InputTerminal JY5113.QuadEncoder.BInputTerminal
getset

Input Terminal

◆ EncodingType

QuadEncodingType JY5113.QuadEncoder.EncodingType
getset

Type of Encoding

◆ InitialCount

int JY5113.QuadEncoder.InitialCount
getset

Initial Count

◆ ZInputTerminal

InputTerminal JY5113.QuadEncoder.ZInputTerminal
getset

Input Terminal

◆ ZReloadEnabled

bool JY5113.QuadEncoder.ZReloadEnabled
getset

In Encoder mode ,the Z signal enable

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.TwoPulseEncoder Class Reference

  • TwoPulseEncoder
Properties | List of all members
JY5113.TwoPulseEncoder Class Reference

Configure CI Measure. More...

Properties

int | InitialCount [get, set]
Initial Count More...
InputTerminal | AInputTerminal [get, set]
Input Terminal More...
InputTerminal | BInputTerminal [get, set]
Input Terminal More...

Detailed Description

Configure CI Measure.

Property Documentation

◆ AInputTerminal

InputTerminal JY5113.TwoPulseEncoder.AInputTerminal
getset

Input Terminal

◆ BInputTerminal

InputTerminal JY5113.TwoPulseEncoder.BInputTerminal
getset

Input Terminal

◆ InitialCount

int JY5113.TwoPulseEncoder.InitialCount
getset

Initial Count

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CITrigger Class Reference

  • CITrigger
Properties | List of all members
JY5113.CITrigger Class Reference

Constructor to create an CITrigger task object. More...

Properties

CITriggerType | Type [get, set]
CI trigger type. More...
CIDigitalTrigger | Digital [get, set]
CI Digital Trigger. More...

Detailed Description

Constructor to create an CITrigger task object.

Used to build CI Trigger

Property Documentation

◆ Digital

CIDigitalTrigger JY5113.CITrigger.Digital
getset

CI Digital Trigger.

Valid when Type is CITriggerType.Digital

◆ Type

CITriggerType JY5113.CITrigger.Type
getset

CI trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CIDigitalTrigger Class Reference

  • CIDigitalTrigger
Properties | List of all members
JY5113.CIDigitalTrigger Class Reference

CI Digital trigger . More...

Properties

CIDigitalTriggerSource | Source [get, set]
CI Digital Trigger source. More...
CIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

CI Digital trigger .

Property Documentation

◆ Edge

CIDigitalTriggerEdge JY5113.CIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CIDigitalTriggerSource JY5113.CIDigitalTrigger.Source
getset

CI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: JY5113.CISignalExport Class Reference

  • CISignalExport
Public Member Functions | List of all members
JY5113.CISignalExport Class Reference

CI Signal Export Class More...

Public Member Functions

void | Add (CISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (CISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.CISignalExport.Add | ( | CISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CI Signal Source
destination | Export Desination

◆ Clear()

void JY5113.CISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.CISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113CITask.cs


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113COTask.cs File Reference

Classes

class | JY5113.JY5113COTask
JY5113 Counter Output Task More...
class | JY5113.COTrigger
Constructor to create an COTrigger task object. More...
class | JY5113.CODigitalTrigger
CO Digital trigger . More...
class | JY5113.COPulse
Pulse Parameter More...
class | JY5113.COExternalTimebase
class | JY5113.COTimebase
class | JY5113.COSignalExport
CO Signal Export Class More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.COIdleState { JY5113.HighLevel = JY5113Import.JY5113_HighLevel , JY5113.LowLevel = JY5113Import.JY5113_LowLevel }
Idle state when pulse output before start and after stop. More...
enum class | JY5113.COMode { JY5113.Single = 3 , JY5113.Finite = 0 , JY5113.ContinuousNoWrapping = 2 , JY5113.ContinuousWrapping = 1 }
CO output mode More...
enum class | JY5113.COTriggerType { JY5113.Immediate = JY5113Import.JY5113_CIO_Immediately , JY5113.Digital = JY5113Import.JY5113_CIO_Digital , JY5113.Soft = JY5113Import.JY5113_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5113.CODigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , JY5113.AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
JY5113.AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
JY5113.CO_0_Out = JY5113Import.JY5113_CO_0_Out , JY5113.CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
CO Digital trigger source. More...
enum class | JY5113.CODigitalTriggerEdge { JY5113.Rising , JY5113.Falling }
CO Digital Trigger Edge More...
enum class | JY5113.COPulseType { JY5113.DutyCycleFrequency , JY5113.HighLowTime , JY5113.HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | JY5113.COTimebaseSource { JY5113.Internal100MHz = 0 , JY5113.Internal5MHz = 1 , JY5113.Internal100kHz = 2 , JY5113.External = 3 }
enum class | JY5113.COSignalExportSource { JY5113.StartTrig , JY5113.Output }
SourceSignal More...


5113 C# Programming Manual: JY5113.JY5113COTask Class Reference

  • JY5113COTask
Public Member Functions | Properties | List of all members
JY5113.JY5113COTask Class Reference

JY5113 Counter Output Task More...

Public Member Functions

JY5113COTask (int slotNum, int channel)
Constructor. More...
JY5113COTask (string boardName, int channel)
Constructor. More...
void | WriteSinglePoint (COPulse pulse)
Write a single pulse parameter to the register. More...
void | WriteData (COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000)
Write pulse parameters to be output to the buffer. More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Start ()
Start CO task . More...
void | Stop ()
Stop COtask . More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...

Properties

COMode | Mode [get, set]
CO output mode More...
IOTerminal | OutputTerminal [get, set]
PauseTrigger | Pause [get, set]
COTimebase | Timebase [get, set]
CO's time base. More...
double | InitialDelay [get, set]
Counter output initial delay in seconds. More...
COIdleState | IdleState [get, set]
Idle state when pulse output before start and after stop. More...
uint | SamplesToUpdate [get, set]
有限频率输出 More...
uint | AvaliableLenInSamples [get]
本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数） More...
ulong | TransferedSamples [get]
uint | TransferedPulses [get]
COTrigger | Trigger = new COTrigger() [get, set]
CO trigger property configured by CO Trigger(). More...
JY5113Device | Device [get]
Device More...
COSignalExport | SignalExport [get, set]
Export CO Signal Configuration More...

Detailed Description

JY5113 Counter Output Task

Constructor & Destructor Documentation

◆ JY5113COTask() [1/2]

JY5113.JY5113COTask.JY5113COTask | ( | int | slotNum,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CO task by a slot number.

Parameters
slotNum | Card slot number.
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

◆ JY5113COTask() [2/2]

JY5113.JY5113COTask.JY5113COTask | ( | string | boardName,
 |  | int | channel
 | ) |  |

Constructor.

Used to create an CO task by a board name.

Parameters
boardName | Board name(device alias), set by device manager
channel | Counter channel （5510 5511 support0-3,5515 5516 suppor0-1）.

Member Function Documentation

◆ SendSoftwareTrigger()

void JY5113.JY5113COTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113.JY5113COTask.Start ( )

Start CO task .

◆ Stop()

void JY5113.JY5113COTask.Stop ( )

Stop COtask .

◆ WaitUntilDone()

bool JY5113.JY5113COTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData()

void JY5113.JY5113COTask.WriteData | ( | COPulse[] | pulsesGroup,
 |  | int | samplesToWrite,
 |  | int | timeout = 10000
 | ) |  |

Write pulse parameters to be output to the buffer.

Valid when Mode is NOT COMode.Single. When Mode is COMode.Finite or COMode.ContinuousWrapping, this function can only be called once before starting the task.

Parameters
pulsesGroup | A group of pulse parameters
samplesToWrite | Number of samples to write. If Mode is COMode.ContinuousWrapping, you need to write at least 2 samples before starting the task
timeout | Timeout (ms). Wait until all data is written to buffer or timed out. If it times out, a timeout exception will be thrown. When the value is -1, it never times out.

◆ WriteSinglePoint()

void JY5113.JY5113COTask.WriteSinglePoint ( COPulse pulse )

Write a single pulse parameter to the register.

Valid when Mode is COMode.Single. This function is also available after starting the task when the number of pulses being sent is infinite.

Parameters
pulse Pulse Parameter

Property Documentation

◆ AvaliableLenInSamples

uint JY5113.JY5113COTask.AvaliableLenInSamples
get

本地缓冲区当前可容纳的样点数（当前每通道可写入缓冲区的样点数）

◆ Device

JY5113Device JY5113.JY5113COTask.Device
get

Device

◆ IdleState

COIdleState JY5113.JY5113COTask.IdleState
getset

Idle state when pulse output before start and after stop.

◆ InitialDelay

double JY5113.JY5113COTask.InitialDelay
getset

Counter output initial delay in seconds.

There are five ticks of the timebase fixed delay in counter internal, so the total delay(s) = InitialDelay + (5 / timebase)

◆ Mode

COMode JY5113.JY5113COTask.Mode
getset

CO output mode

◆ OutputTerminal

IOTerminal JY5113.JY5113COTask.OutputTerminal
getset

脉冲输出端口

Pulse Output Terminal

◆ Pause

PauseTrigger JY5113.JY5113COTask.Pause
getset

暂停触发配置

Pause Trigger Configuration

◆ SamplesToUpdate

uint JY5113.JY5113COTask.SamplesToUpdate
getset

有限频率输出

◆ SignalExport

COSignalExport JY5113.JY5113COTask.SignalExport
getset

Export CO Signal Configuration

◆ Timebase

COTimebase JY5113.JY5113COTask.Timebase
getset

CO's time base.

◆ TransferedPulses

uint JY5113.JY5113COTask.TransferedPulses
get

当前配置下已发送的脉冲的数量。

The number of pulses transfered under the current configuration.

◆ TransferedSamples

ulong JY5113.JY5113COTask.TransferedSamples
get

已从本地缓冲区传出的样点数（每通道），当 Mode 不为 COMode.Single 时有效。

The number of samples that have been transfered from the local buffer (per channel). Valid when Mode is NOT COMode.Single.

◆ Trigger

COTrigger JY5113.JY5113COTask.Trigger = new COTrigger()
getset

CO trigger property configured by CO Trigger().

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.COTrigger Class Reference

  • COTrigger
Properties | List of all members
JY5113.COTrigger Class Reference

Constructor to create an COTrigger task object. More...

Properties

COTriggerType | Type [get, set]
CO trigger type. More...
CODigitalTrigger | Digital [get, set]
CO Digital Trigger. More...

Detailed Description

Constructor to create an COTrigger task object.

Used to build CO Trigger

Property Documentation

◆ Digital

CODigitalTrigger JY5113.COTrigger.Digital
getset

CO Digital Trigger.

Valid when Type is COTriggerType.Digital

◆ Type

COTriggerType JY5113.COTrigger.Type
getset

CO trigger type.

enum Immediate/Digital/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.CODigitalTrigger Class Reference

  • CODigitalTrigger
Properties | List of all members
JY5113.CODigitalTrigger Class Reference

CO Digital trigger . More...

Properties

CODigitalTriggerSource | Source [get, set]
CO Digital Trigger source. More...
CODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

CO Digital trigger .

Property Documentation

◆ Edge

CODigitalTriggerEdge JY5113.CODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

CODigitalTriggerSource JY5113.CODigitalTrigger.Source
getset

CO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.COPulse Class Reference

  • COPulse
Public Member Functions | List of all members
JY5113.COPulse Class Reference

Pulse Parameter More...

Public Member Functions

COPulse (COPulseType type, double param1, double param2, int count)
Pulse Parameter More...

Detailed Description

Pulse Parameter

Constructor & Destructor Documentation

◆ COPulse()

JY5113.COPulse.COPulse | ( | COPulseType | type,
 |  | double | param1,
 |  | double | param2,
 |  | int | count
 | ) |  |

Pulse Parameter

Parameters
type | The pulse type characteristics.
param1 | Parameter 1. Frequency (Hz) when constructed as COPulseType.DutyCycleFrequency; High duration in seconds when constructed as COPulseType.HighLowTime; High ticks of the clock when constructed as COPulseType.HighLowTick.
param2 | Parameter 1. Duty cycle (greater than 0 and less than 1) when constructed as COPulseType.DutyCycleFrequency; Low duration in seconds when constructed as COPulseType.HighLowTime; Low ticks of the clock when constructed as COPulseType.HighLowTick.
count | Number of pulses. When the value is -1 (indicating that the number of pulses is infinite), pulses will be continuously sent until requested to stop.
The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.COExternalTimebase Class Reference

  • COExternalTimebase
Properties | List of all members
JY5113.COExternalTimebase Class Reference

More...

Properties

InputTerminal | Terminal [get, set]
double | Frequency [get, set]

Detailed Description

外部时基配置类

External timebase configuration class

Property Documentation

◆ Frequency

double JY5113.COExternalTimebase.Frequency
getset

外部时基的频率

Frequency of The External Timebase

◆ Terminal

InputTerminal JY5113.COExternalTimebase.Terminal
getset

外部时基的输入端口

External Timebase Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.COTimebase Class Reference

  • COTimebase
Properties | List of all members
JY5113.COTimebase Class Reference

More...

Properties

COTimebaseSource | Source [get, set]
COExternalTimebase | External [get, set]

Detailed Description

时基配置类

Timebase configuration class

Property Documentation

◆ External

COExternalTimebase JY5113.COTimebase.External
getset

外部时基配置。当 COTimebase.Source 为 COTimebaseSource.External时有效。

External Timebase Configuration. Valid when COTimebase.Source is COTimebaseSource.External.

◆ Source

COTimebaseSource JY5113.COTimebase.Source
getset

时基源。默认值为 COTimebaseSource.Internal100MHz。

Timebase Source. The default value is COTimebaseSource.Internal100MHz.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: JY5113.COSignalExport Class Reference

  • COSignalExport
Public Member Functions | List of all members
JY5113.COSignalExport Class Reference

CO Signal Export Class More...

Public Member Functions

void | Add (COSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (COSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

CO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | CO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.COSignalExport.Add | ( | COSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | CO Signal Source
destination | Export Desination

◆ Clear()

void JY5113.COSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.COSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113COTask.cs


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113DITask.cs File Reference

Classes

class | JY5113.JY5113DITask
JY5113 Digital Iuput Task More...
class | JY5113.DIChannel
DI Channel parameter class . More...
class | JY5113.DISampleClock
Sample clock configuration class More...
class | JY5113.DIExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5113.DISignalExport
DI Signal Export Class More...
class | JY5113.DITrigger
Constructor to create an DITrigger task object. More...
class | JY5113.DIDigitalTrigger
DI Digital trigger . More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.DISampleClockSource { JY5113.Internal , JY5113.External }
DI Sample Clock Source More...
enum class | JY5113.DIMode { JY5113.Single = 2 , JY5113.Finite = 0 , JY5113.Continuous = 1 }
DIMode More...
enum class | JY5113.DISignalExportSource { JY5113.StartTrig = JY5113Import.SignalSource_JY5113_DI_StartTrig , JY5113.ReferenceTrig = JY5113Import.SignalSource_JY5113_DI_ReferenceTrig , JY5113.SampleClock = JY5113Import.SignalSource_JY5113_DI_SampleClock }
SourceSignal More...
enum class | JY5113.DITriggerMode { JY5113.Start , JY5113.Reference }
DI Trigger Mode More...
enum class | JY5113.DITriggerType { JY5113.Immediate = JY5113Import.JY5113_TriggerType_Immediately , JY5113.Digital = JY5113Import.JY5113_TriggerType_Digital , JY5113.Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class JY5113.DIDigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , JY5113.AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
JY5113.AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
JY5113.CO_0_Out = JY5113Import.JY5113_CO_0_Out , JY5113.CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
DI Digital trigger source. More...
enum class | JY5113.DIDigitalTriggerEdge { JY5113.Rising , JY5113.Falling }
DI Digital Trigger Edge More...


5113 C# Programming Manual: JY5113.JY5113DITask Class Reference

  • JY5113DITask
Public Member Functions | Properties | List of all members
JY5113.JY5113DITask Class Reference

JY5113 Digital Iuput Task More...

Public Member Functions

JY5113DITask (int slotNum)
Constructor. More...
JY5113DITask (string boardName)
Constructor. More...
void | AddChannel (int lineNum)
Add one line More...
void | AddChannel (int[] linesNum)
Add a group of channel. More...
void | RemoveChannel (int lineNum)
Delete the specified port number .If it is -1, delete all ports. More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Start ()
Start DI task . More...
void | Stop ()
Stop DI task . More...
void | ReadSinglePoint (ref bool readValue, int line)
Read one sample for specified channel in register. More...
void | ReadSinglePoint (ref bool[] readValues)
Read one sample for all ports in register . More...
void | ReadData (ref short[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read the short data from one line. More...
void | ReadData (ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read Data More...
void | ReadData (ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000)
Read Data More...

Properties

List< DIChannel > | Channels [get]
List of DI channels,16 Line More...
DIMode | Mode [get, set]
DI acquisition mode，support Single/ Finite/Continuous More...
double | SampleRate [get, set]
Sample rate per channel. More...
int | SamplesToAcquire [get, set]
Number of samples to be read per channel. More...
DISampleClock | SampleClock [get, set]
DI Sample Clock Configuration More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value. More...
ulong | AvailableSamples [get]
Number of samples per channel that can be read in the buffer More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
DITrigger | Trigger [get, set]
DI Trigger Configuration More...
DISignalExport | SignalExport [get, set]
Export DI Signal More...
JY5113Device | Device [get]
Device More...

Detailed Description

JY5113 Digital Iuput Task

Constructor & Destructor Documentation

◆ JY5113DITask() [1/2]

JY5113.JY5113DITask.JY5113DITask ( int slotNum )

Constructor.

Used to create an DItask by a slot number.

Parameters
slotNum Card slot number.

◆ JY5113DITask() [2/2]

JY5113.JY5113DITask.JY5113DITask ( string boardName )

Constructor.

Used to create an DI task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5113.JY5113DITask.AddChannel ( int lineNum )

Add one line

Parameters
lineNum
Exceptions
JYDriverException

◆ AddChannel() [2/2]

void JY5113.JY5113DITask.AddChannel ( int[] linesNum )

Add a group of channel.

Parameters
linesNum an array of line numbers of added ports.

◆ ReadData() [1/3]

void JY5113.JY5113DITask.ReadData | ( | ref byte | dataBuffer[,],
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read Data

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [2/3]

void JY5113.JY5113DITask.ReadData | ( | ref byte[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read Data

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per line to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadData() [3/3]

void JY5113.JY5113DITask.ReadData | ( | ref short[] | dataBuffer,
 |  | uint | samplesToAcquire,
 |  | int | timeOut = 10000
 | ) |  |

Read the short data from one line.

Parameters
dataBuffer | Data buffer
samplesToAcquire | Number of samples per port to be read
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ ReadSinglePoint() [1/2]

void JY5113.JY5113DITask.ReadSinglePoint | ( | ref bool | readValue,
 |  | int | line
 | ) |  |

Read one sample for specified channel in register.

Available when Mode is DIMode.Single

Parameters
readValue | values read,. Buffer size >= 8
line | Each line is independently controlled. You can directly obtain the corresponding status based on the input of the corresponding line number

◆ ReadSinglePoint() [2/2]

void JY5113.JY5113DITask.ReadSinglePoint ( ref bool[] readValues )

Read one sample for all ports in register .

Available when Mode is DIMode.Single

Parameters
readValues Values read. Buffer size >= number of ports * 16.

◆ RemoveChannel()

void JY5113.JY5113DITask.RemoveChannel ( int lineNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5113.JY5113DITask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113.JY5113DITask.Start ( )

Start DI task .

◆ Stop()

void JY5113.JY5113DITask.Stop ( )

Stop DI task .

Property Documentation

◆ AvailableSamples

ulong JY5113.JY5113DITask.AvailableSamples
get

Number of samples per channel that can be read in the buffer

◆ BufLenInSamples

int JY5113.JY5113DITask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the Proprety SamplesToAcquire must be less than or equal to this value.

◆ Channels

List<DIChannel> JY5113.JY5113DITask.Channels
get

List of DI channels,16 Line

◆ Device

JY5113Device JY5113.JY5113DITask.Device
get

Device

◆ Mode

DIMode JY5113.JY5113DITask.Mode
getset

DI acquisition mode，support Single/ Finite/Continuous

◆ SampleClock

DISampleClock JY5113.JY5113DITask.SampleClock
getset

DI Sample Clock Configuration

◆ SampleRate

double JY5113.JY5113DITask.SampleRate
getset

Sample rate per channel.

Maximum sample rate is 10M The defalut sample rate = 10k You can read this property to obtain the sample rate that will actually take effect in the current configuration.

◆ SamplesToAcquire

int JY5113.JY5113DITask.SamplesToAcquire
getset

Number of samples to be read per channel.

Only valid when Mode is DIMode.Finite.

◆ SignalExport

DISignalExport JY5113.JY5113DITask.SignalExport
getset

Export DI Signal

◆ TransferedSamples

ulong JY5113.JY5113DITask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DIMode.Single.

◆ Trigger

DITrigger JY5113.JY5113DITask.Trigger
getset

DI Trigger Configuration

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DIChannel Class Reference

  • DIChannel
Properties | List of all members
JY5113.DIChannel Class Reference

DI Channel parameter class . More...

Properties

int LineNum [get, set]
Line number. More...

Detailed Description

DI Channel parameter class .

Property Documentation

◆ LineNum

int JY5113.DIChannel.LineNum
getset

Line number.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DISampleClock Class Reference

  • DISampleClock
Properties | List of all members
JY5113.DISampleClock Class Reference

Sample clock configuration class More...

Properties

DISampleClockSource | Source [get, set]
Clock Source. More...
DIExternalSampleClock | External [get, set]
External Sample Clock, Valid when Source is DISampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

DIExternalSampleClock JY5113.DISampleClock.External
getset

External Sample Clock, Valid when Source is DISampleClockSource.External.

◆ Source

DISampleClockSource JY5113.DISampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DIExternalSampleClock Class Reference

  • DIExternalSampleClock
Properties | List of all members
JY5113.DIExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5113.DIExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5113.DIExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DISignalExport Class Reference

  • DISignalExport
Public Member Functions | List of all members
JY5113.DISignalExport Class Reference

DI Signal Export Class More...

Public Member Functions

void | Add (DISignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DISignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DI Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DI Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.DISignalExport.Add | ( | DISignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DI Signal Source
destination | Export Desination

◆ Clear()

void JY5113.DISignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.DISignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DITrigger Class Reference

  • DITrigger
Properties | List of all members
JY5113.DITrigger Class Reference

Constructor to create an DITrigger task object. More...

Properties

DITriggerType | Type [get, set]
DI trigger type. More...
DITriggerMode | Mode [get, set]
DI trigger mode. More...
DIDigitalTrigger | Digital [get, set]
DI Digital Trigger.Valid when Type is DITriggerType.Digital. More...
uint | PreTriggerSamples [get, set]
Pretrigger Samples, must be less than or equal to JY5113DITask.SamplesToAcquire. More...

Detailed Description

Constructor to create an DITrigger task object.

Used to build DI Trigger

Property Documentation

◆ Digital

DIDigitalTrigger JY5113.DITrigger.Digital
getset

DI Digital Trigger.Valid when Type is DITriggerType.Digital.

◆ Mode

DITriggerMode JY5113.DITrigger.Mode
getset

DI trigger mode.

enum Start/Reference.

◆ PreTriggerSamples

uint JY5113.DITrigger.PreTriggerSamples
getset

Pretrigger Samples, must be less than or equal to JY5113DITask.SamplesToAcquire.

Valid when Mode is DITriggerMode.Reference. Pretrigger samples, must be greater than 1. Valid when Type is DITriggerType.Digital.

◆ Type

DITriggerType JY5113.DITrigger.Type
getset

DI trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: JY5113.DIDigitalTrigger Class Reference

  • DIDigitalTrigger
Properties | List of all members
JY5113.DIDigitalTrigger Class Reference

DI Digital trigger . More...

Properties

DIDigitalTriggerSource | Source [get, set]
DI Digital Trigger source. More...
DIDigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

DI Digital trigger .

Property Documentation

◆ Edge

DIDigitalTriggerEdge JY5113.DIDigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DIDigitalTriggerSource JY5113.DIDigitalTrigger.Source
getset

DI Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DITask.cs


5113 C# Programming Manual: C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs File Reference

  • 5113 C#
Classes | Namespaces | Enumerations
JY5113DOTask.cs File Reference

Classes

class | JY5113.JY5113DOTask
JY5113 Digital Output Task More...
class | JY5113.DOChannel
DO Channel parameter class . More...
class | JY5113.DOSampleClock
Sample clock configuration class More...
class | JY5113.DOExternalSampleClock
External Sample Clock Configuration Class More...
class | JY5113.DOTrigger
Constructor to create an DOTrigger task object. More...
class | JY5113.DODigitalTrigger
DO Digital trigger More...
class | JY5113.DOSignalExport
DO Signal Export Class More...

Namespaces

namespace JY5113

Enumerations

enum class | JY5113.DOSampleClockSource { JY5113.Internal , JY5113.External }
DO Sample Clock Source More...
enum class | JY5113.DOMode { JY5113.Single = 3 , JY5113.Finite = 0 , JY5113.ContinuousWrapping = 1 , JY5113.ContinuousNoWrapping = 2 }
DOMode More...
enum class | JY5113.DODigitalTriggerEdge { JY5113.Rising , JY5113.Falling }
DO Digital Trigger Edge More...
enum class JY5113.DODigitalTriggerSource {
JY5113.PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , JY5113.PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , JY5113.PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , JY5113.PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
JY5113.PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , JY5113.PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , JY5113.PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , JY5113.PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
JY5113.PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , JY5113.PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , JY5113.PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , JY5113.PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
JY5113.PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , JY5113.PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , JY5113.PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , JY5113.PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
JY5113.PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , JY5113.PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , JY5113.PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , JY5113.PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
JY5113.PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , JY5113.PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , JY5113.PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , JY5113.PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
JY5113.AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , JY5113.AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , JY5113.DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , JY5113.DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
JY5113.AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , JY5113.DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , JY5113.CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , JY5113.CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
JY5113.CO_0_Out = JY5113Import.JY5113_CO_0_Out , JY5113.CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
DO Digital trigger source More...
enum class | JY5113.DOTriggerType { JY5113.Immediate = JY5113Import.JY5113_TriggerType_Immediately , JY5113.Digital = JY5113Import.JY5113_TriggerType_Digital , JY5113.Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class | JY5113.DOSignalExportSource { JY5113.StartTrig = JY5113Import.SignalSource_JY5113_DO_StartTrig , JY5113.SampleClock = JY5113Import.SignalSource_JY5113_DO_SampleClock }
SourceSignal More...


5113 C# Programming Manual: JY5113.JY5113DOTask Class Reference

  • JY5113DOTask
Public Member Functions | Properties | List of all members
JY5113.JY5113DOTask Class Reference

JY5113 Digital Output Task More...

Public Member Functions

JY5113DOTask (int slotNum)
Constructor. More...
JY5113DOTask (string boardName)
Constructor. More...
void | AddChannel (int lineNum)
Add one channel. More...
void | AddChannel (int[] linesNum)
Add a group of channels. More...
void | RemoveChannel (int lineNum)
Delete the specified port number .If it is -1, delete all ports. More...
void | Start ()
Start DO task . More...
void | SendSoftwareTrigger ()
Generate a software trigger. More...
void | Stop ()
Stop DO task . More...
bool | WaitUntilDone (int timeout=-1)
Waiting until current task to complete. More...
void | WriteSinglePoint (bool writeValues, int line)
Write one sample to the specified port in register.Available when Mode is DOMode.Single More...
void | WriteSinglePoint (bool[] writeValues)
write one sample to all ports in register . More...
void | WriteData (ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the ushort data from one line or multi-lines. More...
void | WriteData (byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Wirte the byte data to all lines. More...
void | WriteData (byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000)
Write the line byte data to the lines. More...

Properties

List< DOChannel > | Channels [get]
List of DO channels,16个line More...
DOMode | Mode [get, set]
DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single More...
double | UpdateRate [get, set]
Update rate per channel. More...
int | SamplesToUpdate [get, set]
Number of output samples to write per channel , Only valid when Mode is DOMode.Finite. More...
DOSampleClock | SampleClock [get, set]
DO Sample Clock Configuration . More...
int | BufLenInSamples [get]
Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value. More...
uint | AvaliableLenInSamples [get]
Number of output samples per channel avaliable to write in DO buffuer. More...
ulong | TransferedSamples [get]
The number of samples that have been transfered from the local buffer (per channel). More...
OutputCompleteState | CompleteState [get, set]
DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero. More...
DOTrigger | Trigger [get, set]
DO Trigger Configuration. More...
DOSignalExport | SignalExport [get, set]
Export DO Signal More...
JY5113Device | Device [get]
Device More...

Detailed Description

JY5113 Digital Output Task

Constructor & Destructor Documentation

◆ JY5113DOTask() [1/2]

JY5113.JY5113DOTask.JY5113DOTask ( int slotNum )

Constructor.

Used to create an DOtask by a slot number.

Parameters
slotNum Card slot number.

◆ JY5113DOTask() [2/2]

JY5113.JY5113DOTask.JY5113DOTask ( string boardName )

Constructor.

Used to create an DO task by a board name.

Parameters
boardName Board name(device alias), set by device manager

Member Function Documentation

◆ AddChannel() [1/2]

void JY5113.JY5113DOTask.AddChannel ( int lineNum )

Add one channel.

Parameters
lineNum port number to be added.

◆ AddChannel() [2/2]

void JY5113.JY5113DOTask.AddChannel ( int[] linesNum )

Add a group of channels.

Parameters
linesNum an array of port numbers of added ports.

◆ RemoveChannel()

void JY5113.JY5113DOTask.RemoveChannel ( int lineNum )

Delete the specified port number .If it is -1, delete all ports.

Parameters
lineNum port number to be delete.

◆ SendSoftwareTrigger()

void JY5113.JY5113DOTask.SendSoftwareTrigger ( )

Generate a software trigger.

◆ Start()

void JY5113.JY5113DOTask.Start ( )

Start DO task .

◆ Stop()

void JY5113.JY5113DOTask.Stop ( )

Stop DO task .

◆ WaitUntilDone()

bool JY5113.JY5113DOTask.WaitUntilDone ( int timeout = -1 )

Waiting until current task to complete.

Available when Mode is DOMode.Finite

Parameters
timeout timeout = -1, wait until done, other positive number N, wait N mS. If not done, a timeout error generate.
Returns

◆ WriteData() [1/3]

void JY5113.JY5113DOTask.WriteData | ( | byte | dataBuffer[,],
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Write the line byte data to the lines.

Each line represents one port. There are 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [2/3]

void JY5113.JY5113DOTask.WriteData | ( | byte[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Wirte the byte data to all lines.

There are 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per port to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteData() [3/3]

void JY5113.JY5113DOTask.WriteData | ( | ushort[] | dataBuffer,
 |  | uint | samplesToUpdate,
 |  | int | timeOut = 10000
 | ) |  |

Write the ushort data from one line or multi-lines.

There are a total of 16 lines from 0 to 15. Each bit from low to high represents one line.

Parameters
dataBuffer | Data buffer
samplesToUpdate | Number of samples per line to be write
timeOut | timeout before generating error message, uint is ms。 timeout =-1 keep waiting until finish.

◆ WriteSinglePoint() [1/2]

void JY5113.JY5113DOTask.WriteSinglePoint | ( | bool | writeValues,
 |  | int | line
 | ) |  |

Write one sample to the specified port in register.Available when Mode is DOMode.Single

Parameters
writeValues | Write values.Buffer size >= 16
line | Specified port.

◆ WriteSinglePoint() [2/2]

void JY5113.JY5113DOTask.WriteSinglePoint ( bool[] writeValues )

write one sample to all ports in register .

Available when Mode is DOMode.Single

Parameters
writeValues Data to be written.Buffer size >= number of lines。

Property Documentation

◆ AvaliableLenInSamples

uint JY5113.JY5113DOTask.AvaliableLenInSamples
get

Number of output samples per channel avaliable to write in DO buffuer.

◆ BufLenInSamples

int JY5113.JY5113DOTask.BufLenInSamples
get

Number of samples per channel can be storage in the buffer, the PropretySamplesToUpdate must be less than or equal to this value.

◆ Channels

List<DOChannel> JY5113.JY5113DOTask.Channels
get

List of DO channels,16个line

◆ CompleteState

OutputCompleteState JY5113.JY5113DOTask.CompleteState
getset

DO Output Complete State, Valid when Mode is NOT DOMode.Single.Default is Zero.

◆ Device

JY5113Device JY5113.JY5113DOTask.Device
get

Device

◆ Mode

DOMode JY5113.JY5113DOTask.Mode
getset

DO acquisition mode.Select DO Mode from enum:ContinuousNoWrapping/ContinuousWrapping/Finite/Single

◆ SampleClock

DOSampleClock JY5113.JY5113DOTask.SampleClock
getset

DO Sample Clock Configuration .

◆ SamplesToUpdate

int JY5113.JY5113DOTask.SamplesToUpdate
getset

Number of output samples to write per channel , Only valid when Mode is DOMode.Finite.

◆ SignalExport

DOSignalExport JY5113.JY5113DOTask.SignalExport
getset

Export DO Signal

◆ TransferedSamples

ulong JY5113.JY5113DOTask.TransferedSamples
get

The number of samples that have been transfered from the local buffer (per channel).

Valid when Mode is NOT DOMode.Single.

◆ Trigger

DOTrigger JY5113.JY5113DOTask.Trigger
getset

DO Trigger Configuration.

◆ UpdateRate

double JY5113.JY5113DOTask.UpdateRate
getset

Update rate per channel.

Maximum update rate is 10M . The defalut sample rate = 10000 You can read this property to obtain the update rate that will actually take effect in the current configuration.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DOChannel Class Reference

  • DOChannel
Properties | List of all members
JY5113.DOChannel Class Reference

DO Channel parameter class . More...

Properties

int LineNum [get, set]
port number. More...

Detailed Description

DO Channel parameter class .

Property Documentation

◆ LineNum

int JY5113.DOChannel.LineNum
getset

port number.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DOSampleClock Class Reference

  • DOSampleClock
Properties | List of all members
JY5113.DOSampleClock Class Reference

Sample clock configuration class More...

Properties

DOSampleClockSource | Source [get, set]
Clock Source. More...
DOExternalSampleClock | External [get, set]
External Sample Clock.Valid when Source is DOSampleClockSource.External. More...

Detailed Description

Sample clock configuration class

Property Documentation

◆ External

DOExternalSampleClock JY5113.DOSampleClock.External
getset

External Sample Clock.Valid when Source is DOSampleClockSource.External.

◆ Source

DOSampleClockSource JY5113.DOSampleClock.Source
getset

Clock Source.

enum Internal/External

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DOExternalSampleClock Class Reference

  • DOExternalSampleClock
Properties | List of all members
JY5113.DOExternalSampleClock Class Reference

External Sample Clock Configuration Class More...

Properties

ClockTerminal | Terminal [get, set]
External Sample Clock Input Terminal More...
double | ExpectedRate [get, set]
Expected External Sample Clock Rate More...

Detailed Description

External Sample Clock Configuration Class

Property Documentation

◆ ExpectedRate

double JY5113.DOExternalSampleClock.ExpectedRate
getset

Expected External Sample Clock Rate

◆ Terminal

ClockTerminal JY5113.DOExternalSampleClock.Terminal
getset

External Sample Clock Input Terminal

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DOTrigger Class Reference

  • DOTrigger
Properties | List of all members
JY5113.DOTrigger Class Reference

Constructor to create an DOTrigger task object. More...

Properties

DOTriggerType | Type [get, set]
DO trigger type. More...
DODigitalTrigger | Digital [get, set]
DO Digital Trigger.Valid when Type is DOTriggerType.Digital. More...

Detailed Description

Constructor to create an DOTrigger task object.

Used to build DO Trigger

Property Documentation

◆ Digital

DODigitalTrigger JY5113.DOTrigger.Digital
getset

DO Digital Trigger.Valid when Type is DOTriggerType.Digital.

◆ Type

DOTriggerType JY5113.DOTrigger.Type
getset

DO trigger type.

enum Digital/Immediate/Soft.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DODigitalTrigger Class Reference

  • DODigitalTrigger
Properties | List of all members
JY5113.DODigitalTrigger Class Reference

DO Digital trigger More...

Properties

DODigitalTriggerSource | Source [get, set]
DO Digital Trigger source. More...
DODigitalTriggerEdge | Edge [get, set]
Digital Trigger edge，Rising/Falling. More...

Detailed Description

DO Digital trigger

Property Documentation

◆ Edge

DODigitalTriggerEdge JY5113.DODigitalTrigger.Edge
getset

Digital Trigger edge，Rising/Falling.

◆ Source

DODigitalTriggerSource JY5113.DODigitalTrigger.Source
getset

DO Digital Trigger source.

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: JY5113.DOSignalExport Class Reference

  • DOSignalExport
Public Member Functions | List of all members
JY5113.DOSignalExport Class Reference

DO Signal Export Class More...

Public Member Functions

void | Add (DOSignalExportSource source, SignalExportDestination destination)
Export one Signal to Desination More...
void | Add (DOSignalExportSource source, List< SignalExportDestination > destinations)
Export one Signal to Mutil Desination More...
void | Clear (SignalExportDestination destination)
Clear one Signal Export More...
void | ClearAll ()
Clear All Signal Export More...

Detailed Description

DO Signal Export Class

Member Function Documentation

◆ Add() [1/2]

void JY5113.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | List< SignalExportDestination > | destinations
 | ) |  |

Export one Signal to Mutil Desination

Parameters
source | DO Signal Source
destinations | Mutil Export Desinations

◆ Add() [2/2]

void JY5113.DOSignalExport.Add | ( | DOSignalExportSource | source,
 |  | SignalExportDestination | destination
 | ) |  |

Export one Signal to Desination

Parameters
source | DO Signal Source
destination | Export Desination

◆ Clear()

void JY5113.DOSignalExport.Clear ( SignalExportDestination destination )

Clear one Signal Export

Parameters
destination Export Desination

◆ ClearAll()

void JY5113.DOSignalExport.ClearAll ( )

Clear All Signal Export

The documentation for this class was generated from the following file:
  • C:/Users/wukeping/Desktop/5113 C#/JY5113DOTask.cs


5113 C# Programming Manual: Class List

Class List
Here are the classes, structs, unions and interfaces with brief descriptions:
[detail level 12]
▼N JY5113 |
C JY5113AITask | JY5113 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C DSMode | DS Mode Class Paraments
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5113AOTask | JY5113 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY5113CITask | JY5113 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5113COTask | JY5113 Counter Output Task
C COTrigger | Constructor to create an COTrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5113DITask | JY5113 Digital Iuput Task
C DIChannel | DI Channel parameter class
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DIDigitalTrigger | DI Digital trigger
C JY5113DOTask | JY5113 Digital Output Task
C DOChannel | DO Channel parameter class
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOTrigger | Constructor to create an DOTrigger task object
C DODigitalTrigger | DO Digital trigger
C DOSignalExport | DO Signal Export Class


5113 C# Programming Manual: Member List

  • AIAdvanced
JY5113.AIAdvanced Member List

This is the complete list of members for JY5113.AIAdvanced, including all inherited members.

ConvertRate | JY5113.AIAdvanced
DSMode | JY5113.AIAdvanced


5113 C# Programming Manual: Member List

  • AIAnalogEdgeComparator
JY5113.AIAnalogEdgeComparator Member List

This is the complete list of members for JY5113.AIAnalogEdgeComparator, including all inherited members.

Slope | JY5113.AIAnalogEdgeComparator
Threshold | JY5113.AIAnalogEdgeComparator


5113 C# Programming Manual: Member List

  • AIAnalogHysteresisComparator
JY5113.AIAnalogHysteresisComparator Member List

This is the complete list of members for JY5113.AIAnalogHysteresisComparator, including all inherited members.

HighThreshold | JY5113.AIAnalogHysteresisComparator
HighThresholdMultiChannels | JY5113.AIAnalogHysteresisComparator
LowThreshold | JY5113.AIAnalogHysteresisComparator
Slope | JY5113.AIAnalogHysteresisComparator


5113 C# Programming Manual: Member List

  • AIAnalogTrigger
JY5113.AIAnalogTrigger Member List

This is the complete list of members for JY5113.AIAnalogTrigger, including all inherited members.

AIAnalogTrigger() | JY5113.AIAnalogTrigger
Comparator | JY5113.AIAnalogTrigger
Edge | JY5113.AIAnalogTrigger
Hysteresis | JY5113.AIAnalogTrigger
Source | JY5113.AIAnalogTrigger
Window | JY5113.AIAnalogTrigger


5113 C# Programming Manual: Member List

  • AIAnalogWindowComparator
JY5113.AIAnalogWindowComparator Member List

This is the complete list of members for JY5113.AIAnalogWindowComparator, including all inherited members.

Condition | JY5113.AIAnalogWindowComparator
HighThreshold | JY5113.AIAnalogWindowComparator
HighThresholdMultiChannels | JY5113.AIAnalogWindowComparator
LowThreshold | JY5113.AIAnalogWindowComparator


5113 C# Programming Manual: Member List

  • AIChannel
JY5113.AIChannel Member List

This is the complete list of members for JY5113.AIChannel, including all inherited members.

AIChannel(int channelId, double rangeLow, double rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth) | JY5113.AIChannel
BandWidth | JY5113.AIChannel
ChannelID | JY5113.AIChannel
RangeHigh | JY5113.AIChannel
RangeLow | JY5113.AIChannel
Terminal | JY5113.AIChannel


5113 C# Programming Manual: Member List

  • AIDigitalTrigger
JY5113.AIDigitalTrigger Member List

This is the complete list of members for JY5113.AIDigitalTrigger, including all inherited members.

Edge | JY5113.AIDigitalTrigger
Source | JY5113.AIDigitalTrigger


5113 C# Programming Manual: Member List

  • AIExternalSampleClock
JY5113.AIExternalSampleClock Member List

This is the complete list of members for JY5113.AIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113.AIExternalSampleClock
Terminal | JY5113.AIExternalSampleClock


5113 C# Programming Manual: Member List

  • AIRecord
JY5113.AIRecord Member List

This is the complete list of members for JY5113.AIRecord, including all inherited members.

FileFormat | JY5113.AIRecord
FilePath | JY5113.AIRecord
Length | JY5113.AIRecord
Mode | JY5113.AIRecord


5113 C# Programming Manual: Member List

  • AISampleClock
JY5113.AISampleClock Member List

This is the complete list of members for JY5113.AISampleClock, including all inherited members.

External | JY5113.AISampleClock
Source | JY5113.AISampleClock


5113 C# Programming Manual: Member List

  • AISignalExport
JY5113.AISignalExport Member List

This is the complete list of members for JY5113.AISignalExport, including all inherited members.

Add(AISignalExportSource source, SignalExportDestination destination) | JY5113.AISignalExport
Add(AISignalExportSource source, List< SignalExportDestination > destinations) | JY5113.AISignalExport
Clear(SignalExportDestination destination) | JY5113.AISignalExport
ClearAll() | JY5113.AISignalExport


5113 C# Programming Manual: Member List

  • AISync
JY5113.AISync Member List

This is the complete list of members for JY5113.AISync, including all inherited members.

PulseRouting | JY5113.AISync
Topology | JY5113.AISync
TriggerRouting | JY5113.AISync


5113 C# Programming Manual: Member List

  • AITrigger
JY5113.AITrigger Member List

This is the complete list of members for JY5113.AITrigger, including all inherited members.

Analog | JY5113.AITrigger
Digital | JY5113.AITrigger
Mode | JY5113.AITrigger
PreTriggerSamples | JY5113.AITrigger
ReTriggerCount | JY5113.AITrigger
Type | JY5113.AITrigger


5113 C# Programming Manual: Member List

  • AOChannel
JY5113.AOChannel Member List

This is the complete list of members for JY5113.AOChannel, including all inherited members.

ChannelID | JY5113.AOChannel
RangeHigh | JY5113.AOChannel
RangeLow | JY5113.AOChannel


5113 C# Programming Manual: Member List

  • AODigitalTrigger
JY5113.AODigitalTrigger Member List

This is the complete list of members for JY5113.AODigitalTrigger, including all inherited members.

Edge | JY5113.AODigitalTrigger
Source | JY5113.AODigitalTrigger


5113 C# Programming Manual: Member List

  • AOExternalSampleClock
JY5113.AOExternalSampleClock Member List

This is the complete list of members for JY5113.AOExternalSampleClock, including all inherited members.

ExpectedRate | JY5113.AOExternalSampleClock
Terminal | JY5113.AOExternalSampleClock


5113 C# Programming Manual: Member List

  • AOSampleClock
JY5113.AOSampleClock Member List

This is the complete list of members for JY5113.AOSampleClock, including all inherited members.

External | JY5113.AOSampleClock
Source | JY5113.AOSampleClock


5113 C# Programming Manual: Member List

  • AOSignalExport
JY5113.AOSignalExport Member List

This is the complete list of members for JY5113.AOSignalExport, including all inherited members.

Add(AOSignalExportSource source, SignalExportDestination destination) | JY5113.AOSignalExport
Add(AOSignalExportSource source, List< SignalExportDestination > destinations) | JY5113.AOSignalExport
Clear(SignalExportDestination destination) | JY5113.AOSignalExport
ClearAll() | JY5113.AOSignalExport


5113 C# Programming Manual: Member List

  • AOTrigger
JY5113.AOTrigger Member List

This is the complete list of members for JY5113.AOTrigger, including all inherited members.

Digital | JY5113.AOTrigger
Type | JY5113.AOTrigger


5113 C# Programming Manual: Member List

  • CIDigitalTrigger
JY5113.CIDigitalTrigger Member List

This is the complete list of members for JY5113.CIDigitalTrigger, including all inherited members.

Edge | JY5113.CIDigitalTrigger
Source | JY5113.CIDigitalTrigger


5113 C# Programming Manual: Member List

  • CIExternalSampleClock
JY5113.CIExternalSampleClock Member List

This is the complete list of members for JY5113.CIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113.CIExternalSampleClock
IgnoreFirstSampleClock | JY5113.CIExternalSampleClock
Terminal | JY5113.CIExternalSampleClock


5113 C# Programming Manual: Member List

  • CIExternalTimebase
JY5113.CIExternalTimebase Member List

This is the complete list of members for JY5113.CIExternalTimebase, including all inherited members.

Frequency | JY5113.CIExternalTimebase
Terminal | JY5113.CIExternalTimebase


5113 C# Programming Manual: Member List

  • CIImplicitSampleClock
JY5113.CIImplicitSampleClock Member List

This is the complete list of members for JY5113.CIImplicitSampleClock, including all inherited members.

ExpectedRate JY5113.CIImplicitSampleClock


5113 C# Programming Manual: Member List

  • CIInternalSampleClock
JY5113.CIInternalSampleClock Member List

This is the complete list of members for JY5113.CIInternalSampleClock, including all inherited members.

IgnoreFirstSampleClock | JY5113.CIInternalSampleClock
Rate | JY5113.CIInternalSampleClock


5113 C# Programming Manual: Member List

  • CISampleClock
JY5113.CISampleClock Member List

This is the complete list of members for JY5113.CISampleClock, including all inherited members.

External | JY5113.CISampleClock
Implicit | JY5113.CISampleClock
Internal | JY5113.CISampleClock
Source | JY5113.CISampleClock


5113 C# Programming Manual: Member List

  • CISignalExport
JY5113.CISignalExport Member List

This is the complete list of members for JY5113.CISignalExport, including all inherited members.

Add(CISignalExportSource source, SignalExportDestination destination) | JY5113.CISignalExport
Add(CISignalExportSource source, List< SignalExportDestination > destinations) | JY5113.CISignalExport
Clear(SignalExportDestination destination) | JY5113.CISignalExport
ClearAll() | JY5113.CISignalExport


5113 C# Programming Manual: Member List

  • CITimebase
JY5113.CITimebase Member List

This is the complete list of members for JY5113.CITimebase, including all inherited members.

External | JY5113.CITimebase
Source | JY5113.CITimebase


5113 C# Programming Manual: Member List

  • CITrigger
JY5113.CITrigger Member List

This is the complete list of members for JY5113.CITrigger, including all inherited members.

Digital | JY5113.CITrigger
Type | JY5113.CITrigger


5113 C# Programming Manual: Member List

  • CODigitalTrigger
JY5113.CODigitalTrigger Member List

This is the complete list of members for JY5113.CODigitalTrigger, including all inherited members.

Edge | JY5113.CODigitalTrigger
Source | JY5113.CODigitalTrigger


5113 C# Programming Manual: Member List

  • COExternalTimebase
JY5113.COExternalTimebase Member List

This is the complete list of members for JY5113.COExternalTimebase, including all inherited members.

Frequency | JY5113.COExternalTimebase
Terminal | JY5113.COExternalTimebase


5113 C# Programming Manual: Member List

  • COPulse
JY5113.COPulse Member List

This is the complete list of members for JY5113.COPulse, including all inherited members.

COPulse(COPulseType type, double param1, double param2, int count) JY5113.COPulse


5113 C# Programming Manual: Member List

  • COSignalExport
JY5113.COSignalExport Member List

This is the complete list of members for JY5113.COSignalExport, including all inherited members.

Add(COSignalExportSource source, SignalExportDestination destination) | JY5113.COSignalExport
Add(COSignalExportSource source, List< SignalExportDestination > destinations) | JY5113.COSignalExport
Clear(SignalExportDestination destination) | JY5113.COSignalExport
ClearAll() | JY5113.COSignalExport


5113 C# Programming Manual: Member List

  • COTimebase
JY5113.COTimebase Member List

This is the complete list of members for JY5113.COTimebase, including all inherited members.

External | JY5113.COTimebase
Source | JY5113.COTimebase


5113 C# Programming Manual: Member List

  • COTrigger
JY5113.COTrigger Member List

This is the complete list of members for JY5113.COTrigger, including all inherited members.

Digital | JY5113.COTrigger
Type | JY5113.COTrigger


5113 C# Programming Manual: Member List

  • DIChannel
JY5113.DIChannel Member List

This is the complete list of members for JY5113.DIChannel, including all inherited members.

LineNum JY5113.DIChannel


5113 C# Programming Manual: Member List

  • DIDigitalTrigger
JY5113.DIDigitalTrigger Member List

This is the complete list of members for JY5113.DIDigitalTrigger, including all inherited members.

Edge | JY5113.DIDigitalTrigger
Source | JY5113.DIDigitalTrigger


5113 C# Programming Manual: Member List

  • DIExternalSampleClock
JY5113.DIExternalSampleClock Member List

This is the complete list of members for JY5113.DIExternalSampleClock, including all inherited members.

ExpectedRate | JY5113.DIExternalSampleClock
Terminal | JY5113.DIExternalSampleClock


5113 C# Programming Manual: Member List

  • DISampleClock
JY5113.DISampleClock Member List

This is the complete list of members for JY5113.DISampleClock, including all inherited members.

External | JY5113.DISampleClock
Source | JY5113.DISampleClock


5113 C# Programming Manual: Member List

  • DISignalExport
JY5113.DISignalExport Member List

This is the complete list of members for JY5113.DISignalExport, including all inherited members.

Add(DISignalExportSource source, SignalExportDestination destination) | JY5113.DISignalExport
Add(DISignalExportSource source, List< SignalExportDestination > destinations) | JY5113.DISignalExport
Clear(SignalExportDestination destination) | JY5113.DISignalExport
ClearAll() | JY5113.DISignalExport


5113 C# Programming Manual: Member List

  • DITrigger
JY5113.DITrigger Member List

This is the complete list of members for JY5113.DITrigger, including all inherited members.

Digital | JY5113.DITrigger
Mode | JY5113.DITrigger
PreTriggerSamples | JY5113.DITrigger
Type | JY5113.DITrigger


5113 C# Programming Manual: Member List

  • DOChannel
JY5113.DOChannel Member List

This is the complete list of members for JY5113.DOChannel, including all inherited members.

LineNum JY5113.DOChannel


5113 C# Programming Manual: Member List

  • DODigitalTrigger
JY5113.DODigitalTrigger Member List

This is the complete list of members for JY5113.DODigitalTrigger, including all inherited members.

Edge | JY5113.DODigitalTrigger
Source | JY5113.DODigitalTrigger


5113 C# Programming Manual: Member List

  • DOExternalSampleClock
JY5113.DOExternalSampleClock Member List

This is the complete list of members for JY5113.DOExternalSampleClock, including all inherited members.

ExpectedRate | JY5113.DOExternalSampleClock
Terminal | JY5113.DOExternalSampleClock


5113 C# Programming Manual: Member List

  • DOSampleClock
JY5113.DOSampleClock Member List

This is the complete list of members for JY5113.DOSampleClock, including all inherited members.

External | JY5113.DOSampleClock
Source | JY5113.DOSampleClock


5113 C# Programming Manual: Member List

  • DOSignalExport
JY5113.DOSignalExport Member List

This is the complete list of members for JY5113.DOSignalExport, including all inherited members.

Add(DOSignalExportSource source, SignalExportDestination destination) | JY5113.DOSignalExport
Add(DOSignalExportSource source, List< SignalExportDestination > destinations) | JY5113.DOSignalExport
Clear(SignalExportDestination destination) | JY5113.DOSignalExport
ClearAll() | JY5113.DOSignalExport


5113 C# Programming Manual: Member List

  • DOTrigger
JY5113.DOTrigger Member List

This is the complete list of members for JY5113.DOTrigger, including all inherited members.

Digital | JY5113.DOTrigger
Type | JY5113.DOTrigger


5113 C# Programming Manual: Member List

  • DSMode
JY5113.DSMode Member List

This is the complete list of members for JY5113.DSMode, including all inherited members.

Enable JY5113.DSMode


5113 C# Programming Manual: Member List

  • EdgeCounting
JY5113.EdgeCounting Member List

This is the complete list of members for JY5113.EdgeCounting, including all inherited members.

ActiveEdge | JY5113.EdgeCounting
Direction | JY5113.EdgeCounting
DirTerminal | JY5113.EdgeCounting
InitialCount | JY5113.EdgeCounting
InputTerminal | JY5113.EdgeCounting
OutEvent | JY5113.EdgeCounting
Pause | JY5113.EdgeCounting


5113 C# Programming Manual: Member List

  • EdgeCountingOutEvent
JY5113.EdgeCountingOutEvent Member List

This is the complete list of members for JY5113.EdgeCountingOutEvent, including all inherited members.

IdleState | JY5113.EdgeCountingOutEvent
Terminal | JY5113.EdgeCountingOutEvent
Threshold | JY5113.EdgeCountingOutEvent


5113 C# Programming Manual: Member List

  • FrequencyMeas
JY5113.FrequencyMeas Member List

This is the complete list of members for JY5113.FrequencyMeas, including all inherited members.

InputTerminal | JY5113.FrequencyMeas
Timebase | JY5113.FrequencyMeas


5113 C# Programming Manual: Member List

  • JY5113AITask
JY5113.JY5113AITask Member List

This is the complete list of members for JY5113.JY5113AITask, including all inherited members.

AddChannel(int chnId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth._80KHz) | JY5113.JY5113AITask
AddChannel(int[] chnsId, double rangeLow=-10, double rangeHigh=10, AITerminal terminalCfg=AITerminal.RSE, AIBandWidth bandWidth=AIBandWidth._80KHz) | JY5113.JY5113AITask
AddChannel(int[] chnsId, double[] rangeLow, double[] rangeHigh, AITerminal terminalCfg, AIBandWidth bandWidth) | JY5113.JY5113AITask
Advanced | JY5113.JY5113AITask
AvailableSamples | JY5113.JY5113AITask
BufLenInSamples | JY5113.JY5113AITask
Channels | JY5113.JY5113AITask
Device | JY5113.JY5113AITask
DisableCalibration | JY5113.JY5113AITask
GetRecordPreviewData(ref double[,] buf, int samplesPerChannel, int timeout=1000) | JY5113.JY5113AITask
GetRecordPreviewData(ref double[,] buf, int timeout=1000) | JY5113.JY5113AITask
GetRecordPreviewData(ref double[] buf, int samplesPerChannel, int timeout=1000) | JY5113.JY5113AITask
GetRecordPreviewData(ref double[] buf, int timeout=1000) | JY5113.JY5113AITask
GetRecordStatus(out double recordedLength, out bool recordDone) | JY5113.JY5113AITask
JY5113AITask(int slotNumber) | JY5113.JY5113AITask
JY5113AITask(string boardName) | JY5113.JY5113AITask
Mode | JY5113.JY5113AITask
ReadData(ref double[,] buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadData(ref double[,] buf, int timeout=10000) | JY5113.JY5113AITask
ReadData(ref double[] buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadData(ref double[] buf, int timeout=10000) | JY5113.JY5113AITask
ReadRawData(ref short[,] buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadRawData(ref short[,] buf, int timeout=10000) | JY5113.JY5113AITask
ReadRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadRawData(ref short[] buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AITask
ReadRawData(ref short[] buf, int timeout=10000) | JY5113.JY5113AITask
ReadSinglePoint(ref double readValue, int channel) | JY5113.JY5113AITask
ReadSinglePoint(ref double[] readValues) | JY5113.JY5113AITask
Record | JY5113.JY5113AITask
RemoveChannel(int chnId) | JY5113.JY5113AITask
SampleClock | JY5113.JY5113AITask
SampleRate | JY5113.JY5113AITask
SamplesToAcquire | JY5113.JY5113AITask
SendSoftwareTrigger() | JY5113.JY5113AITask
SignalExport | JY5113.JY5113AITask
Start() | JY5113.JY5113AITask
Stop() | JY5113.JY5113AITask
TransferedSamples | JY5113.JY5113AITask
Trigger | JY5113.JY5113AITask
WaitUntilDone(int timeout=-1) | JY5113.JY5113AITask


5113 C# Programming Manual: Member List

  • JY5113AOTask
JY5113.JY5113AOTask Member List

This is the complete list of members for JY5113.JY5113AOTask, including all inherited members.

AddChannel(int chnId) | JY5113.JY5113AOTask
AddChannel(int[] chnsId) | JY5113.JY5113AOTask
AvaliableLenInSamples | JY5113.JY5113AOTask
BufLenInSamples | JY5113.JY5113AOTask
Channels | JY5113.JY5113AOTask
CompleteState | JY5113.JY5113AOTask
Device | JY5113.JY5113AOTask
DisableCalibration | JY5113.JY5113AOTask
JY5113AOTask(int slotNum) | JY5113.JY5113AOTask
JY5113AOTask(string boardName) | JY5113.JY5113AOTask
Mode | JY5113.JY5113AOTask
RemoveChannel(int chnId) | JY5113.JY5113AOTask
SampleClock | JY5113.JY5113AOTask
SamplesToUpdate | JY5113.JY5113AOTask
SendSoftwareTrigger() | JY5113.JY5113AOTask
SignalExport | JY5113.JY5113AOTask
Start() | JY5113.JY5113AOTask
Stop() | JY5113.JY5113AOTask
TransferedSamples | JY5113.JY5113AOTask
Trigger | JY5113.JY5113AOTask
UpdateRate | JY5113.JY5113AOTask
WaitUntilDone(int timeout=-1) | JY5113.JY5113AOTask
WriteData(double[,] buf, int timeout=10000) | JY5113.JY5113AOTask
WriteData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AOTask
WriteData(double[] buf, int timeout=10000) | JY5113.JY5113AOTask
WriteRawData(ushort[,] buf, int timeout=10000) | JY5113.JY5113AOTask
WriteRawData(IntPtr buf, int samplesPerChannel, int timeout=10000) | JY5113.JY5113AOTask
WriteRawData(ushort[] buf, int timeout=10000) | JY5113.JY5113AOTask
WriteRawSinglePoint(ushort[] writeValues) | JY5113.JY5113AOTask
WriteRawSinglePoint(ushort writeValue, int channel) | JY5113.JY5113AOTask
WriteSinglePoint(double[] writeValues) | JY5113.JY5113AOTask
WriteSinglePoint(double writeValue, int channel) | JY5113.JY5113AOTask


5113 C# Programming Manual: Member List

  • JY5113CITask
JY5113.JY5113CITask Member List

This is the complete list of members for JY5113.JY5113CITask, including all inherited members.

AvailableSamples | JY5113.JY5113CITask
Device | JY5113.JY5113CITask
EdgeCounting | JY5113.JY5113CITask
FrequencyMeas | JY5113.JY5113CITask
JY5113CITask(int slotNum, int channel) | JY5113.JY5113CITask
JY5113CITask(string boardName, int channel) | JY5113.JY5113CITask
Mode | JY5113.JY5113CITask
PeriodMeas | JY5113.JY5113CITask
PulseMeas | JY5113.JY5113CITask
QuadEncoder | JY5113.JY5113CITask
ReadData(ref uint[] bufCount, int samplesToAcquire, int timeout=10000) | JY5113.JY5113CITask
ReadData(ref uint[] bufCount, int timeout=10000) | JY5113.JY5113CITask
ReadData(ref double[] bufMeasurement, int samplesToAcquire, int timeout=10000) | JY5113.JY5113CITask
ReadData(ref double[] bufMeasurement, int timeout=10000) | JY5113.JY5113CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int samplesToAcquire, int timeout=10000) | JY5113.JY5113CITask
ReadData(ref double[] bufMeasurement1, ref double[] bufMeasurement2, int timeout=10000) | JY5113.JY5113CITask
ReadSinglePoint(ref uint count) | JY5113.JY5113CITask
ReadSinglePoint(ref double measurement, int timeout=10000) | JY5113.JY5113CITask
ReadSinglePoint(ref double measurement1, ref double measurement2, int timeout=10000) | JY5113.JY5113CITask
SampleClock | JY5113.JY5113CITask
SamplesToAcquire | JY5113.JY5113CITask
SemiPeriodMeas | JY5113.JY5113CITask
SendSoftwareTrigger() | JY5113.JY5113CITask
SignalExport | JY5113.JY5113CITask
Start() | JY5113.JY5113CITask
Stop() | JY5113.JY5113CITask
TransferedSamples | JY5113.JY5113CITask
Trigger | JY5113.JY5113CITask
TwoEdgeSeparation | JY5113.JY5113CITask
TwoPulseEncoder | JY5113.JY5113CITask
Type | JY5113.JY5113CITask


5113 C# Programming Manual: Member List

  • JY5113COTask
JY5113.JY5113COTask Member List

This is the complete list of members for JY5113.JY5113COTask, including all inherited members.

AvaliableLenInSamples | JY5113.JY5113COTask
Device | JY5113.JY5113COTask
IdleState | JY5113.JY5113COTask
InitialDelay | JY5113.JY5113COTask
JY5113COTask(int slotNum, int channel) | JY5113.JY5113COTask
JY5113COTask(string boardName, int channel) | JY5113.JY5113COTask
Mode | JY5113.JY5113COTask
OutputTerminal | JY5113.JY5113COTask
Pause | JY5113.JY5113COTask
SamplesToUpdate | JY5113.JY5113COTask
SendSoftwareTrigger() | JY5113.JY5113COTask
SignalExport | JY5113.JY5113COTask
Start() | JY5113.JY5113COTask
Stop() | JY5113.JY5113COTask
Timebase | JY5113.JY5113COTask
TransferedPulses | JY5113.JY5113COTask
TransferedSamples | JY5113.JY5113COTask
Trigger | JY5113.JY5113COTask
WaitUntilDone(int timeout=-1) | JY5113.JY5113COTask
WriteData(COPulse[] pulsesGroup, int samplesToWrite, int timeout=10000) | JY5113.JY5113COTask
WriteSinglePoint(COPulse pulse) | JY5113.JY5113COTask


5113 C# Programming Manual: Member List

  • JY5113DITask
JY5113.JY5113DITask Member List

This is the complete list of members for JY5113.JY5113DITask, including all inherited members.

AddChannel(int lineNum) | JY5113.JY5113DITask
AddChannel(int[] linesNum) | JY5113.JY5113DITask
AvailableSamples | JY5113.JY5113DITask
BufLenInSamples | JY5113.JY5113DITask
Channels | JY5113.JY5113DITask
Device | JY5113.JY5113DITask
JY5113DITask(int slotNum) | JY5113.JY5113DITask
JY5113DITask(string boardName) | JY5113.JY5113DITask
Mode | JY5113.JY5113DITask
ReadData(ref short[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5113.JY5113DITask
ReadData(ref byte[] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5113.JY5113DITask
ReadData(ref byte[,] dataBuffer, uint samplesToAcquire, int timeOut=10000) | JY5113.JY5113DITask
ReadSinglePoint(ref bool readValue, int line) | JY5113.JY5113DITask
ReadSinglePoint(ref bool[] readValues) | JY5113.JY5113DITask
RemoveChannel(int lineNum) | JY5113.JY5113DITask
SampleClock | JY5113.JY5113DITask
SampleRate | JY5113.JY5113DITask
SamplesToAcquire | JY5113.JY5113DITask
SendSoftwareTrigger() | JY5113.JY5113DITask
SignalExport | JY5113.JY5113DITask
Start() | JY5113.JY5113DITask
Stop() | JY5113.JY5113DITask
TransferedSamples | JY5113.JY5113DITask
Trigger | JY5113.JY5113DITask


5113 C# Programming Manual: Member List

  • JY5113DOTask
JY5113.JY5113DOTask Member List

This is the complete list of members for JY5113.JY5113DOTask, including all inherited members.

AddChannel(int lineNum) | JY5113.JY5113DOTask
AddChannel(int[] linesNum) | JY5113.JY5113DOTask
AvaliableLenInSamples | JY5113.JY5113DOTask
BufLenInSamples | JY5113.JY5113DOTask
Channels | JY5113.JY5113DOTask
CompleteState | JY5113.JY5113DOTask
Device | JY5113.JY5113DOTask
JY5113DOTask(int slotNum) | JY5113.JY5113DOTask
JY5113DOTask(string boardName) | JY5113.JY5113DOTask
Mode | JY5113.JY5113DOTask
RemoveChannel(int lineNum) | JY5113.JY5113DOTask
SampleClock | JY5113.JY5113DOTask
SamplesToUpdate | JY5113.JY5113DOTask
SendSoftwareTrigger() | JY5113.JY5113DOTask
SignalExport | JY5113.JY5113DOTask
Start() | JY5113.JY5113DOTask
Stop() | JY5113.JY5113DOTask
TransferedSamples | JY5113.JY5113DOTask
Trigger | JY5113.JY5113DOTask
UpdateRate | JY5113.JY5113DOTask
WaitUntilDone(int timeout=-1) | JY5113.JY5113DOTask
WriteData(ushort[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5113.JY5113DOTask
WriteData(byte[] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5113.JY5113DOTask
WriteData(byte[,] dataBuffer, uint samplesToUpdate, int timeOut=10000) | JY5113.JY5113DOTask
WriteSinglePoint(bool writeValues, int line) | JY5113.JY5113DOTask
WriteSinglePoint(bool[] writeValues) | JY5113.JY5113DOTask


5113 C# Programming Manual: Member List

  • PauseTrigger
JY5113.PauseTrigger Member List

This is the complete list of members for JY5113.PauseTrigger, including all inherited members.

ActivePolarity | JY5113.PauseTrigger
Terminal | JY5113.PauseTrigger


5113 C# Programming Manual: Member List

  • PeriodMeas
JY5113.PeriodMeas Member List

This is the complete list of members for JY5113.PeriodMeas, including all inherited members.

InputTerminal | JY5113.PeriodMeas
Timebase | JY5113.PeriodMeas


5113 C# Programming Manual: Member List

  • PulseMeas
JY5113.PulseMeas Member List

This is the complete list of members for JY5113.PulseMeas, including all inherited members.

InputTerminal | JY5113.PulseMeas
StartingEdge | JY5113.PulseMeas
Timebase | JY5113.PulseMeas


5113 C# Programming Manual: Member List

  • QuadEncoder
JY5113.QuadEncoder Member List

This is the complete list of members for JY5113.QuadEncoder, including all inherited members.

AInputTerminal | JY5113.QuadEncoder
BInputTerminal | JY5113.QuadEncoder
EncodingType | JY5113.QuadEncoder
InitialCount | JY5113.QuadEncoder
ZInputTerminal | JY5113.QuadEncoder
ZReloadEnabled | JY5113.QuadEncoder


5113 C# Programming Manual: Member List

  • SemiPeriodMeas
JY5113.SemiPeriodMeas Member List

This is the complete list of members for JY5113.SemiPeriodMeas, including all inherited members.

InputTerminal | JY5113.SemiPeriodMeas
StartingEdge | JY5113.SemiPeriodMeas
Timebase | JY5113.SemiPeriodMeas


5113 C# Programming Manual: Member List

  • TwoEdgeSeparation
JY5113.TwoEdgeSeparation Member List

This is the complete list of members for JY5113.TwoEdgeSeparation, including all inherited members.

EdgeSeparationMode | JY5113.TwoEdgeSeparation
FirstInputTerminal | JY5113.TwoEdgeSeparation
SecondInputTerminal | JY5113.TwoEdgeSeparation
Timebase | JY5113.TwoEdgeSeparation


5113 C# Programming Manual: Member List

  • TwoPulseEncoder
JY5113.TwoPulseEncoder Member List

This is the complete list of members for JY5113.TwoPulseEncoder, including all inherited members.

AInputTerminal | JY5113.TwoPulseEncoder
BInputTerminal | JY5113.TwoPulseEncoder
InitialCount | JY5113.TwoPulseEncoder


5113 C# Programming Manual: Class Index

Class Index
A | C | D | E | F | J | P | Q | S | T
A
AIAdvanced (JY5113)
AIAnalogEdgeComparator (JY5113)
AIAnalogHysteresisComparator (JY5113)
AIAnalogTrigger (JY5113)
AIAnalogWindowComparator (JY5113)
AIChannel (JY5113)
AIDigitalTrigger (JY5113)
AIExternalSampleClock (JY5113)
AIRecord (JY5113)
AISampleClock (JY5113)
AISignalExport (JY5113)
AISync (JY5113)
AITrigger (JY5113)
AOChannel (JY5113)
AODigitalTrigger (JY5113)
AOExternalSampleClock (JY5113)
AOSampleClock (JY5113)
AOSignalExport (JY5113)
AOTrigger (JY5113)
C
CIDigitalTrigger (JY5113)
CIExternalSampleClock (JY5113)
CIExternalTimebase (JY5113)
CIImplicitSampleClock (JY5113)
CIInternalSampleClock (JY5113)
CISampleClock (JY5113)
CISignalExport (JY5113)
CITimebase (JY5113)
CITrigger (JY5113)
CODigitalTrigger (JY5113)
COExternalTimebase (JY5113)
COPulse (JY5113)
COSignalExport (JY5113)
COTimebase (JY5113)
COTrigger (JY5113)
D
DIChannel (JY5113)
DIDigitalTrigger (JY5113)
DIExternalSampleClock (JY5113)
DISampleClock (JY5113)
DISignalExport (JY5113)
DITrigger (JY5113)
DOChannel (JY5113)
DODigitalTrigger (JY5113)
DOExternalSampleClock (JY5113)
DOSampleClock (JY5113)
DOSignalExport (JY5113)
DOTrigger (JY5113)
DSMode (JY5113)
E
EdgeCounting (JY5113)
EdgeCountingOutEvent (JY5113)
F
FrequencyMeas (JY5113)
J
JY5113AITask (JY5113)
JY5113AOTask (JY5113)
JY5113CITask (JY5113)
JY5113COTask (JY5113)
JY5113DITask (JY5113)
JY5113DOTask (JY5113)
P
PauseTrigger (JY5113)
PeriodMeas (JY5113)
PulseMeas (JY5113)
Q
QuadEncoder (JY5113)
S
SemiPeriodMeas (JY5113)
T
TwoEdgeSeparation (JY5113)
TwoPulseEncoder (JY5113)


5113 C# Programming Manual: File List

File List
Here is a list of all files with brief descriptions:
[detail level 12]
▼ 5113 C#
JY5113AITask.cs
JY5113AOTask.cs
JY5113CITask.cs
JY5113COTask.cs
JY5113DITask.cs
JY5113DOTask.cs


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- a -

  • ActiveEdge : JY5113.EdgeCounting
  • ActivePolarity : JY5113.PauseTrigger
  • Add() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • AddChannel() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Advanced : JY5113.JY5113AITask
  • AIAnalogTrigger() : JY5113.AIAnalogTrigger
  • AIChannel() : JY5113.AIChannel
  • AInputTerminal : JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • Analog : JY5113.AITrigger
  • AvailableSamples : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • AvaliableLenInSamples : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- b -

  • BandWidth : JY5113.AIChannel
  • BInputTerminal : JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • BufLenInSamples : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- c -

  • ChannelID : JY5113.AIChannel , JY5113.AOChannel
  • Channels : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Clear() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • ClearAll() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • Comparator : JY5113.AIAnalogTrigger
  • CompleteState : JY5113.JY5113AOTask , JY5113.JY5113DOTask
  • Condition : JY5113.AIAnalogWindowComparator
  • ConvertRate : JY5113.AIAdvanced
  • COPulse() : JY5113.COPulse


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- d -

  • Device : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Digital : JY5113.AITrigger , JY5113.AOTrigger , JY5113.CITrigger , JY5113.COTrigger , JY5113.DITrigger , JY5113.DOTrigger
  • Direction : JY5113.EdgeCounting
  • DirTerminal : JY5113.EdgeCounting
  • DisableCalibration : JY5113.JY5113AITask , JY5113.JY5113AOTask
  • DSMode : JY5113.AIAdvanced


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- e -

  • Edge : JY5113.AIAnalogTrigger , JY5113.AIDigitalTrigger , JY5113.AODigitalTrigger , JY5113.CIDigitalTrigger , JY5113.CODigitalTrigger , JY5113.DIDigitalTrigger , JY5113.DODigitalTrigger
  • EdgeCounting : JY5113.JY5113CITask
  • EdgeSeparationMode : JY5113.TwoEdgeSeparation
  • Enable : JY5113.DSMode
  • EncodingType : JY5113.QuadEncoder
  • ExpectedRate : JY5113.AIExternalSampleClock , JY5113.AOExternalSampleClock , JY5113.CIExternalSampleClock , JY5113.CIImplicitSampleClock , JY5113.DIExternalSampleClock , JY5113.DOExternalSampleClock
  • External : JY5113.AISampleClock , JY5113.AOSampleClock , JY5113.CISampleClock , JY5113.CITimebase , JY5113.COTimebase , JY5113.DISampleClock , JY5113.DOSampleClock


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- f -

  • FileFormat : JY5113.AIRecord
  • FilePath : JY5113.AIRecord
  • FirstInputTerminal : JY5113.TwoEdgeSeparation
  • Frequency : JY5113.CIExternalTimebase , JY5113.COExternalTimebase
  • FrequencyMeas : JY5113.JY5113CITask


5113 C# Programming Manual: Class Members - Functions

- a -

  • Add() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • AddChannel() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • AIAnalogTrigger() : JY5113.AIAnalogTrigger
  • AIChannel() : JY5113.AIChannel

- c -

  • Clear() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • ClearAll() : JY5113.AISignalExport , JY5113.AOSignalExport , JY5113.CISignalExport , JY5113.COSignalExport , JY5113.DISignalExport , JY5113.DOSignalExport
  • COPulse() : JY5113.COPulse

- g -

  • GetRecordPreviewData() : JY5113.JY5113AITask
  • GetRecordStatus() : JY5113.JY5113AITask

- j -

  • JY5113AITask() : JY5113.JY5113AITask
  • JY5113AOTask() : JY5113.JY5113AOTask
  • JY5113CITask() : JY5113.JY5113CITask
  • JY5113COTask() : JY5113.JY5113COTask
  • JY5113DITask() : JY5113.JY5113DITask
  • JY5113DOTask() : JY5113.JY5113DOTask

- r -

  • ReadData() : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • ReadRawData() : JY5113.JY5113AITask
  • ReadSinglePoint() : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • RemoveChannel() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask

- s -

  • SendSoftwareTrigger() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Start() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Stop() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask

- w -

  • WaitUntilDone() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • WriteData() : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • WriteRawData() : JY5113.JY5113AOTask
  • WriteRawSinglePoint() : JY5113.JY5113AOTask
  • WriteSinglePoint() : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- g -

  • GetRecordPreviewData() : JY5113.JY5113AITask
  • GetRecordStatus() : JY5113.JY5113AITask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- h -

  • HighThreshold : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator
  • HighThresholdMultiChannels : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator
  • Hysteresis : JY5113.AIAnalogTrigger


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- i -

  • IdleState : JY5113.EdgeCountingOutEvent , JY5113.JY5113COTask
  • IgnoreFirstSampleClock : JY5113.CIExternalSampleClock , JY5113.CIInternalSampleClock
  • Implicit : JY5113.CISampleClock
  • InitialCount : JY5113.EdgeCounting , JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • InitialDelay : JY5113.JY5113COTask
  • InputTerminal : JY5113.EdgeCounting , JY5113.FrequencyMeas , JY5113.PeriodMeas , JY5113.PulseMeas , JY5113.SemiPeriodMeas
  • Internal : JY5113.CISampleClock


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- j -

  • JY5113AITask() : JY5113.JY5113AITask
  • JY5113AOTask() : JY5113.JY5113AOTask
  • JY5113CITask() : JY5113.JY5113CITask
  • JY5113COTask() : JY5113.JY5113COTask
  • JY5113DITask() : JY5113.JY5113DITask
  • JY5113DOTask() : JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- l -

  • Length : JY5113.AIRecord
  • LineNum : JY5113.DIChannel , JY5113.DOChannel
  • LowThreshold : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- m -

  • Mode : JY5113.AIRecord , JY5113.AITrigger , JY5113.DITrigger , JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- o -

  • OutEvent : JY5113.EdgeCounting
  • OutputTerminal : JY5113.JY5113COTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- p -

  • Pause : JY5113.EdgeCounting , JY5113.JY5113COTask
  • PeriodMeas : JY5113.JY5113CITask
  • PreTriggerSamples : JY5113.AITrigger , JY5113.DITrigger
  • PulseMeas : JY5113.JY5113CITask
  • PulseRouting : JY5113.AISync


5113 C# Programming Manual: Class Members - Properties

- a -

  • ActiveEdge : JY5113.EdgeCounting
  • ActivePolarity : JY5113.PauseTrigger
  • Advanced : JY5113.JY5113AITask
  • AInputTerminal : JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • Analog : JY5113.AITrigger
  • AvailableSamples : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • AvaliableLenInSamples : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members - Properties

- b -

  • BandWidth : JY5113.AIChannel
  • BInputTerminal : JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • BufLenInSamples : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members - Properties

- c -

  • ChannelID : JY5113.AIChannel , JY5113.AOChannel
  • Channels : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Comparator : JY5113.AIAnalogTrigger
  • CompleteState : JY5113.JY5113AOTask , JY5113.JY5113DOTask
  • Condition : JY5113.AIAnalogWindowComparator
  • ConvertRate : JY5113.AIAdvanced


5113 C# Programming Manual: Class Members - Properties

- d -

  • Device : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Digital : JY5113.AITrigger , JY5113.AOTrigger , JY5113.CITrigger , JY5113.COTrigger , JY5113.DITrigger , JY5113.DOTrigger
  • Direction : JY5113.EdgeCounting
  • DirTerminal : JY5113.EdgeCounting
  • DisableCalibration : JY5113.JY5113AITask , JY5113.JY5113AOTask
  • DSMode : JY5113.AIAdvanced


5113 C# Programming Manual: Class Members - Properties

- e -

  • Edge : JY5113.AIAnalogTrigger , JY5113.AIDigitalTrigger , JY5113.AODigitalTrigger , JY5113.CIDigitalTrigger , JY5113.CODigitalTrigger , JY5113.DIDigitalTrigger , JY5113.DODigitalTrigger
  • EdgeCounting : JY5113.JY5113CITask
  • EdgeSeparationMode : JY5113.TwoEdgeSeparation
  • Enable : JY5113.DSMode
  • EncodingType : JY5113.QuadEncoder
  • ExpectedRate : JY5113.AIExternalSampleClock , JY5113.AOExternalSampleClock , JY5113.CIExternalSampleClock , JY5113.CIImplicitSampleClock , JY5113.DIExternalSampleClock , JY5113.DOExternalSampleClock
  • External : JY5113.AISampleClock , JY5113.AOSampleClock , JY5113.CISampleClock , JY5113.CITimebase , JY5113.COTimebase , JY5113.DISampleClock , JY5113.DOSampleClock


5113 C# Programming Manual: Class Members - Properties

- f -

  • FileFormat : JY5113.AIRecord
  • FilePath : JY5113.AIRecord
  • FirstInputTerminal : JY5113.TwoEdgeSeparation
  • Frequency : JY5113.CIExternalTimebase , JY5113.COExternalTimebase
  • FrequencyMeas : JY5113.JY5113CITask


5113 C# Programming Manual: Class Members - Properties

- h -

  • Hysteresis : JY5113.AIAnalogTrigger


5113 C# Programming Manual: Class Members - Properties

- i -

  • IdleState : JY5113.EdgeCountingOutEvent , JY5113.JY5113COTask
  • IgnoreFirstSampleClock : JY5113.CIExternalSampleClock , JY5113.CIInternalSampleClock
  • Implicit : JY5113.CISampleClock
  • InitialCount : JY5113.EdgeCounting , JY5113.QuadEncoder , JY5113.TwoPulseEncoder
  • InitialDelay : JY5113.JY5113COTask
  • InputTerminal : JY5113.EdgeCounting , JY5113.FrequencyMeas , JY5113.PeriodMeas , JY5113.PulseMeas , JY5113.SemiPeriodMeas
  • Internal : JY5113.CISampleClock


5113 C# Programming Manual: Class Members - Properties

- l -

  • Length : JY5113.AIRecord
  • LineNum : JY5113.DIChannel , JY5113.DOChannel


5113 C# Programming Manual: Class Members - Properties

- m -

  • Mode : JY5113.AIRecord , JY5113.AITrigger , JY5113.DITrigger , JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members - Properties

- o -

  • OutEvent : JY5113.EdgeCounting
  • OutputTerminal : JY5113.JY5113COTask


5113 C# Programming Manual: Class Members - Properties

- p -

  • Pause : JY5113.EdgeCounting , JY5113.JY5113COTask
  • PeriodMeas : JY5113.JY5113CITask
  • PreTriggerSamples : JY5113.AITrigger , JY5113.DITrigger
  • PulseMeas : JY5113.JY5113CITask
  • PulseRouting : JY5113.AISync


5113 C# Programming Manual: Class Members - Properties

- q -

  • QuadEncoder : JY5113.JY5113CITask


5113 C# Programming Manual: Class Members - Properties

- r -

  • RangeHigh : JY5113.AIChannel , JY5113.AOChannel
  • RangeLow : JY5113.AIChannel , JY5113.AOChannel
  • Rate : JY5113.CIInternalSampleClock
  • Record : JY5113.JY5113AITask
  • ReTriggerCount : JY5113.AITrigger


5113 C# Programming Manual: Class Members - Properties

- s -

  • SampleClock : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • SampleRate : JY5113.JY5113AITask , JY5113.JY5113DITask
  • SamplesToAcquire : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • SamplesToUpdate : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • SecondInputTerminal : JY5113.TwoEdgeSeparation
  • SemiPeriodMeas : JY5113.JY5113CITask
  • SignalExport : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Slope : JY5113.AIAnalogEdgeComparator , JY5113.AIAnalogHysteresisComparator
  • Source : JY5113.AIAnalogTrigger , JY5113.AIDigitalTrigger , JY5113.AISampleClock , JY5113.AODigitalTrigger , JY5113.AOSampleClock , JY5113.CIDigitalTrigger , JY5113.CISampleClock , JY5113.CITimebase , JY5113.CODigitalTrigger , JY5113.COTimebase , JY5113.DIDigitalTrigger , JY5113.DISampleClock , JY5113.DODigitalTrigger , JY5113.DOSampleClock
  • StartingEdge : JY5113.PulseMeas , JY5113.SemiPeriodMeas


5113 C# Programming Manual: Class Members - Properties

- t -

  • Terminal : JY5113.AIChannel , JY5113.AIExternalSampleClock , JY5113.AOExternalSampleClock , JY5113.CIExternalSampleClock , JY5113.CIExternalTimebase , JY5113.COExternalTimebase , JY5113.DIExternalSampleClock , JY5113.DOExternalSampleClock , JY5113.EdgeCountingOutEvent , JY5113.PauseTrigger
  • Threshold : JY5113.EdgeCountingOutEvent
  • Timebase : JY5113.FrequencyMeas , JY5113.JY5113COTask , JY5113.PeriodMeas , JY5113.PulseMeas , JY5113.SemiPeriodMeas , JY5113.TwoEdgeSeparation
  • Topology : JY5113.AISync
  • TransferedPulses : JY5113.JY5113COTask
  • TransferedSamples : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Trigger : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • TriggerRouting : JY5113.AISync
  • TwoEdgeSeparation : JY5113.JY5113CITask
  • TwoPulseEncoder : JY5113.JY5113CITask
  • Type : JY5113.AITrigger , JY5113.AOTrigger , JY5113.CITrigger , JY5113.COTrigger , JY5113.DITrigger , JY5113.DOTrigger , JY5113.JY5113CITask


5113 C# Programming Manual: Class Members - Properties

- u -

  • UpdateRate : JY5113.JY5113AOTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members - Properties

- w -

  • Window : JY5113.AIAnalogTrigger


5113 C# Programming Manual: Class Members - Properties

- z -

  • ZInputTerminal : JY5113.QuadEncoder
  • ZReloadEnabled : JY5113.QuadEncoder


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- q -

  • QuadEncoder : JY5113.JY5113CITask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- r -

  • RangeHigh : JY5113.AIChannel , JY5113.AOChannel
  • RangeLow : JY5113.AIChannel , JY5113.AOChannel
  • Rate : JY5113.CIInternalSampleClock
  • ReadData() : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • ReadRawData() : JY5113.JY5113AITask
  • ReadSinglePoint() : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • Record : JY5113.JY5113AITask
  • RemoveChannel() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • ReTriggerCount : JY5113.AITrigger


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- s -

  • SampleClock : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • SampleRate : JY5113.JY5113AITask , JY5113.JY5113DITask
  • SamplesToAcquire : JY5113.JY5113AITask , JY5113.JY5113CITask , JY5113.JY5113DITask
  • SamplesToUpdate : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • SecondInputTerminal : JY5113.TwoEdgeSeparation
  • SemiPeriodMeas : JY5113.JY5113CITask
  • SendSoftwareTrigger() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • SignalExport : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Slope : JY5113.AIAnalogEdgeComparator , JY5113.AIAnalogHysteresisComparator
  • Source : JY5113.AIAnalogTrigger , JY5113.AIDigitalTrigger , JY5113.AISampleClock , JY5113.AODigitalTrigger , JY5113.AOSampleClock , JY5113.CIDigitalTrigger , JY5113.CISampleClock , JY5113.CITimebase , JY5113.CODigitalTrigger , JY5113.COTimebase , JY5113.DIDigitalTrigger , JY5113.DISampleClock , JY5113.DODigitalTrigger , JY5113.DOSampleClock
  • Start() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • StartingEdge : JY5113.PulseMeas , JY5113.SemiPeriodMeas
  • Stop() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- t -

  • Terminal : JY5113.AIChannel , JY5113.AIExternalSampleClock , JY5113.AOExternalSampleClock , JY5113.CIExternalSampleClock , JY5113.CIExternalTimebase , JY5113.COExternalTimebase , JY5113.DIExternalSampleClock , JY5113.DOExternalSampleClock , JY5113.EdgeCountingOutEvent , JY5113.PauseTrigger
  • Threshold : JY5113.AIAnalogEdgeComparator , JY5113.EdgeCountingOutEvent
  • Timebase : JY5113.FrequencyMeas , JY5113.JY5113COTask , JY5113.PeriodMeas , JY5113.PulseMeas , JY5113.SemiPeriodMeas , JY5113.TwoEdgeSeparation
  • Topology : JY5113.AISync
  • TransferedPulses : JY5113.JY5113COTask
  • TransferedSamples : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • Trigger : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113CITask , JY5113.JY5113COTask , JY5113.JY5113DITask , JY5113.JY5113DOTask
  • TriggerRouting : JY5113.AISync
  • TwoEdgeSeparation : JY5113.JY5113CITask
  • TwoPulseEncoder : JY5113.JY5113CITask
  • Type : JY5113.AITrigger , JY5113.AOTrigger , JY5113.CITrigger , JY5113.COTrigger , JY5113.DITrigger , JY5113.DOTrigger , JY5113.JY5113CITask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- u -

  • UpdateRate : JY5113.JY5113AOTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members - Variables

  • HighThreshold : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator
  • HighThresholdMultiChannels : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator
  • LowThreshold : JY5113.AIAnalogHysteresisComparator , JY5113.AIAnalogWindowComparator
  • Threshold : JY5113.AIAnalogEdgeComparator


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- w -

  • WaitUntilDone() : JY5113.JY5113AITask , JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • Window : JY5113.AIAnalogTrigger
  • WriteData() : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask
  • WriteRawData() : JY5113.JY5113AOTask
  • WriteRawSinglePoint() : JY5113.JY5113AOTask
  • WriteSinglePoint() : JY5113.JY5113AOTask , JY5113.JY5113COTask , JY5113.JY5113DOTask


5113 C# Programming Manual: Class Members

Here is a list of all class members with links to the classes they belong to:

- z -

  • ZInputTerminal : JY5113.QuadEncoder
  • ZReloadEnabled : JY5113.QuadEncoder


5113 C# Programming Manual: Main Page

5113 C# Programming Manual Documentation


5113 C# Programming Manual: JY5113 Namespace Reference

Classes | Enumerations
JY5113 Namespace Reference

Classes

class | JY5113AITask
JY5113 Analog Input Task. More...
class | AIChannel
AI Channel parameter class More...
class | AIAnalogHysteresisComparator
AI Analog Hysteresis Comparatorr More...
class | AIAnalogWindowComparator
AI Analog Window Comparatorr More...
class | AIAnalogEdgeComparator
AI Analog Edge Comparator More...
class | AISampleClock
Sample clock configuration class More...
class | AIExternalSampleClock
External Sample Clock Configuration Class More...
class | AITrigger
AI Trigger class More...
class | AIDigitalTrigger
AI Digital Trigger More...
class | AIAnalogTrigger
AI Analog Trigger More...
class | AIRecord
AI Record class More...
class | AIAdvanced
AI Advance parameter More...
class | DSMode
DS Mode Class Paraments More...
class | AISync
Configure sync signal More...
class | AISignalExport
AI Signal Export Class More...
class | JY5113AOTask
JY5113 Analog Ouput Task More...
class | AOChannel
AO Channel parameter class . More...
class | AOSampleClock
AO Sample clock configuration class More...
class | AOExternalSampleClock
External Sample Clock Configuration Class More...
class | AOTrigger
Constructor to create an AOTrigger task object. More...
class | AODigitalTrigger
AO Digital trigger . More...
class | AOSignalExport
AO Signal Export Class More...
class | JY5113CITask
JY5113 Counter Input Task More...
class | CISampleClock
CI Sample Clock class More...
class | CIInternalSampleClock
CI Internal Sample Clock Configuration Class More...
class | CIImplicitSampleClock
CI Implicit Sample Clock class More...
class | CIExternalSampleClock
CI Implicit Sample Clock class More...
class | CIExternalTimebase
class | CITimebase
class | EdgeCounting
Configure CI EdgeCounting. More...
class | EdgeCountingOutEvent
Edge counting output event configuration class More...
class | PauseTrigger
Pause trigger configuration class. More...
class | FrequencyMeas
Configure CI Measure. More...
class | PeriodMeas
Configure CI Measure. More...
class | PulseMeas
Configure CI Measure. More...
class | SemiPeriodMeas
Configure CI Measure. More...
class | TwoEdgeSeparation
Configure CI Measure. More...
class | QuadEncoder
Configure CI Measure. More...
class | TwoPulseEncoder
Configure CI Measure. More...
class | CITrigger
Constructor to create an CITrigger task object. More...
class | CIDigitalTrigger
CI Digital trigger . More...
class | CISignalExport
CI Signal Export Class More...
class | JY5113COTask
JY5113 Counter Output Task More...
class | COTrigger
Constructor to create an COTrigger task object. More...
class | CODigitalTrigger
CO Digital trigger . More...
class | COPulse
Pulse Parameter More...
class | COExternalTimebase
class | COTimebase
class | COSignalExport
CO Signal Export Class More...
class | JY5113DITask
JY5113 Digital Iuput Task More...
class | DIChannel
DI Channel parameter class . More...
class | DISampleClock
Sample clock configuration class More...
class | DIExternalSampleClock
External Sample Clock Configuration Class More...
class | DISignalExport
DI Signal Export Class More...
class | DITrigger
Constructor to create an DITrigger task object. More...
class | DIDigitalTrigger
DI Digital trigger . More...
class | JY5113DOTask
JY5113 Digital Output Task More...
class | DOChannel
DO Channel parameter class . More...
class | DOSampleClock
Sample clock configuration class More...
class | DOExternalSampleClock
External Sample Clock Configuration Class More...
class | DOTrigger
Constructor to create an DOTrigger task object. More...
class | DODigitalTrigger
DO Digital trigger More...
class | DOSignalExport
DO Signal Export Class More...

Enumerations

enum class | AIBandWidth { _39KHz = JY5113Import.JY5113_AI_BandWidth_39K , _15KHz = JY5113Import.JY5113_AI_BandWidth_15K , _80KHz = JY5113Import.JY5113_AI_BandWidth_80K }
AI BandWidth More...
enum class | AITriggerType { Immediate = JY5113Import.JY5113_TriggerType_Immediately , Digital = JY5113Import.JY5113_TriggerType_Digital , Analog = JY5113Import.JY5113_TriggerType_Analog , Soft = JY5113Import.JY5113_TriggerType_Soft }
Trigger Type: Digital/Analog/Immediate More...
enum class | AIDigitalTriggerEdge { Rising = JY5113Import.JY5113_DigitalTriggerEdge_Rising , Falling = JY5113Import.JY5113_DigitalTriggerEdge_Falling }
AI Digital Trigger Edge More...
enum class | AIAnalogTriggerEdge { Rising = JY5113Import.JY5113_AnalogTriggerEdge_Rising , Falling = JY5113Import.JY5113_AnalogTriggerEdge_Falling }
AI Analog Trigger Edge More...
enum class | AIAnalogWindowCondition { Entering = JY5113Import.JY5113_AnalogWindowCondition_Entering , Leaving = JY5113Import.JY5113_AnalogWindowCondition_Leaving }
AI Analog Window Trigger Condition More...
enum class | AIAnalogTriggerComparator { Edge , Hysteresis , Window }
AI Analog Trigger Comparator More...
enum class | AIMode { Single = JY5113Import.JY5113_AI_Single , Finite = JY5113Import.JY5113_AI_Finite , Continuous = JY5113Import.JY5113_AI_Continuous , Record = 0x3 }
AIMode More...
enum class | AITerminal { RSE = JY5113Import.JY5113_AI_RSE , Differential = JY5113Import.JY5113_AI_Diff }
AITerminal More...
enum class | AISampleClockSource { Internal = JY5113Import.JY5113_AI_InternalClock , External = JY5113Import.JY5113_AI_ExternalClock }
AIClockSource Type More...
enum class ClockTerminal {
PFI0 = JY5113Import.JY5113_Clock_PFI_0 , PFI1 = JY5113Import.JY5113_Clock_PFI_1 , PFI2 = JY5113Import.JY5113_Clock_PFI_2 , PFI3 = JY5113Import.JY5113_Clock_PFI_3 ,
PFI4 = JY5113Import.JY5113_Clock_PFI_4 , PFI5 = JY5113Import.JY5113_Clock_PFI_5 , PFI6 = JY5113Import.JY5113_Clock_PFI_6 , PFI7 = JY5113Import.JY5113_Clock_PFI_7 ,
PFI8 = JY5113Import.JY5113_Clock_PFI_8 , PFI9 = JY5113Import.JY5113_Clock_PFI_9 , PFI10 = JY5113Import.JY5113_Clock_PFI_10 , PFI11 = JY5113Import.JY5113_Clock_PFI_11 ,
PFI12 = JY5113Import.JY5113_Clock_PFI_12 , PFI13 = JY5113Import.JY5113_Clock_PFI_13 , PFI14 = JY5113Import.JY5113_Clock_PFI_14 , PFI15 = JY5113Import.JY5113_Clock_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_Clock_PXI_Trig_0 , PXI_Trig1 = JY5113Import.JY5113_Clock_PXI_Trig_1 , PXI_Trig2 = JY5113Import.JY5113_Clock_PXI_Trig_2 , PXI_Trig3 = JY5113Import.JY5113_Clock_PXI_Trig_3 ,
PXI_Trig4 = JY5113Import.JY5113_Clock_PXI_Trig_4 , PXI_Trig5 = JY5113Import.JY5113_Clock_PXI_Trig_5 , PXI_Trig6 = JY5113Import.JY5113_Clock_PXI_Trig_6 , PXI_Trig7 = JY5113Import.JY5113_Clock_PXI_Trig_7 ,
AI_SampleClock = JY5113Import.JY5113_Inter_AI_SampleClock , AO_SampleClock = JY5113Import.JY5113_Inter_AO_SampleClock , DI_SampleClock = JY5113Import.JY5113_Inter_DI_SampleClock , DO_SampleClock = JY5113Import.JY5113_Inter_DO_SampleClock ,
CI0_SampleClock = JY5113Import.JY5113_Inter_CI_0_SampleClock , CI1_SampleClock = JY5113Import.JY5113_Inter_CI_1_SampleClock , CI2_SampleClock = JY5113Import.JY5113_Inter_CI_2_SampleClock , CI3_SampleClock = JY5113Import.JY5113_Inter_CI_3_SampleClock ,
CO0_Output = JY5113Import.JY5113_Inter_CO_0_Output , CO1_Output = JY5113Import.JY5113_Inter_CO_1_Output , CO2_Output = JY5113Import.JY5113_Inter_CO_2_Output , CO3_Output = JY5113Import.JY5113_Inter_CO_3_Output
}
External Sample Clock Terminal More...
enum class | AITriggerMode { Start = JY5113Import.JY5113_StartTrigger , Reference =JY5113Import.JY5113_ReferenceTrigger }
AI Trigger Mode More...
enum class AIAnalogTriggerSource {
Channel_0 , Channel_1 , Channel_2 , Channel_3 ,
Channel_4 , Channel_5 , Channel_6 , Channel_7 ,
Channel_8 , Channel_9 , Channel_10 , Channel_11 ,
Channel_12 , Channel_13 , Channel_14 , Channel_15 ,
Channel_16 , Channel_17 , Channel_18 , Channel_19 ,
Channel_20 , Channel_21 , Channel_22 , Channel_23 ,
Channel_24 , Channel_25 , Channel_26 , Channel_27 ,
Channel_28 , Channel_29 , Channel_30 , Channel_31 ,
Channel_32 , Channel_33 , Channel_34 , Channel_35 ,
Channel_36 , Channel_37 , Channel_38 , Channel_39 ,
Channel_40 , Channel_41 , Channel_42 , Channel_43 ,
Channel_44 , Channel_45 , Channel_46 , Channel_47 ,
Channel_48 , Channel_49 , Channel_50 , Channel_51 ,
Channel_52 , Channel_53 , Channel_54 , Channel_55 ,
Channel_56 , Channel_57 , Channel_58 , Channel_59 ,
Channel_60 , Channel_61 , Channel_62 , Channel_63
}
AI Analog Trigger Source More...
enum class AIDigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig , AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , DO_StartTrig = JY5113Import.JY5113_DO_StartTrig ,
CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig , CIO_2_StartTrig = JY5113Import.JY5113_CIO2_StartTrig , CIO_3_StartTrig = JY5113Import.JY5113_CIO3_StartTrig ,
CO0_Output = JY5113Import.JY5113_CO_0_Out , CO1_Output = JY5113Import.JY5113_CO_1_Out , CO2_Output = JY5113Import.JY5113_CO_2_Out , CO3_Output = JY5113Import.JY5113_CO_3_Out
}
AI Digital Trigger Source More...
enum class | FileFormat { Bin }
Streaming file format More...
enum class | RecordMode { Finite , Infinite }
Two stream mode from enum Finite/Infinite More...
enum class | SyncTopology { Independent , Master , Slave }
Synchronization board configuration More...
enum class SyncTriggerRouting {
NONE = -1 , PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7
}
Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口) More...
enum class SyncPulseRouting {
NONE = -1 , PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 ,
PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 , PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 ,
PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7
}
Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号) More...
enum class | AISignalExportSource { StartTrig = JY5113Import.SignalSource_JY5113_AI_StartTrig , ReferenceTrig = JY5113Import.SignalSource_JY5113_AI_ReferenceTrig , SampleClock = JY5113Import.SignalSource_JY5113_AI_SampleClock }
AI Signal Export Source More...
enum class SignalExportDestination {
PFI0 = JY5113Import.SignalDestination_JY5113_PFI0 , PFI1 = JY5113Import.SignalDestination_JY5113_PFI1 , PFI2 = JY5113Import.SignalDestination_JY5113_PFI2 , PFI3 = JY5113Import.SignalDestination_JY5113_PFI3 ,
PFI4 = JY5113Import.SignalDestination_JY5113_PFI4 , PFI5 = JY5113Import.SignalDestination_JY5113_PFI5 , PFI6 = JY5113Import.SignalDestination_JY5113_PFI6 , PFI7 = JY5113Import.SignalDestination_JY5113_PFI7 ,
PFI8 = JY5113Import.SignalDestination_JY5113_PFI8 , PFI9 = JY5113Import.SignalDestination_JY5113_PFI9 , PFI10 = JY5113Import.SignalDestination_JY5113_PFI10 , PFI11 = JY5113Import.SignalDestination_JY5113_PFI11 ,
PFI12 = JY5113Import.SignalDestination_JY5113_PFI12 , PFI13 = JY5113Import.SignalDestination_JY5113_PFI13 , PFI14 = JY5113Import.SignalDestination_JY5113_PFI14 , PFI15 = JY5113Import.SignalDestination_JY5113_PFI15 ,
PXI_Trig0 = JY5113Import.SignalDestination_JY5113_PXITrig0 , PXI_Trig1 = JY5113Import.SignalDestination_JY5113_PXITrig1 , PXI_Trig2 = JY5113Import.SignalDestination_JY5113_PXITrig2 , PXI_Trig3 = JY5113Import.SignalDestination_JY5113_PXITrig3 ,
PXI_Trig4 = JY5113Import.SignalDestination_JY5113_PXITrig4 , PXI_Trig5 = JY5113Import.SignalDestination_JY5113_PXITrig5 , PXI_Trig6 = JY5113Import.SignalDestination_JY5113_PXITrig6 , PXI_Trig7 = JY5113Import.SignalDestination_JY5113_PXITrig7
}
输出目的终端 More...
enum class | AODigitalTriggerEdge { Rising , Falling }
AO Digital Trigger Edge More...
enum class AODigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig , CO_0_Out = JY5113Import.JY5113_CO_0_Out ,
CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
AO Digital trigger source. More...
enum class | OutputCompleteState { Zero , Hold }
Output Complete State More...
enum class | AOMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
AOMode More...
enum class | AOSampleClockSource { Internal , External }
AO Sample Clock Source More...
enum class | AOSignalExportSource { StartTrig = JY5113Import.SignalSource_JY5113_AO_StartTrig , SampleClock = JY5113Import.SignalSource_JY5113_AO_SampleClock }
SourceSignal More...
enum class | AOTriggerType { Immediate = JY5113Import.JY5113_TriggerType_Immediately , Digital = JY5113Import.JY5113_TriggerType_Digital , Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class | CountDirection { Up = JY5113Import.JY5113_CI_Count_Up , Down = JY5113Import.JY5113_CI_Count_Down , External = JY5113Import.JY5113_CI_Count_External }
Counter direction. More...
enum class | CIMode { Single = 2 , Finite = 0 , Continuous = 1 }
CIMode More...
enum class CIType {
EdgeCounting , Period , Frequency , Pulse ,
SemiPeriod , TwoEdgeSeparation , QuadEncoder , TwoPulseEncoder
}
Counter Input Application Type. More...
enum class | CISampleClockSource { Implicit = JY5113Import.JY5113_CI_ImplicitClock , Internal = JY5113Import.JY5113_CI_InternalClock , External = JY5113Import.JY5113_CI_ExternalClock }
CI Sample Clock Source. More...
enum class | EdgeType { Rising , Falling , Any }
Edge Type More...
enum class | CITimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum class | EdgeCntOunEvtIdleState { LowLevel = 0 , HighLevel = 1 }
Output idle state when the event has not occurred. More...
enum class | LevelPolarity { LowLevel = 0 , HighLevel = 1 , None = 2 }
Level Polarity More...
enum class | ValueReturnMode { TwoValue , OneValue }
TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type. More...
enum class | QuadEncodingType { X1 , X2 , X4 }
Quadrature Encoding Type More...
enum class | CITriggerType { Immediate = JY5113Import.JY5113_CIO_Immediately , Digital = JY5113Import.JY5113_CIO_Digital , Soft = JY5113Import.JY5113_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class CIDigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig
}
CI Digital trigger source. More...
enum class | CIDigitalTriggerEdge { Rising , Falling }
CI Digital Trigger Edge More...
enum class InputTerminal {
PFI0 = JY5113Import.JY5113_PFI0_Input , PFI1 = JY5113Import.JY5113_PFI1_Input , PFI2 = JY5113Import.JY5113_PFI2_Input , PFI3 = JY5113Import.JY5113_PFI3_Input ,
PFI4 = JY5113Import.JY5113_PFI4_Input , PFI5 = JY5113Import.JY5113_PFI5_Input , PFI6 = JY5113Import.JY5113_PFI6_Input , PFI7 = JY5113Import.JY5113_PFI7_Input ,
PFI8 = JY5113Import.JY5113_PFI8_Input , PFI9 = JY5113Import.JY5113_PFI9_Input , PFI10 = JY5113Import.JY5113_PFI10_Input , PFI11 = JY5113Import.JY5113_PFI11_Input ,
PFI12 = JY5113Import.JY5113_PFI12_Input , PFI13 = JY5113Import.JY5113_PFI13_Input , PFI14 = JY5113Import.JY5113_PFI14_Input , PFI15 = JY5113Import.JY5113_PFI15_Input ,
PXI_Trig0 = JY5113Import.JY5113_PXI_Trig0_Input , PXI_Trig1 = JY5113Import.JY5113_PXI_Trig1_Input , PXI_Trig2 = JY5113Import.JY5113_PXI_Trig2_Input , PXI_Trig3 = JY5113Import.JY5113_PXI_Trig3_Input ,
PXI_Trig4 = JY5113Import.JY5113_PXI_Trig4_Input , PXI_Trig5 = JY5113Import.JY5113_PXI_Trig5_Input , PXI_Trig6 = JY5113Import.JY5113_PXI_Trig6_Input , PXI_Trig7 = JY5113Import.JY5113_PXI_Trig7_Input ,
AI_SampleClock = JY5113Import.JY5113_IN_AI_SampleClock , AO_SampleClock = JY5113Import.JY5113_IN_AO_SampleClock , DI_SampleClock = JY5113Import.JY5113_IN_DI_SampleClock , DO_SampleClock = JY5113Import.JY5113_IN_DO_SampleClock ,
CO_0_OutPut = JY5113Import.JY5113_IN_CO_0_Output , CO_1_OutPut = JY5113Import.JY5113_IN_CO_1_Output , CO_2_OutPut = JY5113Import.JY5113_IN_CO_2_Output , CO_3_OutPut = JY5113Import.JY5113_IN_CO_3_Output ,
Timebase_100MHz = JY5113Import.JY5113_IN_CIO_100MHz , Timebase_5MHz = JY5113Import.JY5113_IN_CIO_5MHz , Timebase_100kHz = JY5113Import.JY5113_IN_CIO_100kHz
}
输入终端 More...
enum class IOTerminal {
PFI0 = JY5113Import.JY5113_DigitalTriggerOut_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerOut_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerOut_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerOut_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerOut_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerOut_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerOut_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerOut_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerOut_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerOut_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerOut_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerOut_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerOut_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerOut_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerOut_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerOut_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_TriggerOut_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_TriggerOut_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_TriggerOut_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_TriggerOut_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_TriggerOut_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_TriggerOut_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_TriggerOut_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_TriggerOut_PXI_7 ,
None = 24
}
IO终端=信号的目的地（共24个） More...
enum class | CISignalExportSource { StartTrig , SampleClock }
SourceSignal More...
enum class | COIdleState { HighLevel = JY5113Import.JY5113_HighLevel , LowLevel = JY5113Import.JY5113_LowLevel }
Idle state when pulse output before start and after stop. More...
enum class | COMode { Single = 3 , Finite = 0 , ContinuousNoWrapping = 2 , ContinuousWrapping = 1 }
CO output mode More...
enum class | COTriggerType { Immediate = JY5113Import.JY5113_CIO_Immediately , Digital = JY5113Import.JY5113_CIO_Digital , Soft = JY5113Import.JY5113_CIO_Soft }
TriggerType Digital/Immediate/Soft More...
enum class CODigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
CO_0_Out = JY5113Import.JY5113_CO_0_Out , CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
CO Digital trigger source. More...
enum class | CODigitalTriggerEdge { Rising , Falling }
CO Digital Trigger Edge More...
enum class | COPulseType { DutyCycleFrequency , HighLowTime , HighLowTick }
Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick. More...
enum class | COTimebaseSource { Internal100MHz = 0 , Internal5MHz = 1 , Internal100kHz = 2 , External = 3 }
enum class | COSignalExportSource { StartTrig , Output }
SourceSignal More...
enum class | DISampleClockSource { Internal , External }
DI Sample Clock Source More...
enum class | DIMode { Single = 2 , Finite = 0 , Continuous = 1 }
DIMode More...
enum class | DISignalExportSource { StartTrig = JY5113Import.SignalSource_JY5113_DI_StartTrig , ReferenceTrig = JY5113Import.SignalSource_JY5113_DI_ReferenceTrig , SampleClock = JY5113Import.SignalSource_JY5113_DI_SampleClock }
SourceSignal More...
enum class | DITriggerMode { Start , Reference }
DI Trigger Mode More...
enum class | DITriggerType { Immediate = JY5113Import.JY5113_TriggerType_Immediately , Digital = JY5113Import.JY5113_TriggerType_Digital , Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class DIDigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
CO_0_Out = JY5113Import.JY5113_CO_0_Out , CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
DI Digital trigger source. More...
enum class | DIDigitalTriggerEdge { Rising , Falling }
DI Digital Trigger Edge More...
enum class | DOSampleClockSource { Internal , External }
DO Sample Clock Source More...
enum class | DOMode { Single = 3 , Finite = 0 , ContinuousWrapping = 1 , ContinuousNoWrapping = 2 }
DOMode More...
enum class | DODigitalTriggerEdge { Rising , Falling }
DO Digital Trigger Edge More...
enum class DODigitalTriggerSource {
PFI0 = JY5113Import.JY5113_DigitalTriggerSource_PFI_0 , PFI1 = JY5113Import.JY5113_DigitalTriggerSource_PFI_1 , PFI2 = JY5113Import.JY5113_DigitalTriggerSource_PFI_2 , PFI3 = JY5113Import.JY5113_DigitalTriggerSource_PFI_3 ,
PFI4 = JY5113Import.JY5113_DigitalTriggerSource_PFI_4 , PFI5 = JY5113Import.JY5113_DigitalTriggerSource_PFI_5 , PFI6 = JY5113Import.JY5113_DigitalTriggerSource_PFI_6 , PFI7 = JY5113Import.JY5113_DigitalTriggerSource_PFI_7 ,
PFI8 = JY5113Import.JY5113_DigitalTriggerSource_PFI_8 , PFI9 = JY5113Import.JY5113_DigitalTriggerSource_PFI_9 , PFI10 = JY5113Import.JY5113_DigitalTriggerSource_PFI_10 , PFI11 = JY5113Import.JY5113_DigitalTriggerSource_PFI_11 ,
PFI12 = JY5113Import.JY5113_DigitalTriggerSource_PFI_12 , PFI13 = JY5113Import.JY5113_DigitalTriggerSource_PFI_13 , PFI14 = JY5113Import.JY5113_DigitalTriggerSource_PFI_14 , PFI15 = JY5113Import.JY5113_DigitalTriggerSource_PFI_15 ,
PXI_Trig0 = JY5113Import.JY5113_DigitalTriggerSource_PXI_0 , PXI_Trig1 = JY5113Import.JY5113_DigitalTriggerSource_PXI_1 , PXI_Trig2 = JY5113Import.JY5113_DigitalTriggerSource_PXI_2 , PXI_Trig3 = JY5113Import.JY5113_DigitalTriggerSource_PXI_3 ,
PXI_Trig4 = JY5113Import.JY5113_DigitalTriggerSource_PXI_4 , PXI_Trig5 = JY5113Import.JY5113_DigitalTriggerSource_PXI_5 , PXI_Trig6 = JY5113Import.JY5113_DigitalTriggerSource_PXI_6 , PXI_Trig7 = JY5113Import.JY5113_DigitalTriggerSource_PXI_7 ,
AI_StartTrig = JY5113Import.JY5113_AI_StartTrig , AI_ReferenceTrig = JY5113Import.JY5113_AI_ReferenceTrig , DI_StartTrig = JY5113Import.JY5113_DI_StartTrig , DI_ReferenceTrig = JY5113Import.JY5113_DI_ReferenceTrig ,
AO_StartTrig = JY5113Import.JY5113_AO_StartTrig , DO_StartTrig = JY5113Import.JY5113_DO_StartTrig , CIO_0_StartTrig = JY5113Import.JY5113_CIO0_StartTrig , CIO_1_StartTrig = JY5113Import.JY5113_CIO1_StartTrig ,
CO_0_Out = JY5113Import.JY5113_CO_0_Out , CO_1_Out = JY5113Import.JY5113_CO_1_Out
}
DO Digital trigger source More...
enum class | DOTriggerType { Immediate = JY5113Import.JY5113_TriggerType_Immediately , Digital = JY5113Import.JY5113_TriggerType_Digital , Soft = JY5113Import.JY5113_TriggerType_Soft }
TriggerType Digital/Immediate/Soft More...
enum class | DOSignalExportSource { StartTrig = JY5113Import.SignalSource_JY5113_DO_StartTrig , SampleClock = JY5113Import.SignalSource_JY5113_DO_SampleClock }
SourceSignal More...

Enumeration Type Documentation

◆ AIAnalogTriggerComparator

enum JY5113.AIAnalogTriggerComparator
strong

AI Analog Trigger Comparator

Enumerator
Edge | Edge Comparator
Hysteresis | Hysteresis Comparator
Window | Window Comparator

◆ AIAnalogTriggerEdge

enum JY5113.AIAnalogTriggerEdge
strong

AI Analog Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIAnalogTriggerSource

enum JY5113.AIAnalogTriggerSource
strong

AI Analog Trigger Source

Enumerator
Channel_0 | channel 0
Channel_1 | channel 1
Channel_2 | channel 2
Channel_3 | channel 3
Channel_4 | channel 4
Channel_5 | channel 5
Channel_6 | channel 6
Channel_7 | channel 7
Channel_8 | channel 8
Channel_9 | channel 9
Channel_10 | channel 10
Channel_11 | channel 11
Channel_12 | channel 12
Channel_13 | channel 13
Channel_14 | channel 14
Channel_15 | channel 15
Channel_16 | channel 16
Channel_17 | channel 17
Channel_18 | channel 18
Channel_19 | channel 19
Channel_20 | channel 20
Channel_21 | channel 21
Channel_22 | channel 22
Channel_23 | channel 23
Channel_24 | channel 24
Channel_25 | channel 25
Channel_26 | channel 26
Channel_27 | channel 27
Channel_28 | channel 28
Channel_29 | channel 29
Channel_30 | channel 30
Channel_31 | channel 31
Channel_32 | channel 32
Channel_33 | channel 33
Channel_34 | channel 34
Channel_35 | channel 35
Channel_36 | channel 36
Channel_37 | channel 37
Channel_38 | channel 38
Channel_39 | channel 39
Channel_40 | channel 40
Channel_41 | channel 41
Channel_42 | channel 42
Channel_43 | channel 43
Channel_44 | channel 44
Channel_45 | channel 45
Channel_46 | channel 46
Channel_47 | channel 47
Channel_48 | channel 48
Channel_49 | channel 49
Channel_50 | channel 50
Channel_51 | channel 51
Channel_52 | channel 52
Channel_53 | channel 53
Channel_54 | channel 54
Channel_55 | channel 55
Channel_56 | channel 56
Channel_57 | channel 57
Channel_58 | channel 58
Channel_59 | channel 59
Channel_60 | channel 60
Channel_61 | channel 61
Channel_62 | channel 62
Channel_63 | channel 63

◆ AIAnalogWindowCondition

enum JY5113.AIAnalogWindowCondition
strong

AI Analog Window Trigger Condition

Enumerator
Entering | Rising
Leaving | Falling

◆ AIBandWidth

enum JY5113.AIBandWidth
strong

AI BandWidth

Enumerator
_39KHz | 39KHz BandWidth
_15KHz | 15KHz BandWidth
_80KHz | 80KHz BandWidth

◆ AIDigitalTriggerEdge

enum JY5113.AIDigitalTriggerEdge
strong

AI Digital Trigger Edge

Enumerator
Rising | Rising
Falling | Falling

◆ AIDigitalTriggerSource

enum JY5113.AIDigitalTriggerSource
strong

AI Digital Trigger Source

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
AO_StartTrig | AO_StartTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig
CIO_2_StartTrig | CI2_StartTrig
CIO_3_StartTrig | CI3_StartTrig
CO0_Output | CO0_Output
CO1_Output | CO1_Output
CO2_Output | CO2_Output
CO3_Output | CO3_Output

◆ AIMode

enum JY5113.AIMode
strong

AIMode

Enumerator
Single | 单点模式
Finite | Finite
Continuous | Continuous
Record | Record

◆ AISampleClockSource

enum JY5113.AISampleClockSource
strong

AIClockSource Type

Enumerator
Internal | Internal
External | External

◆ AISignalExportSource

enum JY5113.AISignalExportSource
strong

AI Signal Export Source

Enumerator
StartTrig | AI_StartTrig
ReferenceTrig | AI_ReferenceTrig
SampleClock | AI_SampleClock

◆ AITerminal

enum JY5113.AITerminal
strong

AITerminal

Enumerator
RSE | RSE
Differential | Differential

◆ AITriggerMode

enum JY5113.AITriggerMode
strong

AI Trigger Mode

Enumerator
Start | Start Trigger Mode
Reference | Reference Trigger Mode，Valid when JY5113AITask.Mode is AIMode.Finite

◆ AITriggerType

enum JY5113.AITriggerType
strong

Trigger Type: Digital/Analog/Immediate

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Analog | Analog Trigger
Soft | Soft Trigger

◆ AODigitalTriggerEdge

enum JY5113.AODigitalTriggerEdge
strong

AO Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ AODigitalTriggerSource

enum JY5113.AODigitalTriggerSource
strong

AO Digital trigger source.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig
CO_0_Out | CI0_StartTrig
CO_1_Out | CI1_StartTrig

◆ AOMode

enum JY5113.AOMode
strong

AOMode

Enumerator
Single | Single
Finite | Finite
ContinuousNoWrapping | ContinuousNoWrapping
ContinuousWrapping | ContinuousWrapping

◆ AOSampleClockSource

enum JY5113.AOSampleClockSource
strong

AO Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ AOSignalExportSource

enum JY5113.AOSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | AO_StartTrig
SampleClock | AO_SampleClock

◆ AOTriggerType

enum JY5113.AOTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ CIDigitalTriggerEdge

enum JY5113.CIDigitalTriggerEdge
strong

CI Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ CIDigitalTriggerSource

enum JY5113.CIDigitalTriggerSource
strong

CI Digital trigger source.

(共32个）

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
AO_StartTrig | AO_StartTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig

◆ CIMode

enum JY5113.CIMode
strong

CIMode

Enumerator
Single | Single
Finite | Finite
Continuous | Continuous

◆ CISampleClockSource

enum JY5113.CISampleClockSource
strong

CI Sample Clock Source.

Enumerator
Implicit | Implicit
Internal | Internal
External | External

◆ CISignalExportSource

enum JY5113.CISignalExportSource
strong

SourceSignal

Enumerator
StartTrig | CI_StartTrig
SampleClock | CI_SampleClock

◆ CITimebaseSource

enum JY5113.CITimebaseSource
strong

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ CITriggerType

enum JY5113.CITriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ CIType

enum JY5113.CIType
strong

Counter Input Application Type.

Enumerator
EdgeCounting | Edge Counting
Period | Period Measure
Frequency | Frequenc Measure
Pulse | Pulse Measure
SemiPeriod | SemiPeriod Measure
TwoEdgeSeparation | TwoEdgeSeparation Measure
QuadEncoder | QuadEncoder
TwoPulseEncoder | EncoderTwoPulse

◆ ClockTerminal

enum JY5113.ClockTerminal
strong

External Sample Clock Terminal

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_SampleClock | AI SampleClock
AO_SampleClock | AO SampleClock
DI_SampleClock | DI SampleClock
DO_SampleClock | DO SampleClock
CI0_SampleClock | CI0_SampleClock
CI1_SampleClock | CI1_SampleClock
CI2_SampleClock | CI2_SampleClock
CI3_SampleClock | CI3_SampleClock
CO0_Output | CO0_Output
CO1_Output | CO1_Output
CO2_Output | CO2_Output
CO3_Output | CO3_Output

◆ CODigitalTriggerEdge

enum JY5113.CODigitalTriggerEdge
strong

CO Digital Trigger Edge

Enumerator
Rising | Rising Edge
Falling | Falling Edge

◆ CODigitalTriggerSource

enum JY5113.CODigitalTriggerSource
strong

CO Digital trigger source.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
AO_StartTrig | AO_StartTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig
CO_0_Out | CI0_StartTrig
CO_1_Out | CI1_StartTrig

◆ COIdleState

enum JY5113.COIdleState
strong

Idle state when pulse output before start and after stop.

Enumerator
HighLevel | Idle state is high level.
LowLevel | Idle state is low level.

◆ COMode

enum JY5113.COMode
strong

CO output mode

Enumerator
Single | Single pulse output
Finite | Finite
ContinuousNoWrapping | ContinuousNoWrapping
ContinuousWrapping | ContinuousWrapping

◆ COPulseType

enum JY5113.COPulseType
strong

Set pulse type.enum DutyCycleFrequencyenum/HighLowTime/HighLowTick.

Enumerator
DutyCycleFrequency | Configure CO output pulse according to its DutyCycle and Freqency.
HighLowTime | Configure CO output pulse according to duration of its high/low voltage levels.
HighLowTick | Configure CO output pulse according to its high/low tick level.

◆ COSignalExportSource

enum JY5113.COSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | CI_StartTrig
Output | CO_Output

◆ COTimebaseSource

enum JY5113.COTimebaseSource
strong

时基源

Timebase source

Enumerator
Internal100MHz | 内部100MHz时基 Internal 100MHz Timebase
Internal5MHz | 内部5MHz时基 Internal 5MHz Timebase
Internal100kHz | 内部100kHz时基 Internal 100kHz Timebase
External | 外部时基 External Timebase

◆ COTriggerType

enum JY5113.COTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ CountDirection

enum JY5113.CountDirection
strong

Counter direction.

enum Up/Down/External

Enumerator
Up | Counter increases
Down | Counter decreases
External | External signal control counter direction. If External signal is highlevel counter increases, or lowlevel counter decreases.

◆ DIDigitalTriggerEdge

enum JY5113.DIDigitalTriggerEdge
strong

DI Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ DIDigitalTriggerSource

enum JY5113.DIDigitalTriggerSource
strong

DI Digital trigger source.

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
AO_StartTrig | AO_StartTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig
CO_0_Out | CI0_StartTrig
CO_1_Out | CI1_StartTrig

◆ DIMode

enum JY5113.DIMode
strong

DIMode

Enumerator
Single | Single
Finite | Finite
Continuous | Continuous

◆ DISampleClockSource

enum JY5113.DISampleClockSource
strong

DI Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ DISignalExportSource

enum JY5113.DISignalExportSource
strong

SourceSignal

Enumerator
StartTrig | DI_StartTrig
ReferenceTrig | DI_ReferenceTrig
SampleClock | DI_SampleClock

◆ DITriggerMode

enum JY5113.DITriggerMode
strong

DI Trigger Mode

Enumerator
Start | Start Trigger
Reference | Reference Trigger，only for finite acquisition mode

◆ DITriggerType

enum JY5113.DITriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ DODigitalTriggerEdge

enum JY5113.DODigitalTriggerEdge
strong

DO Digital Trigger Edge

Enumerator
Rising | RisingEdge
Falling | FallingEdge

◆ DODigitalTriggerSource

enum JY5113.DODigitalTriggerSource
strong

DO Digital trigger source

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_StartTrig | AI_StartTrig
AI_ReferenceTrig | AI_ReferenceTrig
DI_StartTrig | DI_StartTrig
DI_ReferenceTrig | DI_ReferenceTrig
AO_StartTrig | AO_StartTrig
DO_StartTrig | AO_StartTrig
CIO_0_StartTrig | CI0_StartTrig
CIO_1_StartTrig | CI1_StartTrig
CO_0_Out | CI0_StartTrig
CO_1_Out | CI1_StartTrig

◆ DOMode

enum JY5113.DOMode
strong

DOMode

Enumerator
Single | Single
Finite | Finite
ContinuousWrapping | ContinuousNoWrapping
ContinuousNoWrapping | ContinuousWrapping

◆ DOSampleClockSource

enum JY5113.DOSampleClockSource
strong

DO Sample Clock Source

Enumerator
Internal | Internal Clock Source
External | External Clock Source

◆ DOSignalExportSource

enum JY5113.DOSignalExportSource
strong

SourceSignal

Enumerator
StartTrig | DO_StartTrig
SampleClock | DO_SampleClock

◆ DOTriggerType

enum JY5113.DOTriggerType
strong

TriggerType Digital/Immediate/Soft

Enumerator
Immediate | Immediate Trigger
Digital | Digital Trigger
Soft | Soft Trigger

◆ EdgeCntOunEvtIdleState

enum JY5113.EdgeCntOunEvtIdleState
strong

Output idle state when the event has not occurred.

Enumerator
LowLevel | Idle state is low level.
HighLevel | Idle state is high level.

◆ EdgeType

enum JY5113.EdgeType
strong

Edge Type

Enumerator
Rising | Rising Edge
Falling | Falling Edge
Any | Any Edge

◆ FileFormat

enum JY5113.FileFormat
strong

Streaming file format

Enumerator
Bin

Binary file format

◆ InputTerminal

enum JY5113.InputTerminal
strong

输入终端

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
AI_SampleClock | AI SampleClock
AO_SampleClock | AO SampleClock
DI_SampleClock | DI SampleClock
DO_SampleClock | DO SampleClock
CO_0_OutPut | CO_0_OutPut
CO_1_OutPut | CO_1_OutPut
CO_2_OutPut | CO_2_OutPut
CO_3_OutPut | CO_3_OutPut
Timebase_100MHz | Timebase_100MHz
Timebase_5MHz | Timebase_5MHz
Timebase_100kHz | Timebase_100kHz

◆ IOTerminal

enum JY5113.IOTerminal
strong

IO终端=信号的目的地（共24个）

Enumerator
PFI0 | PFI_0
PFI1 | PFI_1
PFI2 | PFI_2
PFI3 | PFI_3
PFI4 | PFI_4
PFI5 | PFI_5
PFI6 | PFI_6
PFI7 | PFI_7
PFI8 | PFI_8
PFI9 | PFI_9
PFI10 | PFI_10
PFI11 | PFI_11
PFI12 | PFI_12
PFI13 | PFI_13
PFI14 | PFI_14
PFI15 | PFI_15
PXI_Trig0 | PXI Trig 0
PXI_Trig1 | PXI Trig 1
PXI_Trig2 | PXI Trig 2
PXI_Trig3 | PXI Trig 3
PXI_Trig4 | PXI Trig 4
PXI_Trig5 | PXI Trig 5
PXI_Trig6 | PXI Trig 6
PXI_Trig7 | PXI Trig 7
None | None

◆ LevelPolarity

enum JY5113.LevelPolarity
strong

Level Polarity

Enumerator
LowLevel | Low level
HighLevel | High level
None | No active polarity.

◆ OutputCompleteState

enum JY5113.OutputCompleteState
strong

Output Complete State

Enumerator
Zero | Output Complete Zero
Hold | Output Complete Hold in The last point

◆ QuadEncodingType

enum JY5113.QuadEncodingType
strong

Quadrature Encoding Type

Enumerator
X1 | X1
X2 | X2
X4 | X4

◆ RecordMode

enum JY5113.RecordMode
strong

Two stream mode from enum Finite/Infinite

Enumerator
Finite | Finite Streaming
Infinite | InFinite Streaming

◆ SignalExportDestination

enum JY5113.SignalExportDestination
strong

输出目的终端

Enumerator
PFI0 | PFI0
PFI1 | PFI1
PFI2 | PFI2
PFI3 | PFI3
PFI4 | PFI4
PFI5 | PFI5
PFI6 | PFI6
PFI7 | PFI7
PFI8 | PFI8
PFI9 | PFI9
PFI10 | PFI10
PFI11 | PFI11
PFI12 | PFI12
PFI13 | PFI13
PFI14 | PFI14
PFI15 | PFI15
PXI_Trig0 | PXI_Trig0
PXI_Trig1 | PXI_Trig1
PXI_Trig2 | PXI_Trig2
PXI_Trig3 | PXI_Trig3
PXI_Trig4 | PXI_Trig4
PXI_Trig5 | PXI_Trig5
PXI_Trig6 | PXI_Trig6
PXI_Trig7 | PXI_Trig7

◆ SyncPulseRouting

enum JY5113.SyncPulseRouting
strong

Synchronous signal routing (the master card routes the synchronous signal to this port, and the slave card receives the synchronous signal from this port) 同步信号路由(主卡将同步信号路由到该端口，从卡从该端口接收同步信号)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7

◆ SyncTopology

enum JY5113.SyncTopology
strong

Synchronization board configuration

Enumerator
Independent | Independent, synchronization not supported
Master | master card
Slave | slave card

◆ SyncTriggerRouting

enum JY5113.SyncTriggerRouting
strong

Master card trigger signal routing (Master card routes trigger signal to this port) 主控卡触发信号路由(主控卡将触发信号路由到此端口)

Enumerator
NONE | Default NONE
PXI_Trig0 | PXI Trig0
PXI_Trig1 | PXI Trig1
PXI_Trig2 | PXI Trig2
PXI_Trig3 | PXI Trig3
PXI_Trig4 | PXI Trig4
PXI_Trig5 | PXI Trig5
PXI_Trig6 | PXI Trig6
PXI_Trig7 | PXI Trig7

◆ ValueReturnMode

enum JY5113.ValueReturnMode
strong

TwoEdgeSeparation value return mode.only for TwoEdgeSeparation type.

Enumerator
TwoValue | Return two data simultaneously. first data is gate to aux edge separation, second data is aux to gate edge separation.
OneValue | only return gate to aux edge separation


5113 C# Programming Manual: Package Functions

Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • AIAnalogTriggerComparator : JY5113
  • AIAnalogTriggerEdge : JY5113
  • AIAnalogTriggerSource : JY5113
  • AIAnalogWindowCondition : JY5113
  • AIBandWidth : JY5113
  • AIDigitalTriggerEdge : JY5113
  • AIDigitalTriggerSource : JY5113
  • AIMode : JY5113
  • AISampleClockSource : JY5113
  • AISignalExportSource : JY5113
  • AITerminal : JY5113
  • AITriggerMode : JY5113
  • AITriggerType : JY5113
  • AODigitalTriggerEdge : JY5113
  • AODigitalTriggerSource : JY5113
  • AOMode : JY5113
  • AOSampleClockSource : JY5113
  • AOSignalExportSource : JY5113
  • AOTriggerType : JY5113

- c -

  • CIDigitalTriggerEdge : JY5113
  • CIDigitalTriggerSource : JY5113
  • CIMode : JY5113
  • CISampleClockSource : JY5113
  • CISignalExportSource : JY5113
  • CITimebaseSource : JY5113
  • CITriggerType : JY5113
  • CIType : JY5113
  • ClockTerminal : JY5113
  • CODigitalTriggerEdge : JY5113
  • CODigitalTriggerSource : JY5113
  • COIdleState : JY5113
  • COMode : JY5113
  • COPulseType : JY5113
  • COSignalExportSource : JY5113
  • COTimebaseSource : JY5113
  • COTriggerType : JY5113
  • CountDirection : JY5113

- d -

  • DIDigitalTriggerEdge : JY5113
  • DIDigitalTriggerSource : JY5113
  • DIMode : JY5113
  • DISampleClockSource : JY5113
  • DISignalExportSource : JY5113
  • DITriggerMode : JY5113
  • DITriggerType : JY5113
  • DODigitalTriggerEdge : JY5113
  • DODigitalTriggerSource : JY5113
  • DOMode : JY5113
  • DOSampleClockSource : JY5113
  • DOSignalExportSource : JY5113
  • DOTriggerType : JY5113

- e -

  • EdgeCntOunEvtIdleState : JY5113
  • EdgeType : JY5113

- f -

  • FileFormat : JY5113

- i -

  • InputTerminal : JY5113
  • IOTerminal : JY5113

- l -

  • LevelPolarity : JY5113

- o -

  • OutputCompleteState : JY5113

- q -

  • QuadEncodingType : JY5113

- r -

  • RecordMode : JY5113

- s -

  • SignalExportDestination : JY5113
  • SyncPulseRouting : JY5113
  • SyncTopology : JY5113
  • SyncTriggerRouting : JY5113

- v -

  • ValueReturnMode : JY5113


5113 C# Programming Manual: Package Functions

- a -

  • AIAnalogTriggerComparator : JY5113
  • AIAnalogTriggerEdge : JY5113
  • AIAnalogTriggerSource : JY5113
  • AIAnalogWindowCondition : JY5113
  • AIBandWidth : JY5113
  • AIDigitalTriggerEdge : JY5113
  • AIDigitalTriggerSource : JY5113
  • AIMode : JY5113
  • AISampleClockSource : JY5113
  • AISignalExportSource : JY5113
  • AITerminal : JY5113
  • AITriggerMode : JY5113
  • AITriggerType : JY5113
  • AODigitalTriggerEdge : JY5113
  • AODigitalTriggerSource : JY5113
  • AOMode : JY5113
  • AOSampleClockSource : JY5113
  • AOSignalExportSource : JY5113
  • AOTriggerType : JY5113

- c -

  • CIDigitalTriggerEdge : JY5113
  • CIDigitalTriggerSource : JY5113
  • CIMode : JY5113
  • CISampleClockSource : JY5113
  • CISignalExportSource : JY5113
  • CITimebaseSource : JY5113
  • CITriggerType : JY5113
  • CIType : JY5113
  • ClockTerminal : JY5113
  • CODigitalTriggerEdge : JY5113
  • CODigitalTriggerSource : JY5113
  • COIdleState : JY5113
  • COMode : JY5113
  • COPulseType : JY5113
  • COSignalExportSource : JY5113
  • COTimebaseSource : JY5113
  • COTriggerType : JY5113
  • CountDirection : JY5113

- d -

  • DIDigitalTriggerEdge : JY5113
  • DIDigitalTriggerSource : JY5113
  • DIMode : JY5113
  • DISampleClockSource : JY5113
  • DISignalExportSource : JY5113
  • DITriggerMode : JY5113
  • DITriggerType : JY5113
  • DODigitalTriggerEdge : JY5113
  • DODigitalTriggerSource : JY5113
  • DOMode : JY5113
  • DOSampleClockSource : JY5113
  • DOSignalExportSource : JY5113
  • DOTriggerType : JY5113

- e -

  • EdgeCntOunEvtIdleState : JY5113
  • EdgeType : JY5113

- f -

  • FileFormat : JY5113

- i -

  • InputTerminal : JY5113
  • IOTerminal : JY5113

- l -

  • LevelPolarity : JY5113

- o -

  • OutputCompleteState : JY5113

- q -

  • QuadEncodingType : JY5113

- r -

  • RecordMode : JY5113

- s -

  • SignalExportDestination : JY5113
  • SyncPulseRouting : JY5113
  • SyncTopology : JY5113
  • SyncTriggerRouting : JY5113

- v -

  • ValueReturnMode : JY5113


5113 C# Programming Manual: Packages

Packages
Here are the packages with brief descriptions (if available):
[detail level 12]
▼N JY5113 |
C JY5113AITask | JY5113 Analog Input Task
C AIChannel | AI Channel parameter class
C AIAnalogHysteresisComparator | AI Analog Hysteresis Comparatorr
C AIAnalogWindowComparator | AI Analog Window Comparatorr
C AIAnalogEdgeComparator | AI Analog Edge Comparator
C AISampleClock | Sample clock configuration class
C AIExternalSampleClock | External Sample Clock Configuration Class
C AITrigger | AI Trigger class
C AIDigitalTrigger | AI Digital Trigger
C AIAnalogTrigger | AI Analog Trigger
C AIRecord | AI Record class
C AIAdvanced | AI Advance parameter
C DSMode | DS Mode Class Paraments
C AISync | Configure sync signal
C AISignalExport | AI Signal Export Class
C JY5113AOTask | JY5113 Analog Ouput Task
C AOChannel | AO Channel parameter class
C AOSampleClock | AO Sample clock configuration class
C AOExternalSampleClock | External Sample Clock Configuration Class
C AOTrigger | Constructor to create an AOTrigger task object
C AODigitalTrigger | AO Digital trigger
C AOSignalExport | AO Signal Export Class
C JY5113CITask | JY5113 Counter Input Task
C CISampleClock | CI Sample Clock class
C CIInternalSampleClock | CI Internal Sample Clock Configuration Class
C CIImplicitSampleClock | CI Implicit Sample Clock class
C CIExternalSampleClock | CI Implicit Sample Clock class
C CIExternalTimebase |
C CITimebase |
C EdgeCounting | Configure CI EdgeCounting
C EdgeCountingOutEvent | Edge counting output event configuration class
C PauseTrigger | Pause trigger configuration class
C FrequencyMeas | Configure CI Measure
C PeriodMeas | Configure CI Measure
C PulseMeas | Configure CI Measure
C SemiPeriodMeas | Configure CI Measure
C TwoEdgeSeparation | Configure CI Measure
C QuadEncoder | Configure CI Measure
C TwoPulseEncoder | Configure CI Measure
C CITrigger | Constructor to create an CITrigger task object
C CIDigitalTrigger | CI Digital trigger
C CISignalExport | CI Signal Export Class
C JY5113COTask | JY5113 Counter Output Task
C COTrigger | Constructor to create an COTrigger task object
C CODigitalTrigger | CO Digital trigger
C COPulse | Pulse Parameter
C COExternalTimebase |
C COTimebase |
C COSignalExport | CO Signal Export Class
C JY5113DITask | JY5113 Digital Iuput Task
C DIChannel | DI Channel parameter class
C DISampleClock | Sample clock configuration class
C DIExternalSampleClock | External Sample Clock Configuration Class
C DISignalExport | DI Signal Export Class
C DITrigger | Constructor to create an DITrigger task object
C DIDigitalTrigger | DI Digital trigger
C JY5113DOTask | JY5113 Digital Output Task
C DOChannel | DO Channel parameter class
C DOSampleClock | Sample clock configuration class
C DOExternalSampleClock | External Sample Clock Configuration Class
C DOTrigger | Constructor to create an DOTrigger task object
C DODigitalTrigger | DO Digital trigger
C DOSignalExport | DO Signal Export Class